SENT: 530 SMTP authentication is required.

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-01-26 22:23

Please bear with me, I am learning HMailserver as I go along.

I have read a number of SMTP authentication log messages on this forum but haven't found my particular issue yet, so thought I would ask the experts.

I recently (about two months or so ago) upgraded my Hmailserver to version 5.6-B2145 on a Windows 2008 server. Since then I have had one particular problem.
One of my clients uses 1and1's Exchange server package for a select few of his users: A, B and C. Lets call the domain wmo.com
All the other users of the wmo.com domain are accounts on my HMailserver. They can all send and receive emails no problem at all, both to each other and the world in general.
A, B and C have recently found they cannot email each other. Nor can they send to any account at all on my HMailserver.
When I start HMS logging and send from one of the affected accounts to my own email address (which works perfectly normally, and I have indicated as tmbi@myaccount.com below) I see the following reports on HMS:


"SMTPD" 2508 866177 "2015-01-26 18:24:17.619" "212.227.126.131" "SENT: 220 mail.tmbi.co.uk ESMTP"
"SMTPD" 2532 866177 "2015-01-26 18:24:17.650" "212.227.126.131" "RECEIVED: EHLO mout.kundenserver.de"
"SMTPD" 2532 866177 "2015-01-26 18:24:17.650" "212.227.126.131" "SENT: 250-mail.tmbi.co.uk[nl]250-SIZE[nl]250 AUTH LOGIN"
"SMTPD" 2476 866177 "2015-01-26 18:24:17.681" "212.227.126.131" "RECEIVED: MAIL FROM:<A@wmo.com>"
"SMTPD" 2476 866177 "2015-01-26 18:24:17.681" "212.227.126.131" "SENT: 250 OK"
"SMTPD" 2700 866177 "2015-01-26 18:24:17.712" "212.227.126.131" "RECEIVED: RCPT TO:<tmbi@myaccount.com>"
"SMTPD" 2700 866177 "2015-01-26 18:24:17.712" "212.227.126.131" "SENT: 530 SMTP authentication is required."
"SMTPD" 2508 866177 "2015-01-26 18:24:17.744" "212.227.126.131" "RECEIVED: QUIT"
"SMTPD" 2508 866177 "2015-01-26 18:24:17.744" "212.227.126.131" "SENT: 221 goodbye"
"SMTPD" 2508 866188 "2015-01-26 18:24:17.931" "212.227.15.32" "SENT: 220 mail.tmbi.co.uk ESMTP"
"SMTPD" 2476 866188 "2015-01-26 18:24:17.962" "212.227.15.32" "RECEIVED: EHLO mout-bounce.kundenserver.de"
"SMTPD" 2476 866188 "2015-01-26 18:24:17.962" "212.227.15.32" "SENT: 250-mail.tmbi.co.uk[nl]250-SIZE[nl]250 AUTH LOGIN"
"SMTPD" 2704 866188 "2015-01-26 18:24:17.978" "212.227.15.32" "RECEIVED: MAIL FROM:<>"
"SMTPD" 2704 866188 "2015-01-26 18:24:18.102" "212.227.15.32" "SENT: 250 OK"
"SMTPD" 2572 866188 "2015-01-26 18:24:18.118" "212.227.15.32" "RECEIVED: RCPT TO:<A@wmo.com>"
"SMTPD" 2572 866188 "2015-01-26 18:24:18.118" "212.227.15.32" "SENT: 250 OK"
"SMTPD" 2700 866188 "2015-01-26 18:24:18.149" "212.227.15.32" "RECEIVED: DATA"
"SMTPD" 2700 866188 "2015-01-26 18:24:18.149" "212.227.15.32" "SENT: 354 OK, send."
"SMTPD" 2148 866188 "2015-01-26 18:24:19.881" "212.227.15.32" "SENT: 250 Queued (1.728 seconds)"
"SMTPD" 2704 866188 "2015-01-26 18:24:19.912" "212.227.15.32" "RECEIVED: QUIT"
"SMTPD" 2704 866188 "2015-01-26 18:24:19.912" "212.227.15.32" "SENT: 221 goodbye"
"APPLICATION" 2368 "2015-01-26 18:24:19.974" "SMTPDeliverer - Message 6588391: Delivering message from <Empty> to A@wmo.com. File: D:\Email Store\{414ED0C5-8ADD-4AE6-A453-6EDB2EF6328B}.eml"
"APPLICATION" 2368 "2015-01-26 18:24:20.068" "SMTPDeliverer - Message 6588391: Message delivery thread completed."

HMailserver sends a non delivery message to the sender's email account.

(I'm not sure if it is important or not but it seems to dump the affected email into the root folder D:\Email Store\)

If I create a new account on wmo.com on my HMailserver then the users can send from that account no problem at all.

After reading everything it seems that 1and1 are not authenticating to HMailserver's satisfaction. I have tried a number of different settings, but the only one I have found that works so far is to uncheck the 'Local to local e-mail addresses' box under Settings>Advanced>IP Ranges>Internet - I then sent a test email from one of the affected accounts and it arrived OK.

However, I am now concerned that this might open up my server to sending spam messages if somebody spoofed a local email address and used my server to send spam, if they didn't need authentication.
Am I being paranoid, naive or just thick? As I said earlier I am still learning, and much of this is taking a while for me to get my head around.

Many thanks in advance

Tosh
If you want people to learn, use small words and big letters.

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SENT: 530 SMTP authentication is required.

Post by mattg » 2015-01-27 01:09

I'm guessing that you have a route for wmo.com

What are your route settings?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-01-27 02:44

I'm not sure what you mean. Do you mean under Settings>Protocols>SMTP>Routes? If so there is nothing present.

Thanks

tmbi
If you want people to learn, use small words and big letters.

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SENT: 530 SMTP authentication is required.

Post by mattg » 2015-01-27 11:48

tmbi wrote:One of my clients uses 1and1's Exchange server package for a select few of his users: A, B and C. Lets call the domain wmo.com
All the other users of the wmo.com domain are accounts on my HMailserver. They can all send and receive emails no problem at all, both to each other and the world in general.
A, B and C have recently found they cannot email each other. Nor can they send to any account at all on my HMailserver.
Then yes you should create a route for that domain.

Sender should be a remote address, and the recipient should be a local address ( I think!!)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-01-27 12:14

Thanks for that

So I should create a route like this?
Domain > wmo.com
Target SMTP host > tmbi.co.uk
TCP/IP port > 25
Treat sender as > A remote email address
Treat recipient as > A local email address

If that's correct I'll do it.

Did you have any thoughts on my concern for unchecking the SMTP authentication for local to local e-mail addresses? Does that open me up to spamming (even just within my own server)?

Many thanks for your help on this
If you want people to learn, use small words and big letters.

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SENT: 530 SMTP authentication is required.

Post by mattg » 2015-01-27 12:56

tmbi wrote:So I should create a route like this?
Domain > wmo.com
Target SMTP host > tmbi.co.uk
TCP/IP port > 25
Treat sender as > A remote email address
Treat recipient as > A local email address
Domain > wmo.com
Target SMTP host > 1and1's Exchange server
TCP/IP port > 25
Treat sender as > A remote email address
Treat recipient as > A local email address
tmbi wrote:Did you have any thoughts on my concern for unchecking the SMTP authentication for local to local e-mail addresses? Does that open me up to spamming (even just within my own server)?
Yes that will get you a heap more SPAM to your local users. Try not to do that
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-01-27 19:55

OK. I created that route, and then unchecked the 'Local to local e-mail addresses' box under Settings>Advanced>IP Ranges>Internet but now I'm back to where I started.

I can only think the 1and1 exchange server address must be wrong, or maybe I am using the wrong port now.

I have used 1.exchange.1and1.eu as described on 1and1's setting up exchange help page. http://bit.ly/1uxUr94 - I see that uses https to connect so presumably might use a different port number for SMTP?

I did see a message from Google saying they had detected an unusual amount of unsolicited email from my server for a period around 3pm today but that seems to have stopped now.

Thanks for your help with this.
If you want people to learn, use small words and big letters.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: SENT: 530 SMTP authentication is required.

Post by percepts » 2015-01-27 20:18

If mail from this exchange server of your clients is always coming from same IP (never having used exchnage I don't know if thats the case) then create an IP-Range for just that IP with higher priority than internet range and don't use authentication on local to local or local to external.

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-01-28 02:31

OK, I tried pinging that server and then took its IP and created an IP Range (wasn't sure if 1 is higher than 2 so tried both ways ) but no joy so far. I suspect I might have the wrong server listed. I'll keep checking and trying.

Thanks for your help on this. Looks like the unsolicited mail issue has gone away at least. :-)
If you want people to learn, use small words and big letters.

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SENT: 530 SMTP authentication is required.

Post by mattg » 2015-01-28 02:49

for a new IP range to take precedence it needs to be higher

Internet default is 10
Autoban creates ranges with priority of 20

For an IP range to be effective it should be higher than 20, ie 25
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-02-09 19:26

Well, I'm still struggling with this. It looks as though the server IP is changing all the time, but even so, when I set everything to the current server IP it fails.

I think I must be either using the wrong server, the wrong server IP, or looking in the wrong place completely. I'm sure this issue must have come up before now, it's just a matter of finding out the correct solution. :-(

I'll keep you posted on developments.

Thanks for all your help.
If you want people to learn, use small words and big letters.

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SENT: 530 SMTP authentication is required.

Post by mattg » 2015-02-10 00:58

tmbi wrote:One of my clients uses 1and1's Exchange server package for a select few of his users...
Have you asked why the client does this?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-02-10 17:06

Finally sorted this out.

There are a number of different SMTP servers handling 1and1's email, and we were so close.
I eventually had to find all the IP addresses that 1and1 use for outgoing mail and add them into the Settings>Advanced>IP Ranges as a series of different entries (they were not concurrent)
Once I had done that it appears to have resolved the issue. The fact that the IPs were changing was causing emails to be delivered only sporadically, now it appears to be fine.

Many thanks to you both for your extremely helpful advice and also to Mark at Cosella Consulting for his invaluable assistance today.

Took me a while but I learned a thing or two from this. Thanks chaps.

:-)
If you want people to learn, use small words and big letters.

tmbi
New user
New user
Posts: 8
Joined: 2015-01-26 19:38

Re: SENT: 530 SMTP authentication is required.

Post by tmbi » 2015-02-10 20:21

mattg wrote:
tmbi wrote:One of my clients uses 1and1's Exchange server package for a select few of his users...
Have you asked why the client does this?
It's a legacy thing. He started off with this system quite some time ago (before I was involved) and although it's not ideal he prefers to keep the system in place for the time being as it enables him to do certain things.
We are slowly moving away from 1and1 to be honest and looking at much more integrated services without the pain that 1and1 brings to the party, but it is a slow process.
Hopefully we will be able to eventually drop them completely but only once we are happy that he can do all the things he requires without any grief from his staff or loss of functionality.

Cheers
If you want people to learn, use small words and big letters.

Post Reply