hMailAdmin.exe unable to connect to specified server

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-29 04:18

After struggling all afternoon on this, the sun has finally faded on the wonderful idea of hosting my own email for my great domain. For today at least.
I followed the tutorials to the letter and many times over. Not only did I try various ones I found across the internet, but I actually got quit good at the process.

I finally created a data base depsite my thinking I did the same thing each time and still somehow got it wrong.(uninstalled the 64 bit wamp and tried the 32 bit wamp fixed it)
I took a break, did yet another clean install (finally using 32 wamp instead of 64 bit version)and Viola, it got past the part of creating the database named hmailsever.

The next step was the hmailadmin.exe and connecting to something yet again called a server.
It has been suggested that Administraor was the default user name and the passwortd I created when I fist launched or installed hmailserver was the onme to connect me to the specified server, SO I AM GUESSING IT NOT A ALTERNATIVE AUTHORIZATION. haha.

Besides, I tried every username and password I am aware of nothing works. It must be referring to Administrator/password I just created.
Windows Firewall and antivirus on or off didn't matter and I seem to recal the first time I ran the installer, Windows asked me if I wanted to allow hmailserver through the firewall.
Funny how it didn't ask me that again despite the many times I re-installed it.

Is there something I am missing in using wamp to manage hmailserver?
Some of you, may cry, it is a sacrifice I am willing to make.
If one of you say "Dont tell him anything!" I shall have to make you cry as well.
lol
seriously, what the crap is it that could be broken here?
hmailadmin.jpg
Incidentally, Nothing I could possibly google brought me the answer to this.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: hMailAdmin.exe unable to connect to specified server

Post by percepts » 2014-12-29 06:06

Firstly WAMP is nothing to do with hMailserver. WAMP is a web server and not a mailserver.

So you must get hmailserver installed and working by itself using an email client such a outlook or thunderbird first. And using your domain which means you must have setup your dns. What is your domain name ?

Then you must get your WAMP server setup and test its working using yoru domain name (which is not supported by us here.)

Then when you have got both hmail and your web server working properly you can install the PHPWebAdmin web application which runs on your web server. BUT NOT UNTIL YOU HAVE PROVED HMAILSERVER AND YOUR WEBSERVER ARE WORKING PROPERLY.

Now uninstall hmailserver. Then delete the hmailserver install directory and everything in it. Then drop the hmailserver db schema.

Then I assume you are wanting to use MySQL since you are trying to use WAMP.

So then install hmailserver fresh again and select MySQL as your DB.

Assuming you do all that correctly then it WILL work. And don't tell me you have already done that because I'm not interested. If you had done it correctly then it would be working.

And read each install step instructions carefully. The first password you are asked for is your Administrator password. When it goes into the DB setup the first password it asks for the same as first one, The next one is password for your DB schema.

And finally if you are using 64bit MySQL then read following before starting hmailserver install.

viewtopic.php?f=21&p=170483&sid=de0c156 ... 7d#p170483 (read d: as drive:)

And note that your WAMP install should be on same server as hmailserver if you want to use PHPWebAdmin. And DCOM service must be running.

And you can't spell Administrator :roll:

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-29 07:42

Why is it tutorials assume we know everything and when we go to ask about anything we are presumed to know nothing.
Typos aside, I have no idea what you are trying to say about anything else.

No matter what I have tried during the install, it fails to connect to the specified server.
My domain name(s) aside, localhost means localhost to me.
Since I dont know to what port hmailadmin is trying to connect to, I assume it knows and that it isnt port 80 because it doesnt matter if I have my server running on it or not, firewall up or not, antivirus on or off, and since I did try it with and without the built in server and the microsoft sql server compact enu 3.5 it offers, the closest I get to getting it right , is the error msg "unable to connect to the specified server", but I know your not interested.
So what is the specified server if it isnt the localhost that I may have already running or the one its trying to run?
I get the same error no matter. I would think before I can get it to run from a domain I should be able to see it run from localhost.

Any tutorial I followed seems to show it is simple enough for a caveman to do it.
including this one.
http://youtu.be/K99lmchhy2g?t=1m32s

regardless, it seems like you just want me to piss off.
That's fine, I was thinking this would be fun and easy like all the tutorials indicate . My bad.
Thanks for trying to help me.

Perhaps I should make a video of my installing it so you can see first hand what exactly I am doing or not doing.
Would that interest you, I wonder.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-29 08:27

http://goo.gl/G0C3x6

There is the link to the video that I made just for you.. I hope you like it and that you have a facebook account. You will need one to view it as I would never put something like this on my YT account. I know its not something you'd be interested in watching but I did it anyway. It will show you three possible installs and two uninstalls. I spared you the last uninstall. Your welcome. Also, if you have any means to listen to music while you play this video, I suggest you do that because it has no audio.
Enjoy!

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-29 08:51

I'm getting it now, it doesnt run html on port 80 but connects on 25,110,143 and 587 all typical email ports..
I'm still stuck for what I do next. And what a specified server is. I can also see that none of these ports have active sockets.
I was really hoping this would be more easy to set up.
Tomorrow is another day.

User avatar
jimimaseye
Moderator
Moderator
Posts: 7477
Joined: 2011-09-08 17:48

Re: hMailAdmin.exe unable to connect to specified server

Post by jimimaseye » 2014-12-29 14:00

See your PM messages for further offers of help.
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: hMailAdmin.exe unable to connect to specified server

Post by percepts » 2014-12-29 18:25

stop the hmailserver service then Telnet your server on the ports 25, 110 and 143 to check whether another server is listening on them.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 02:27

Does it run on Windows 8.1 Pro?

All I get is error "unable to connect to specified server."

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: hMailAdmin.exe unable to connect to specified server

Post by percepts » 2014-12-30 02:34

have you done what I said ?

Are your permissions correct ?

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 03:15

not sure what you mean by telnet, but hmailserver is running on 25,110,143 and 587.

I installed the built in server but used my own mysql and it did succeed in creating a database.
My other Apache xammp server is running on port 8080. I forwarded 8080 and now 80 to my 192 address.

As far as permissions goes, I am on windows 8.1 pro.
I have tried installing in Program Files (x86) folder which is tight but I can work through it if I need a file change or not.
I have tried installing within a htdocs or www of my existing server(s) both wamp and now xampp.
Lastly I have it in my C:/ which I am sure it can write to itself if it has to.
Still, hMailAdmin.exe is "unable to connect to specified server".

What is the specified server, what port, and what specific permissions?

Does hMailServer 5.6 - Build 2145 run on Windows 8.1 Pro?

User avatar
SorenR
Senior user
Senior user
Posts: 2601
Joined: 2006-08-21 15:38
Location: Denmark

Re: hMailAdmin.exe unable to connect to specified server

Post by SorenR » 2014-12-30 03:38

lordfarquadd wrote:Does it run on Windows 8.1 Pro?

All I get is error "unable to connect to specified server."
I just installed the latest version with the Microsoft SQL CE database in "C:\hMailServer" on my Windows 10 Build 9879 and it runs perfectly - so far ... :wink:

Either your hmailserver service is not running or your COM/DCOM permissions have a problem.

"Server" is a Dell D610 Laptop (Pentium M 1.6 GHz, 2 GB RAM) :twisted:
SørenR.

The quantum rule of insecurity which states that the act of observing how vulnerable a host or service is changes the insecurity level of the service.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: hMailAdmin.exe unable to connect to specified server

Post by percepts » 2014-12-30 04:04

Or something else is listening on port 25 but since he doesn't do what I ask and give answers to questions there's no point in trying to help.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:11

Ya there is, the point is trying to get me to understand.. Help me.

hmail is running on port 25.
How do I check and change COM.DCOM pernmissions?
Last edited by lordfarquadd on 2014-12-30 04:15, edited 1 time in total.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:14

I dont understand telnet except for Through Telnet, an administrator or another user can access someone else's computer remotely.remote.
Yours is the first mention of it so I am sorry I cannot comply.

as far as netstat, hmailserver is using it and the other ports mentioned.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:22

Found this
Start DCOM config by selecting Start, Run, enter dcomcnfg.exe and press OK.
In the Component Services program, expand the Component Services folder
Expand down to Computers | My Computer | DCOM Config
Right-click on hMailServer and select properties
Select the Security tab
Under "Launch and Activation Permissions", select Customize and click on Edit
Under "Group or user names", click Add
For IIS6: add the built-in anonymous IIS user account
For Apache: add the Apache user account
Set the Local Launch and Local Activation permissions for this user to Allow

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: hMailAdmin.exe unable to connect to specified server

Post by percepts » 2014-12-30 04:23

what netstat command did you use ?

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:38

ya nah nope, beings I am the admin, and the admin has full control on all aspects as far as I can see in those properties pages, when I run hmailadmin as admin and click through the user control bs, I would expect that I have permission for something somewhere to be changed or at the very least accessed.

Ahh I know something I can check..
I shall port forward all those other ports incase its trying to access through that depsite it saying localhost.

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:44

nope that didnt work either.

You guys must know something I dont.
What is it?

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:49

percepts wrote:what netstat command did you use ?
xampp has a netstat window that show hmailserver by name.
in my cmd I used -a parameter as well as others..
It's like you are trying to tell me something?

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-30 04:51

percepts wrote:Or something else is listening on port 25 but since he doesn't do what I ask and give answers to questions there's no point in trying to help.

hmailserver is listening on port 25 atm..
not sure what port I am using atm though..lol

User avatar
mattg
Moderator
Moderator
Posts: 19000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailAdmin.exe unable to connect to specified server

Post by mattg » 2014-12-30 09:11

lordfarquadd wrote:seriously, what the crap is it that could be broken here?
hmailadmin.jpg
Incidentally, Nothing I could possibly google brought me the answer to this.
You need to spell 'Administrator' correctly
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

eMilt
Normal user
Normal user
Posts: 35
Joined: 2008-06-12 11:14

Re: hMailAdmin.exe unable to connect to specified server

Post by eMilt » 2014-12-30 15:45

Unreadable in your screenshot but in your video I see "locahost" under Host name, not "localhost", so there's an "l" missing there.

User avatar
jimimaseye
Moderator
Moderator
Posts: 7477
Joined: 2011-09-08 17:48

Re: hMailAdmin.exe unable to connect to specified server

Post by jimimaseye » 2014-12-30 17:21

Lord.....
...hmailadmin is trying to connect to the database. If you have installed a MySQL database then it is on port 3306 or 3307 (whatever you set it at). Have you checked your hmailserver.ini database to ensure it is pointing to the right port? Have you checked that the MySQL database is running ("net start MySQL")? If uyou launch the MySQL Workbench and then try to connect to the 'local instance MySQL', does it allow you? (Remember there are 2 'servers' going on: one is Hmailserver the MAIL server and the other is the database running on the MySQL server (service). You first screenshot shows HMS not being able to connect to this 'server'/service and this is why I say to you the above. Once you have that all working and able to log in to Hmailadmin, then you could concentrate on your other problems (wamp, smtp port connections etc).
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

lordfarquadd
New user
New user
Posts: 14
Joined: 2014-12-29 03:39

Re: hMailAdmin.exe unable to connect to specified server

Post by lordfarquadd » 2014-12-31 03:16

I finally got past it.
I am not sure exactly what I did differently, but between all the typos and root passwords..
It seems the password I was using generated by phpmyadmin had too many characters for every body else which I found is a 15 character limit.

But, ya localhost and administrator were put there wrong by default, or so it seemed to me at the time, however, I did one last re-install from the top and I did see it was spelled correctly that time. Odds are it was the root pw thing that kept doing me in.
Strange how it could create a database named hmailserver in one part but not be able to connect in another.
I can't speak for the built in Microsoft database thinger.

Its all good now though, I am looking at the hmailadmin.exe

I can't wait to move forward from there and see what this baby can do with my domain's POP account.

BTW, some of you seem to have a bad attitude towards me and I don't know exactly why.
If you are the owner creator or god, perhaps you shouldn't answer your own calls anymore, and let someone else do it for you js.
You're not the only one who's ever been burnt out, learn to recognize the signs, while I will learn to spell check.

I hope I can post again sometime soon.
Great concept, great forum.

User avatar
jimimaseye
Moderator
Moderator
Posts: 7477
Joined: 2011-09-08 17:48

Re: hMailAdmin.exe unable to connect to specified server

Post by jimimaseye » 2014-12-31 11:49

Glad its now going for you Lord, its a great feeling to see it running for te first time.

It will handle your POP mail account great - that is currently how Ive opted to handle our mail (it naturalky means a backup of your emaoil - 1, on the pop account by your provider and 2, a local copy in your hmailserver.

Have fun with it.

p.s Dont worry about the grumps, Its nothing personal to you, it happens a lot to many.
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

Post Reply