smtp settings required to use hMailServer from IOT device

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
Erez.Mor
New user
New user
Posts: 3
Joined: 2023-06-07 11:02

smtp settings required to use hMailServer from IOT device

Post by Erez.Mor » 2023-06-07 11:38

Hi all
I'm new to hMailServer, So please bear with me...
I managed to install and configure the server, And I can send emails TO an address and see it received on server side.
My end goal however is to use it to send/receive emails from a remote camera. The camera has a simple configuration page for sender email + password + smtp server (domain + port).
How and what do I need to configure inside hMailServer, And which settings do I need to provide in the SMTP configuration on my camera?
Any combination i tried so far doesnt work..

Thanx in advance,
Erez

User avatar
johang
Senior user
Senior user
Posts: 1105
Joined: 2008-09-01 09:20

Re: smtp settings required to use hMailServer from IOT device

Post by johang » 2023-06-07 18:03

Erez.Mor wrote:
2023-06-07 11:38
Hi all
I'm new to hMailServer, So please bear with me...
I managed to install and configure the server, And I can send emails TO an address and see it received on server side.
My end goal however is to use it to send/receive emails from a remote camera. The camera has a simple configuration page for sender email + password + smtp server (domain + port).
How and what do I need to configure inside hMailServer, And which settings do I need to provide in the SMTP configuration on my camera?
Any combination i tried so far doesnt work..

Thanx in advance,
Erez
is this inside your own lan or on internet ?

do you have your own registered domain ? this should then be straight forward... have you openend all necessary ports

or not a registered domain so you are forced to use IPadresses to point your camera to the server ?

in your hmailserver, have you configured your log so you can read what is happening SMTP wise


generally, your hmailserver should be installed with IPranges on default settings.... in your hmailserver you add a user in a domain ( registered or unregistered domain will need different approach ) .. and you use the credentials of that user in your remote camera to lconnect via smtp to your hmailserver and "send emails" to either an account in your hmailserver ( or externally depending on your setup ).. the SMTP settings for the camera to use specifically would be the IPadress of your hmailserver.. Or if you have a registered domain name.. the hostname of your hmailserver.
lets cheat darwin out of his legacy, find a cure for cancer...

User avatar
jim.bus
Senior user
Senior user
Posts: 1542
Joined: 2011-05-28 11:49
Location: US

Re: smtp settings required to use hMailServer from IOT device

Post by jim.bus » 2023-06-07 20:42

johang covered most of what I was going to say.

But additionally, I would add that the camera is basically connecting to hMailServer as an email client. As such the 'email client' should be submitting email on Port 587 preferred or Port 465 not preferred. To that extent then your hMailServer TCPIP settings should include Port 587 with Security Connection 'StartTLS Optional' or Port 465 with Security Connection SSL/TLS, or both Ports with the same Security Connections indicated. Your camera settings didn't seem to allow you to indicate what the Security Connection would be which would then mean you should probably use Port 587 since you wouldn't need to provide a Secure Connection with Port 587.
If you think you understand quantum mechanics, you don't understand quantum mechanics.

Erez.Mor
New user
New user
Posts: 3
Joined: 2023-06-07 11:02

Re: smtp settings required to use hMailServer from IOT device

Post by Erez.Mor » 2023-06-15 23:19

Hi
Sorry for the delay...
To your questions, This is over the internet, And I'm using my own domain.

Eventually all is working now - It was a port issue after all.
Thanx for the suggestions,
E.

Post Reply