Able to send mail outside but can't receive mail from outside

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
picho
New user
New user
Posts: 24
Joined: 2015-09-29 14:25

Able to send mail outside but can't receive mail from outside

Post by picho » 2019-02-19 15:59

Hullo Experts,

I am having trouble with my hmail server installation, ever since I set it up and I ran the diagnostics on my hmailserver setup and it passed the diagnostics successfully.

I am able to send emails out to external accounts and they are received but when I try to send emails to accounts hosted on my hmailserver, they never come through,

what could be the problem, I would be glad to receive your assistance because it is quite urgent

thx,
picho

picho
New user
New user
Posts: 24
Joined: 2015-09-29 14:25

Re: Able to send mail outside but can't receive mail from outside

Post by picho » 2019-02-19 17:00

Hullo experts more information on the problem I am facing

The error message I get when I try sending to my hmailserver account from gmail is
"the recipient server did not accept our requests to connect: gnereic:: failed_precondition: connect error (111) : Connection refused)

This bounced message appeared the following day after trying to reply to an email I sent from my hmailserver account to my gmail account

palinka
Senior user
Senior user
Posts: 1107
Joined: 2017-09-12 17:57

Re: Able to send mail outside but can't receive mail from outside

Post by palinka » 2019-02-19 17:07

Connection refused
  • Your ISP blocks port 25 incoming
  • Your LAN firewall is blocking port 25 incoming
  • Your server's software firewall is blocking port 25 incoming
  • Some other software is blocking or using port 25 incoming
Something in between gmail and hmailserver is blocking your incoming connection on port 25.

picho
New user
New user
Posts: 24
Joined: 2015-09-29 14:25

Re: Able to send mail outside but can't receive mail from outside

Post by picho » 2019-02-19 18:19

Hullo Palinka,

My ISP allows incoming and outgoing port 25 on firewall
My windows server firewall allows both incoming and outgoing port 25 traffic
I have no LAN firewall
The router is configured to allow all traffic.

And I don't have any software using port 25

I really don't know what is blocking the traffic

palinka
Senior user
Senior user
Posts: 1107
Joined: 2017-09-12 17:57

Re: Able to send mail outside but can't receive mail from outside

Post by palinka » 2019-02-19 23:02

picho wrote:
2019-02-19 18:19
Hullo Palinka,

My ISP allows incoming and outgoing port 25 on firewall
My windows server firewall allows both incoming and outgoing port 25 traffic
I have no LAN firewall
The router is configured to allow all traffic.

And I don't have any software using port 25

I really don't know what is blocking the traffic
Are you sure your mx records point to your hmailserver?

User avatar
mattg
Moderator
Moderator
Posts: 20131
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Able to send mail outside but can't receive mail from outside

Post by mattg » 2019-02-20 02:44

Does your router forward mail ports to your hMailserver?

https://www.hmailserver.com/documentati ... om_outside
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

picho
New user
New user
Posts: 24
Joined: 2015-09-29 14:25

Re: Able to send mail outside but can't receive mail from outside

Post by picho » 2019-02-20 08:42

Yes Mattg,

The technician who set up the cisco 1841 router opened up all ports on the router and therefore the router is not restricting any traffic, the configuration is as below:
Current configuration : 3208 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname UDC-ROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$pZit$oUTB7tVwuND03QwahkEYO1
!
aaa new-model
!
!
!
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.150.1 192.168.150.10
!
ip dhcp pool Voice
!
ip dhcp pool Lan
network 192.168.150.0 255.255.255.0
default-router 192.168.150.4
domain-name write
!
ip dhcp pool servers
network 192.168.0.0 255.255.255.0
default-router 192.168.0.7
domain-name write
!
ip dhcp pool cctv
network 192.168.110.0 255.255.255.0
default-router 192.168.110.254
!
ip dhcp pool user_data
network 192.168.120.0 255.255.255.0
default-router 192.168.120.254
dns-server 41.221.81.132 197.221.148.22
domain-name write
!
ip dhcp pool voice
network 192.168.130.0 255.255.255.0
default-router 192.168.130.254
!
ip dhcp pool corperate_wifi
network 192.168.140.0 255.255.255.0
default-router 192.168.140.254
domain-name write
!
!
no ip domain lookup
ip domain name udc.go.ug
ip name-server 41.221.81.132
ip name-server 197.221.148.22
multilink bundle-name authenticated
!
!
username local privilege 15 secret 5 $1$kbwp$kNdX6qn8eAAF7WkT2XQDC0
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 41.221.91.26 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.150.4 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1.1
description sub_servers
encapsulation dot1Q 10
ip address 192.168.0.7 255.255.255.0
!
interface FastEthernet0/1.2
description sub_cctv
encapsulation dot1Q 110
ip address 192.168.110.254 255.255.255.0
!
interface FastEthernet0/1.3
description sub_user_data
encapsulation dot1Q 120
ip address 192.168.120.254 255.255.255.0
!
interface FastEthernet0/1.4
description sub_voice
encapsulation dot1Q 130
ip address 192.168.130.254 255.255.255.0
!
interface FastEthernet0/1.5
description sub_corperate_wifi
encapsulation dot1Q 140
ip address 192.168.140.254 255.255.255.0
!
ip default-gateway 41.221.91.25
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 41.221.91.25
!
!
no ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source list 2 interface FastEthernet0/0 overload
ip nat inside source list 3 interface FastEthernet0/0 overload
ip nat inside source list 4 interface FastEthernet0/0 overload
ip nat inside source list 5 interface FastEthernet0/0 overload
ip nat inside source list 6 interface FastEthernet0/0 overload
ip nat inside source list 7 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.150.0 0.0.0.255
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 3 permit 192.168.110.0 0.0.0.255
access-list 4 permit 192.168.120.0 0.0.0.255
access-list 5 permit 192.168.130.0 0.0.0.255
access-list 6 permit 192.168.140.0 0.0.0.255
access-list 7 permit 192.168.160.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
transport input all
!
scheduler allocate 20000 1000
end

The router public IP is 41.221.91.26 and you can see that NAT has been enabled, my hmailserver IP on the LAN is 192.168.150.13

So I can't figure out what could be blocking the mails

User avatar
jimimaseye
Moderator
Moderator
Posts: 8131
Joined: 2011-09-08 17:48

Re: Able to send mail outside but can't receive mail from outside

Post by jimimaseye » 2019-02-20 09:56

That router configuration list doesnt show anything that proves port forwarding is set. It only shows that the internal LAN ip ranges have access to send OUT.

You need port forwarding FROM OUTSIDE forwarding to your hmailserver.
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
mattg
Moderator
Moderator
Posts: 20131
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Able to send mail outside but can't receive mail from outside

Post by mattg » 2019-02-20 10:25

And port forwarding is different than opening ports
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

picho
New user
New user
Posts: 24
Joined: 2015-09-29 14:25

Re: Able to send mail outside but can't receive mail from outside

Post by picho » 2019-02-20 10:29

Thank you Jimmisaye,

Will contact the technician to configure the router to enable port forwarding so that mails can come through,

will post an update when this is done,

thanks,

User avatar
SorenR
Senior user
Senior user
Posts: 3190
Joined: 2006-08-21 15:38
Location: Denmark

Re: Able to send mail outside but can't receive mail from outside

Post by SorenR » 2019-02-20 15:58

You would need something like ...

Code: Select all

static (inside,outside) tcp interface smtp 192.168.0.50 smtp netmask 255.255.255.255 
static (inside,outside) tcp interface imap4 192.168.0.50 imap4 netmask 255.255.255.255 
It's from my (very) old Cisco ASA5505 however it may not fit your 1841... Time to dig out the IOS manual for your router.
SørenR.

“With age comes wisdom, but sometimes age comes alone.”
- Oscar Wilde

Post Reply