Emails are not going to gmail, live extra from hmail server.

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Emails are not going to gmail, live extra from hmail server.

Post by itsmesri » 2014-11-07 08:44

I am having an issue sending emails from hmail server (from my domain) to gmail, live ,yahoo , etc from hmail server. Initially I thought My IP address is blocked, then I moved my email server to different ip address. Issue again the same. Looks like hmail server is send email to these services. but I am not seeing these email in inbox and not bouncing back to hmailserver also.

I don't understand why this is happening. I just started a small company.

I can receive emails from these services (gmail, live, yahoo) to my domain account. I am using in hmail (domain) email id as pop3 in gmail account, so I can see email from any another email service. But I can not send from my domain email id to these services.

Domain: intensifytech.com
IP Address: 99.78.126.17
"SMTPD" 3984 158 "2014-11-07 00:13:43.321" "74.125.82.53" "SENT: 220 Welcome message from SMTP"
"SMTPD" 6008 158 "2014-11-07 00:13:43.451" "74.125.82.53" "RECEIVED: EHLO mail-wg0-f53.google.com"
"SMTPD" 6008 158 "2014-11-07 00:13:43.451" "74.125.82.53" "SENT: 250-MALTESE[nl]250-SIZE 20480000[nl]250 AUTH LOGIN"
"SMTPD" 5992 158 "2014-11-07 00:13:43.571" "74.125.82.53" "RECEIVED: AUTH LOGIN"
"SMTPD" 5992 158 "2014-11-07 00:13:43.581" "74.125.82.53" "SENT: 334 VXNlcm5hbWU6"
"SMTPD" 5984 158 "2014-11-07 00:13:43.701" "74.125.82.53" "RECEIVED: c3JpQGludGVuc2lmeXRlY2guY29t"
"SMTPD" 5984 158 "2014-11-07 00:13:43.701" "74.125.82.53" "SENT: 334 UGFzc3dvcmQ6"
"SMTPD" 5984 158 "2014-11-07 00:13:43.821" "74.125.82.53" "RECEIVED: ***"
"SMTPD" 5984 158 "2014-11-07 00:13:43.941" "74.125.82.53" "SENT: 235 authenticated."
"SMTPD" 5976 158 "2014-11-07 00:13:44.073" "74.125.82.53" "RECEIVED: MAIL FROM:<xxx@intensifytech.com> SIZE=1017"
"SMTPD" 5976 158 "2014-11-07 00:13:44.103" "74.125.82.53" "SENT: 250 OK"
"SMTPD" 6016 158 "2014-11-07 00:13:44.227" "74.125.82.53" "RECEIVED: RCPT TO:<xxxxx@gmail.com>"
"SMTPD" 6016 158 "2014-11-07 00:13:44.237" "74.125.82.53" "SENT: 250 OK"
"SMTPD" 5960 158 "2014-11-07 00:13:44.357" "74.125.82.53" "RECEIVED: DATA"
"SMTPD" 5960 158 "2014-11-07 00:13:44.357" "74.125.82.53" "SENT: 354 OK, send."
"SMTPD" 3840 158 "2014-11-07 00:13:44.619" "74.125.82.53" "SENT: 250 Queued (0.234 seconds)"
"SMTPD" 5924 0 "2014-11-07 00:13:44.639" "TCP" "DNS - MX Lookup: gmail.com"
"SMTPD" 5924 0 "2014-11-07 00:13:44.699" "TCP" "DNS - MX Result: 5 IP addresses were found."
"SMTPD" 5968 158 "2014-11-07 00:13:44.750" "74.125.82.53" "RECEIVED: QUIT"
"SMTPD" 5968 158 "2014-11-07 00:13:44.750" "74.125.82.53" "SENT: 221 goodbye"
Help me this is urgent.

I read in some post. My email server needs Reverse DNS lookup. Is this the issue?If yes, How to setup that?

Please help me gurus

User avatar
mattg
Moderator
Moderator
Posts: 21267
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Emails are not going to gmail, live extra from hmail ser

Post by mattg » 2014-11-07 09:18

SMTPD is your mail server accepting the mail

Please show the SMTPC lines that follow on from that log snippet
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 15:24

I got this reply back from bounced email.
The following recipient(s) could not be reached:

Xxxxx@gmail.com
Error Type: SMTP
Remote server (64.233.168.27) issued an error.
hMailServer sent:
Remote server replied: 421 Cannot connect to SMTP server 64.233.168.27 (64.233.168.27:25), NB connect error 1460

Tried 5 time(s)
This is happening after I moved to new modem.

What changes I need take care to fix this issue?

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 15:59

These are SMTPC logs
"SMTPC" 5984 119 "2014-11-07 00:03:00.704" "64.233.168.27" "RECEIVED: 421 Cannot connect to SMTP server 64.233.168.27 (64.233.168.27:25), NB connect error 1460"
"SMTPC" 5984 119 "2014-11-07 00:03:00.704" "64.233.168.27" "SENT: QUIT"
"SMTPC" 1476 118 "2014-11-07 00:03:00.704" "64.233.168.27" "RECEIVED: 421 Cannot connect to SMTP server 64.233.168.27 (64.233.168.27:25), NB connect error 1460"
"SMTPC" 1476 118 "2014-11-07 00:03:00.704" "64.233.168.27" "SENT: QUIT"
"SMTPC" 5976 121 "2014-11-07 00:03:30.728" "64.233.185.26" "RECEIVED: 421 Cannot connect to SMTP server 64.233.185.26 (64.233.185.26:25), NB connect error 1460"
"SMTPC" 5976 121 "2014-11-07 00:03:30.728" "64.233.185.26" "SENT: QUIT"
"SMTPC" 5948 122 "2014-11-07 00:03:30.738" "64.233.185.26" "RECEIVED: 421 Cannot connect to SMTP server 64.233.185.26 (64.233.185.26:25), NB connect error 1460"
"SMTPC" 5948 122 "2014-11-07 00:03:30.748" "64.233.185.26" "SENT: QUIT"
"SMTPC" 5992 123 "2014-11-07 00:04:00.763" "74.125.22.26" "RECEIVED: 421 Cannot connect to SMTP server 74.125.22.26 (74.125.22.26:25), NB connect error 1460"
"SMTPC" 5992 123 "2014-11-07 00:04:00.764" "74.125.22.26" "SENT: QUIT"
"SMTPC" 5960 124 "2014-11-07 00:04:00.768" "74.125.22.26" "RECEIVED: 421 Cannot connect to SMTP server 74.125.22.26 (74.125.22.26:25), NB connect error 1460"
"SMTPC" 5960 124 "2014-11-07 00:04:00.769" "74.125.22.26" "SENT: QUIT"
"POP3D" 5948
I am using ATT Uverse service.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Emails are not going to gmail, live extra from hmail ser

Post by percepts » 2014-11-07 16:14

I would change your SPF to following

v=spf1 mx -all

BUT the 421 usually means service not available. When you moved router did your IP change ? If it did do you need to tell your gmail account about it (or other changes) since it looks like you are using their service for sending mail.

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 16:21

percepts wrote:I would change your SPF to following

v=spf1 mx -all

BUT the 421 usually means service not available. When you moved router did your IP change ? If it did do you need to tell your gmail account about it (or other changes) since it looks like you are using their service for sending mail.
Yes, IP address changed. But understand " you need to tell your gmail account about it "?? What mean? I am poor in this Email configurations changes.

Where should I change v=spf1 mx -all? you mean in godaddy. I did change.

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 17:14

Test: Collect server details
hMailServer version: hMailServer 5.4.1-B1951
Database type: MSSQL

Test: Test IPv6
IPv6 support is available in operating system.

Test: Test outbound port
SMTP relayer not in use. Attempting mail.hmailserver.com:25...
Trying to connect to host mail.hmailserver.com...
Trying to connect to TCP/IP address 46.163.109.39 on port 25.
ERROR: It was not possible to connect.

Test: Test backup directory
Backup directory D:\bkphmail is writable.

Test: Test MX records
Trying to resolve MX records for intensifytech.com...
Host name found: smtp.intensifytech.com
Host name found: mail.intensifytech.com

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain intensifytech.com...
Trying to connect to host smtp.intensifytech.com...
Trying to connect to TCP/IP address 99.78.126.17 on port 25.
Received: 220 Welcome message from SMTP.
Connected successfully.

Test: Test message file locations
Relative message paths are stored in the database for all messages.

Test: Test IP range configuration
No problems were found in the IP range configuration.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Emails are not going to gmail, live extra from hmail ser

Post by percepts » 2014-11-07 17:29

outgoing port 25 is blocked. Port forwarding on router for port 25 and/or isp has decided to block it.

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 17:39

percepts wrote:outgoing port 25 is blocked. Port forwarding on router for port 25 and/or isp has decided to block it.

Port forwarding test passed on ip port 25.

http://www.yougetsignal.com/tools/open-ports/

If ATT uverse blocking 25 port. What is the alternate solution to me? Please give me solutions. Ii is very important for my business run. I cannot send emails to clients.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Emails are not going to gmail, live extra from hmail ser

Post by percepts » 2014-11-07 18:09

If ATT uvers provide an outhoing relay you can use that. You must ask tem if they do and which port you need to use to send via it.
If they don't provide relay then you need to use a third party company such as no-ip or dyn-dns and you must ask them what they require.

But also check its not your firewall blocking port 25 outbound. And also check with ATT Uvers

itsmesri
Normal user
Normal user
Posts: 59
Joined: 2014-11-07 08:30

Re: Emails are not going to gmail, live extra from hmail ser

Post by itsmesri » 2014-11-07 18:47

percepts wrote:If ATT uvers provide an outhoing relay you can use that. You must ask tem if they do and which port you need to use to send via it.
If they don't provide relay then you need to use a third party company such as no-ip or dyn-dns and you must ask them what they require.

But also check its not your firewall blocking port 25 outbound. And also check with ATT Uvers

I disabled both firewall and av. Still the same.

Is there any documentation for no-ip or dyn-dns for hmailserver configuration?

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Emails are not going to gmail, live extra from hmail ser

Post by percepts » 2014-11-07 19:03

No, we do not support other companies, you must deal with them yourself.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Emails are not going to gmail, live extra from hmail ser

Post by percepts » 2014-11-07 19:14

You should contact ATT as I think they will provide you with a relay server which won't cost you anything.

You can then set your hmail server smtp / delivery of email settings to use that relay with the port that ATT will tell you.

And in your email clients use port 587 to send email (unless they've blocked that too but I doubt it).

User avatar
mattg
Moderator
Moderator
Posts: 21267
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Emails are not going to gmail, live extra from hmail ser

Post by mattg » 2014-11-08 04:13

itsmesri wrote:
percepts wrote:outgoing port 25 is blocked. Port forwarding on router for port 25 and/or isp has decided to block it.

Port forwarding test passed on ip port 25.

http://www.yougetsignal.com/tools/open-ports/
That test is for incoming on port 25, not outgoing

The test in hMailserver shows that port 25 outgoing is blocked
percepts wrote:You should contact ATT as I think they will provide you with a relay server which won't cost you anything.
+1
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

glenluo
Normal user
Normal user
Posts: 194
Joined: 2011-07-03 12:10

Re: Emails are not going to gmail, live extra from hmail server.

Post by glenluo » 2014-11-08 17:52

There is way to settle it:
Buy a cheap vps,install the hmailser on it,use it as a relay server,you can use 80 port for SMTP.

Then at your real mail server,send all email to relay server,you ISP can not block your ourgong 80 port.
At the real mail server,use global rule,
To contains: @
send using the route : your-relay-server-ip:80

Post Reply