Backup Mail server

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Backup Mail server

Post by bescher » 2013-02-14 16:57

I am using hmail as a backup mail server. I have told the primary that we have a backup.
and I have added domains and email addresses and have added my email address and password for authentication.
But whenever one comes in the primary server says authentication required. Do I need to add that persons (the receipient) email address and password to authentication instead of mine? That would be a royal pain in the ass

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: Backup Mail server

Post by Bill48105 » 2013-02-14 17:13

Hi. Did you follow this?
http://www.hmailserver.com/documentatio ... _mx_backup
Also look at this:
http://www.hmailserver.com/forum/viewto ... 45#p125845

Odds are you need to setup a route on your backup to your primary with SOME user/pass on it that way all mail flows using that one user/pass.. Bet that's the step you missed.
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Backup Mail server

Post by bescher » 2013-02-14 18:11

I did set up routes under smtp, I did tell the main mail server that therre was a incoming relay. I did setup DNS properly (mail at 15, secondary at 20)
I setup individual accounts. I did tell the secondary that it was a relayer with thr remote host name and my email addy as authorization. Any other ideas
Thanks
Bill

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: Backup Mail server

Post by Bill48105 » 2013-02-14 20:00

Not without seeing logs to understand which part you screwed up on. lol
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Backup Mail server

Post by bescher » 2013-02-16 19:44

Here is a snippet
I can't believe that I would need each individuals password. I would think that mine would be sufficient


"APPLICATION" 1976 "2013-02-04 10:22:26.592" "SMTPDeliverer - Message 2577: Delivering message from to specialrate@trekfancy.com. File: C:\Program Files (x86)\hMailServer\Data\{8A76EDB6-0F2C-4652-A2AD-C938E40FE3AC}.eml"
"APPLICATION" 916 "2013-02-04 10:22:26.592" "SMTPDeliverer - Message 2578: Delivering message from specialrate@sleepingspirit.com to christine@jtimothybuilders.com. File: C:\Program Files (x86)\hMailServer\Data\{C6B9E75C-1509-49E3-9065-5470B653D117}.eml"
"APPLICATION" 4588 "2013-02-04 10:22:26.608" "Servers started."
"APPLICATION" 1976 "2013-02-04 10:22:26.623" "SMTPDeliverer - Message 2577: Relaying to host pop.rsegroup.com."
"TCPIP" 1976 "2013-02-04 10:22:26.623" "Connecting to pop.rsegroup.com..."
"APPLICATION" 916 "2013-02-04 10:22:26.623" "SMTPDeliverer - Message 2578: Relaying to host 63.131.81.207."
"TCPIP" 916 "2013-02-04 10:22:26.623" "Connecting to 63.131.81.207..."
"SMTPC" 4388 1 "2013-02-04 10:22:26.795" "63.131.81.207" "RECEIVED: 220 Welcome to RSEGroup Mail Server"
"SMTPC" 5080 2 "2013-02-04 10:22:26.795" "63.131.81.207" "RECEIVED: 220 Welcome to RSEGroup Mail Server"
"SMTPC" 4388 1 "2013-02-04 10:22:26.795" "63.131.81.207" "SENT: EHLO private.rsegroup.com"
"SMTPC" 5080 2 "2013-02-04 10:22:26.795" "63.131.81.207" "SENT: EHLO private.rsegroup.com"
"SMTPC" 5080 2 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250-pop.rsegroup.com"
"SMTPC" 2796 1 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250-pop.rsegroup.com"
"SMTPC" 4388 2 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250-SIZE"
"SMTPC" 5080 1 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250-SIZE"
"SMTPC" 2796 2 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250 AUTH LOGIN"
"SMTPC" 4388 1 "2013-02-04 10:22:26.857" "63.131.81.207" "RECEIVED: 250 AUTH LOGIN"
"SMTPC" 2796 2 "2013-02-04 10:22:26.857" "63.131.81.207" "SENT: AUTH LOGIN"
"SMTPC" 4388 1 "2013-02-04 10:22:26.857" "63.131.81.207" "SENT: AUTH LOGIN"
"SMTPC" 4388 2 "2013-02-04 10:22:26.920" "63.131.81.207" "RECEIVED: 334 VXNlcm5hbWU6"
"SMTPC" 2796 1 "2013-02-04 10:22:26.920" "63.131.81.207" "RECEIVED: 334 VXNlcm5hbWU6"
"SMTPC" 4388 2 "2013-02-04 10:22:26.920" "63.131.81.207" "SENT: YmVzY2hlcg=="
"SMTPC" 2796 1 "2013-02-04 10:22:26.920" "63.131.81.207" "SENT: YmVzY2hlckByc2Vncm91cC5jb20="
"SMTPC" 2796 2 "2013-02-04 10:22:26.998" "63.131.81.207" "RECEIVED: 334 UGFzc3dvcmQ6"
"SMTPC" 4388 1 "2013-02-04 10:22:26.998" "63.131.81.207" "RECEIVED: 334 UGFzc3dvcmQ6"
"SMTPC" 2796 2 "2013-02-04 10:22:26.998" "63.131.81.207" "SENT: ***"
"SMTPC" 4388 1 "2013-02-04 10:22:26.998" "63.131.81.207" "SENT: ***"
"SMTPC" 2796 1 "2013-02-04 10:22:27.060" "63.131.81.207" "RECEIVED: 235 authenticated."
"SMTPC" 4388 2 "2013-02-04 10:22:27.060" "63.131.81.207" "RECEIVED: 535 Authentication failed. Restarting authentication process."
"SMTPC" 2796 1 "2013-02-04 10:22:27.076" "63.131.81.207" "SENT: MAIL FROM:<>"
"SMTPC" 4388 2 "2013-02-04 10:22:27.076" "63.131.81.207" "SENT: ***"
"SMTPC" 4388 2 "2013-02-04 10:22:27.107" "63.131.81.207" "RECEIVED: 221 goodbye"
"APPLICATION" 916 "2013-02-04 10:22:27.123" "SMTPDeliverer - Message 2578: Message delivery thread completed."
"SMTPC" 3496 1 "2013-02-04 10:22:27.138" "63.131.81.207" "RECEIVED: 250 OK"

User avatar
mattg
Moderator
Moderator
Posts: 21267
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Backup Mail server

Post by mattg » 2013-02-17 00:46

bescher wrote:I can't believe that I would need each individuals password. I would think that mine would be sufficient
You shouldn't need everyone's (or anyone's) password to run a backup server.

The main server is mis-configured I'd reckon
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Backup Mail server

Post by bescher » 2013-02-17 03:20

Well Matt my friend

The main server you have looked at yourself
Can you tell me where then?

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: Backup Mail server

Post by Bill48105 » 2013-02-17 05:59

If you follow the directions/examples you will see on the BACKUP server you add a route for each domain as shown and on the delivery tab you put valid username & password for ANY ACTIVE ACCOUNT. The reason you do that is because the primary server will see the addresses & might not accept the mail. An alternate way is add an ip range with higher priority for the backup server and disable requirement to authenticate. (Doesn't hurt to do both as long as you know what you're doing) Key is you want to think of the backup server as the email client sending on (relaying) those messages so you need to configure the primary in such a way that it will accept them despite the fact the from doesn't match SPF (since sending IP is your backup not the original sender), etc etc. Is why it's important to know how to read the logs & understand mail flow or you'll just have issues. But NO you DO NOT need a different login for each person just some working account on the primary. Make up one called mxbackup@yourdomain.com & assign some strong random password. Or use any existing account (but realize issue if the password gets changed by user & not changed on backup). Then use that account. That's why routes have ONE username/password field because there's no reason for multiple.
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Backup Mail server

Post by bescher » 2013-02-23 19:16

I have done all that except for adding a ip range. But the main servers know the backup server and vice versa.
will keep on checking it

Post Reply