SM plugins help

Use this forum if you have problems with a hMailServer script, such as hMailServer WebAdmin or code in an event handler.
Post Reply
jpeoples
Normal user
Normal user
Posts: 67
Joined: 2004-07-01 05:56
Location: Ft Lauderdale, Fl US of A

SM plugins help

Post by jpeoples » 2004-07-25 22:19

I can't seem to get either the login_alias or the squirrelspell plugin to work...

I've got hmailserver installed on a xp machine running apache 2.0.49 with squirrelmail 143a...

a step by step walk through like the password change would be terrific....thanks in advance...

j. peoples

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-25 23:07

try this then ask again if you have more problems..


http://www.concept4.ca/diy

jpeoples
Normal user
Normal user
Posts: 67
Joined: 2004-07-01 05:56
Location: Ft Lauderdale, Fl US of A

re: plugin help

Post by jpeoples » 2004-07-25 23:32

thanks for responding polarunion...

I've got the server up and running okay (been running for a month, without any problems)

but i can't seem to get any of the plugins to work...especially the alias_login and squirrelspell plugins..

i thought that i had the change password plugin configured okay (it was showing up under the options tab)....but then i realized that it wasn't working right either (kept getting a "unable to reach database server, try again later " error)....but then i went under the addon folder in the hmailserver itself and added the change password plugin that was in there, and it worked great...

if anyone has ever gotten the alias_login or the squirrel plugins to work please let me know how you did it?

thanks again...j. peoples

jpeoples
Normal user
Normal user
Posts: 67
Joined: 2004-07-01 05:56
Location: Ft Lauderdale, Fl US of A

plugins help

Post by jpeoples » 2004-07-25 23:33

oops i meant the squirrelspell plugin^

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-26 06:15

i dabbled with the squirrelspell plugin - and as of yet, i haven't had any luck.. there is instructions on how to install it at the SM website if you do a search for it...

let me know if you can figure it out.. i spent a good while with it without luck..

andyf

squirrelspell

Post by andyf » 2004-11-04 20:39

Just posted information somewhere else on here about squirrelspell.

I didn't have too much difficulty getting it working on Win2k.
http://www.squirrelmail.org/wiki/en_US/SquirrelSpell

I installed mine to C:\aspell to avoid any issues with the "space" being in "Program Files" where it would be installed by default. Put the cat.exe in my system32 folder, and also added the English language dictionary.

I used this in my sqspell_config.php file:
$SQSPELL_APP = array("English" => "C:\\Aspell\\bin\\aspell.exe -d en_us -a");

Hope that might help.

Andy

chaikw
Normal user
Normal user
Posts: 37
Joined: 2005-07-18 10:14
Location: Selangor, Malaysia

Post by chaikw » 2005-07-22 05:31

Hi there,

I using Windows 2003 with IIS6, PHP 5.0.3, hMailServer 4.0 B125, and SM for hMail 0.1.

I copy the squirrelspell to /sm/plugins and use the conf.pl to add the plugins. Then I install the Aspell-0-50-3-3-Setup into C:\Apsell and copy cat.exe to C:\Windows\System32 folder. Finally modify the squirrelspell sqspell_config.php as below:

$SQSPELL_APP = array("English" => "C:\Aspell\bin\aspell.exe -d en_us -a");

However, when I try it out I get the following error message:

ERROR:
Could not run the spellchecker command (%s).


ERROR:
Error while writing to pipe.



Warning: fclose(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 104

Warning: feof(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 107

Warning: fgetss(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 108

Warning: feof(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 107

Warning: fgetss(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 108

Warning: feof(): supplied argument is not a valid stream resource in f:\Inetpub\wwwroot\plugins\squirrelspell\modules\check_me.mod on line 107

Any ideas?

Thanks.
Regards,
Chai Kam Weng

Post Reply