Page 1 of 1

SquirrelMail, HTML_mail and ASpell

Posted: 2005-07-15 02:57
by FAWTS
Well, SquirrelMAil works great ! the same with HTML_mail plugin except the spell checker option that uses ASpell.

I know that this question should have it place on ASpell forum, but here, people are a lot more reactive...

Anyway. the installation worked well and ASpell detects the spell mistakes well too, but as soon as it had to replace a letter, it uses stuff like é (this is his é).

For example, when I write "ecole" (that means school in French), it should replace it with "école" (that still means school, but this is the correct forme!). But it replaces with école. I tried to change the configuration (ASCII, iso 1, 15...) the same with the encoding of html_mail plugin... but I still can't get éçà...

If somebody has an idea!!!!

Thank's a lot.

Posted: 2005-07-15 15:26
by FAWTS
After hours & hours searching what is the page that decide of the encoding type of ASpell, I found it, and now everything works great.

If you have this problem, this means your dictionary does not include utf-8 encode.
But FCKeditor use it...

So you have to go to :

www\Squirellmail\plugins\html_mail\fckeditor\editor\dialog\fck_spellerpages\spellerpages\server-scripts\ ,
Then you edit the spellchecker.php page :

line 22, replace
$aspell_opts = "-a --lang=$lang --encoding=utf-8 -H";

with
$aspell_opts = "-a --lang=$lang --encoding=iso8859-1 -H";

And now, everything work well!!!! :lol:

Posted: 2005-07-15 15:33
by martin
See, asking in the hMailServer forum always helps ;-)

Posted: 2005-07-15 17:12
by FAWTS
Well, the way I look for solving my problems is always the same :

1) try to understand the cause
2) go to different forum (here, for example, HM, SM, ASpell forums)
3) try to find by myself
4) post my problem
5) go to bed
6) after one hour, I was not able to sleep because of it
7) search by myself again and again
8) It is 5 - 6 am, I can see the sun, I go to bed
9) I wake up
10) go to forum to see if I got answers
11) Search
12) Published the solution!!!!!!!!!
13) Feel proud :wink:

Posted: 2005-08-01 09:13
by chaikw
Hi there,

I using hMailServer 4.0 B125, apache 2.0.54, PHP 5.0.3, Aspell-0-50-3-3 on Windows 2003 Server.

When I want to perform spell check, it display found the error but with error message:

Line 25
Char 201
Error Unterminated string constant
Code 0
URL http://localhost/plugins/squirrelspell/ ... erface.php

Line 29
Char 31
Error 'misses' is undefined
Code 0
URL http://localhost/plugins/squirrelspell/ ... erface.php

Any ideas?

Thanks.