Aspell problems with Squirrelmail

Use this forum if you have problems with a hMailServer script, such as hMailServer WebAdmin or code in an event handler.
Post Reply
UltraIT
New user
New user
Posts: 2
Joined: 2010-09-15 09:32

Aspell problems with Squirrelmail

Post by UltraIT » 2010-09-15 09:38

Hi there,

We have Squirrelmail and Aspell installed on our hMailServer but I am having some problems configuring the dictionaries and I'm wondering if anyone with abit of experience in this area could guide me in the right direction. I have installed aspell 0.50.3 win32 on our server and also downloaded the EN directory which is located in /aspell/dict directory and when clicking spellcheck in Squirrelmail it does appear to know there is a dictionary there but I get the following error:

Unhandled Error: The file "/C:/Progra~2/Aspell/dict/en-only.rws" can not be
opened for reading.

...but the rws file does not exist. Please could someone advise? I have already searched Google for two hours now yesterday and can't figure it out.

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Aspell problems with Squirrelmail

Post by dzekas » 2010-09-15 10:27

UltraIT wrote:We have Squirrelmail and Aspell installed on our hMailServer but I am having some problems configuring the dictionaries and I'm wondering if anyone with abit of experience in this area could guide me in the right direction. I have installed aspell 0.50.3 win32 on our server and also downloaded the EN directory which is located in /aspell/dict directory and when clicking spellcheck in Squirrelmail it does appear to know there is a dictionary there but I get the following error:

Unhandled Error: The file "/C:/Progra~2/Aspell/dict/en-only.rws" can not be
opened for reading.
Which aspell packages are installed on your setup? Aspell-0-50-3-3-Setup.exe installs only spellchecking engine. you need aspell-en-0.50-2-3.exe

Please note that this is not SquirrelMail support forum.

UltraIT
New user
New user
Posts: 2
Joined: 2010-09-15 09:32

Re: Aspell problems with Squirrelmail

Post by UltraIT » 2010-09-16 12:33

Hi,

I know it's not Squirrelmail forum I am mainly just here in regards to setting up an aspell dictionary since I couldn't find any forum on the aspell website.

I have aspell-en-0.50-2-3.exe installed on the server but I think I have to do something with the dictionary files to create an RWS file? As it seems I am lacking the en-only.rws which is what it is trying to find. I have an en-only.cwl however.

Thanks.

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Aspell problems with Squirrelmail

Post by dzekas » 2010-09-16 12:45

UltraIT wrote: I know it's not Squirrelmail forum I am here for aspell support with setting up a dictionary.

I have aspell-en-0.50-2-3.exe installed on the server but I think I have to do something with the dictionary files to create an RWS file? As it seems I am lacking the en-only.rws which is what it is trying to find. I have an en-only.cwl however.
you don't have to do anything else in aspell installation. Just install dictionaries that you want use. If you already messed up in aspell directory, uninstall everything, delete aspell directory and reinstall aspell and dictionaries. Make sure that you don't confuse aspell 0.5 and 0.6. Use windows aspell packages from same source.

Check if aspell is working in console

Code: Select all

c:\aspell\bin\aspell.exe -d en -c some-text-file.txt

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: Aspell problems with Squirrelmail

Post by Bill48105 » 2010-09-19 02:23

UltraIT wrote: Unhandled Error: The file "/C:/Progra~2/Aspell/dict/en-only.rws" can not be opened for reading.
Not sure if it's why it's not working but why is there a / before C:?
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Aspell problems with Squirrelmail

Post by bescher » 2010-09-19 09:43

While we are on the subject of aspell (Which I also run
I keep on getting a error No input file specified

I have been working on it for sometime and haven't been able to figure it out

Thanks

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Aspell problems with Squirrelmail

Post by dzekas » 2010-09-19 10:08

bescher wrote:While we are on the subject of aspell (Which I also run
I keep on getting a error No input file specified

I have been working on it for sometime and haven't been able to figure it out
You use aspell in command line mode or aspell in pipe mode (some webmail or html editor scripts)?

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Aspell problems with Squirrelmail

Post by bescher » 2010-09-19 18:30

Insquirrelmail (Actually nutsmail) I check on the checkbox for spelling I am presumin it is asspell
As I understand it

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Aspell problems with Squirrelmail

Post by dzekas » 2010-09-19 18:44

bescher wrote:Insquirrelmail (Actually nutsmail) I check on the checkbox for spelling I am presumin it is asspell
As I understand it
You are checking email in html format or in plain text?
Do you see warnings in SquirrelMail configtest.php or everything is OK?

Please note that questions about "No input file specified" error in SquirrelMail or Nutsmail should be asked on SquirrelMail or Nutsmail support channels.

bescher
Normal user
Normal user
Posts: 123
Joined: 2008-05-26 01:56
Location: Milwaukee Wi
Contact:

Re: Aspell problems with Squirrelmail

Post by bescher » 2010-09-23 09:40

It is in html and no warnings other than "input file not found"

User avatar
dzekas
Senior user
Senior user
Posts: 2486
Joined: 2005-10-13 21:28
Location: Lithuania

Re: Aspell problems with Squirrelmail

Post by dzekas » 2010-09-23 09:55

bescher wrote:It is in html and no warnings other than "input file not found"
Check plugins/html_mail/fckeditor/editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php

Set $tempfiledir to $attachment_dir

Code: Select all

$aspell_opts = "-a --lang=$lang --encoding=utf-8 -H";   // by FredCK
$tempfiledir = $attachment_dir;
It is possible that current directory is not writable and PHP tempnam function can't find writable directory.

If SquirrelMail configtest.php shows warnings (I am thinking about one specific warning), turn that setting off for SquirrelMail. spellchecker.php script has programming mistake which might create problems in some PHP configurations.

If you ask such questions on SquirrelMail mailing list, you would get same answers from same person and you won't anger hMailServer forum moderators.

Post Reply