SA + ClamAV on Ubuntu

Forum for things that doesn't really have anything to do with hMailServer. Such as php.ini, beer, etc etc.
Post Reply
katip
Senior user
Senior user
Posts: 545
Joined: 2006-12-22 07:58
Location: Istanbul

SA + ClamAV on Ubuntu

Post by katip » 2018-01-28 13:59

Hi,
Yesterday I setup an Ubuntu Server VM with Spamassassin + ClamAV.
Does anyone succeed in similar environment to make SA work with ClamAV via plugin on their page?
it always returns: X-Spam-Virus: Error (Cannot connect to 'localhost:3310': IO::Socket::INET: connect: 10061)
on Win box both were working fine together. Any clue? TIA

PS: BTW, i confirm HmailServer & SpamAssassin : The WinSock error code is 2. issue remains the same with Linux variant (mattg confirmed it too).
Katip
--
HMS 5.6.7-B2425, MySQL 5.5.46, SpamAssassin 3.4.2, ClamAV 0.99.2 + SaneS & SecuriteI

User avatar
jimimaseye
Moderator
Moderator
Posts: 7766
Joined: 2011-09-08 17:48

Re: SA + ClamAV on Ubuntu

Post by jimimaseye » 2018-01-28 14:03

Mattg uses it. (Im sure he will respond accordingly).
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
mattg
Moderator
Moderator
Posts: 19460
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: SA + ClamAV on Ubuntu

Post by mattg » 2018-01-28 16:17

Try opening port 3310 on your Ubuntu firewall. (I'm not sure that's what I did)

(And yes it works for me)

Code: Select all

Sun Jan 28 23:59:20 2018 [9535] info: spamd: connection from 10.10.10.150 [10.10.10.150]:50662 to port 783, fd 5
Sun Jan 28 23:59:20 2018 [9535] info: spamd: processing message <e7dda916e8384510ec16774a25571c79@biotekconsulting.com> for (unknown):104
Sun Jan 28 23:59:26 2018 [9535] info: spamd: identified spam (47.5/-500.0) for (unknown):104 in 5.6 seconds, 1152 bytes.
Sun Jan 28 23:59:26 2018 [9535] info: spamd: result: Y 47 - ADD_TO_SCORE,CLAMAV,CLAMAV_SANE,HELO_MISC_IP,HTML_MESSAGE,HTML_MIME_NO_HTML_TAG,KB_WAM_LONELY_WOMEN,MIME_HTML_ONLY,PHP_ORIG_SCRIPT,PYZOR_CHECK,RCVD_IN_BL_SPAMCOP_NET,RCVD_IN_BRBL_LASTEXT,RCVD_IN_HOSTKARMA_BL,RCVD_IN_NERDS_VN,RCVD_IN_PBL,RCVD_IN_SBL_CSS,RCVD_IN_SORBS_WEB,RCVD_IN_XBL,RDNS_NONE,TO_NO_BRKTS_NORDNS_HTML,T_SPF_TEMPERROR scantime=5.6,size=1152,user=(unknown),uid=104,required_score=-500.0,rhost=10.10.10.150,raddr=10.10.10.150,rport=50662,mid=<e7dda916e8384510ec16774a25571c79@biotekconsulting.com>,autolearn=no autolearn_force=no
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

katip
Senior user
Senior user
Posts: 545
Joined: 2006-12-22 07:58
Location: Istanbul

Re: SA + ClamAV on Ubuntu

Post by katip » 2018-01-28 17:37

mattg wrote:Try opening port 3310 on your Ubuntu firewall.
ufw is disabled at all.
anyways, scan called from HMS to Ubuntu works fine, so no big issue.
but looks like this Linux thing will teach me a lot :P
Katip
--
HMS 5.6.7-B2425, MySQL 5.5.46, SpamAssassin 3.4.2, ClamAV 0.99.2 + SaneS & SecuriteI

User avatar
fjansen04
New user
New user
Posts: 25
Joined: 2008-08-30 15:49
Location: The Netherlands

Re: SA + ClamAV on Ubuntu

Post by fjansen04 » 2018-05-06 11:58

It looks like Clamav configuration on Ubuntu is somewhat tricky.
I found valuable input here:

https://serverfault.com/questions/79858 ... n-tcp-3310
HMS 5.6.8 B2431 on Windows Server 2016 Essentials

Post Reply