problem receiving mail internally

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
arash
New user
New user
Posts: 8
Joined: 2004-09-12 19:56

problem receiving mail internally

Post by arash » 2004-09-26 10:49

Hi!,
I am having a problem receiving email sent from one domain to another domain. I am not receiving the mail. I dont get any errors when sending. it just does not arrive. I can send from an outside account and it works,but not internally. I have two domain accounts on the hmail server. and I am sending from one to the other. Any one knows how to fix this?. please help. here is my log after I send the message:

"SMTPD" 1028 "2004-09-26 00:09:52.305" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-25 17:27:50"
"SMTPD" 1028 "2004-09-26 00:09:52.746" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 1028 "2004-09-26 00:09:52.746" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 1028 "2004-09-26 00:09:52.966" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 1028 "2004-09-26 00:09:52.996" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 1028 "2004-09-26 00:09:53.187" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 1028 "2004-09-26 00:09:53.187" "63.120.72.50" "SENT: 221 goodbye"
"SMTPD" 572 "2004-09-26 00:19:59.468" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-25 17:27:50"
"SMTPD" 572 "2004-09-26 00:19:59.739" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 572 "2004-09-26 00:19:59.739" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 572 "2004-09-26 00:19:59.939" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 572 "2004-09-26 00:20:00.069" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 572 "2004-09-26 00:20:00.279" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 572 "2004-09-26 00:20:00.279" "63.120.72.50" "SENT: 221 goodbye"
"APPLICATION" 672 "2004-09-26 00:21:26.634" "SMTPD - Server started."
"APPLICATION" 1024 "2004-09-26 00:21:26.634" "POP3D - Server started."
"APPLICATION" 916 "2004-09-26 00:21:26.644" "IMAPD - Server started."

User avatar
layer
Normal user
Normal user
Posts: 55
Joined: 2004-09-12 14:19
Location: Portugal

Post by layer » 2004-09-26 13:20

you don't have SMTP authentication activated in your e-mail client...

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-09-26 13:40

Yep. layer is right. You haven't turned on SMTP authentication. If you don't receive any error messages in your email client you are using a really buggy email client..

arash
New user
New user
Posts: 8
Joined: 2004-09-12 19:56

Post by arash » 2004-09-26 19:41

Hi,
I know SMTP Authentication is turned on on moth the server and the Client because I am able to send to an outside email account. I am using outlook express on both my computers and i receive the mail fine on any outside account. I am not however receiving it internally..(from one account in hmail to the other). as I said I am not getting an error message. I kno quite a few others have had this problem before.. Any help will be greatly appreciated. I have hmail version 3.2.2.

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-09-26 19:57

It doesn't matter what you say... :)
The email client sending the email in the log snippet you posted has either not turned on SMTP authentication or is really buggy. Are you sure you really posted the correct snippet from the log file?

arash
New user
New user
Posts: 8
Joined: 2004-09-12 19:56

Post by arash » 2004-09-27 02:18

Thanks for the response.. I am sure this is the correct log file. I am posting the latest log after trying to send again so you can see.. SMTP Authentication is turned on and is working fine. How is it I am abale to receive externally then?. My ISP requires SMTP authentication and if it was not turned on I won't be able to send mail right?. So I know I have turned on SMTP. What do you suggest I do next?..

Thanks.

"SMTPD" 1028 "2004-09-26 00:09:52.305" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-25 17:27:50"
"SMTPD" 1028 "2004-09-26 00:09:52.746" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 1028 "2004-09-26 00:09:52.746" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 1028 "2004-09-26 00:09:52.966" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 1028 "2004-09-26 00:09:52.996" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 1028 "2004-09-26 00:09:53.187" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 1028 "2004-09-26 00:09:53.187" "63.120.72.50" "SENT: 221 goodbye"
"SMTPD" 572 "2004-09-26 00:19:59.468" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-25 17:27:50"
"SMTPD" 572 "2004-09-26 00:19:59.739" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 572 "2004-09-26 00:19:59.739" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 572 "2004-09-26 00:19:59.939" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 572 "2004-09-26 00:20:00.069" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 572 "2004-09-26 00:20:00.279" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 572 "2004-09-26 00:20:00.279" "63.120.72.50" "SENT: 221 goodbye"
"APPLICATION" 672 "2004-09-26 00:21:26.634" "SMTPD - Server started."
"APPLICATION" 1024 "2004-09-26 00:21:26.634" "POP3D - Server started."
"APPLICATION" 916 "2004-09-26 00:21:26.644" "IMAPD - Server started."
"APPLICATION" 2104 "2004-09-26 09:24:37.799" "POP3D - Server started."
"APPLICATION" 2108 "2004-09-26 09:24:37.799" "IMAPD - Server started."
"APPLICATION" 2020 "2004-09-26 09:24:37.799" "SMTPD - Server started."
"APPLICATION" 2104 "2004-09-26 10:23:06.494" "SMTPD - Server started."
"APPLICATION" 2020 "2004-09-26 10:23:06.504" "POP3D - Server started."
"APPLICATION" 628 "2004-09-26 10:23:06.504" "IMAPD - Server started."
"APPLICATION" 2020 "2004-09-26 10:25:06.136" "SMTPD - Server started."
"APPLICATION" 2104 "2004-09-26 10:25:06.146" "POP3D - Server started."
"APPLICATION" 984 "2004-09-26 10:25:06.156" "IMAPD - Server started."
"SMTPD" 468 "2004-09-26 10:28:27.796" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 468 "2004-09-26 10:28:28.066" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 468 "2004-09-26 10:28:28.066" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 468 "2004-09-26 10:28:28.267" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@slmuslim.net>"
"SMTPD" 468 "2004-09-26 10:28:28.267" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 468 "2004-09-26 10:28:28.487" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 468 "2004-09-26 10:28:28.487" "63.120.72.50" "SENT: 221 goodbye"
"SMTPD" 2396 "2004-09-26 10:36:10.922" "192.168.0.2" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2396 "2004-09-26 10:36:10.972" "192.168.0.2" "RECEIVED: EHLO slmuslim.net"
"SMTPD" 2396 "2004-09-26 10:36:10.972" "192.168.0.2" "SENT: 250-hmailserver[nl]250 AUTH LOGIN"
"SMTPD" 2396 "2004-09-26 10:36:10.972" "192.168.0.2" "RECEIVED: MAIL FROM:<12843@ensim.rackshack.net>"
"SMTPD" 2396 "2004-09-26 10:36:11.002" "192.168.0.2" "SENT: 250 12843@ensim.rackshack.net... Sender OK"
"SMTPD" 2396 "2004-09-26 10:36:11.022" "192.168.0.2" "RECEIVED: RCPT TO:<office@slmuslim.net>"
"SMTPD" 2396 "2004-09-26 10:36:11.052" "192.168.0.2" "SENT: 550 unknown user <office@slmuslim.net>"
"SMTPD" 2396 "2004-09-26 10:36:11.062" "192.168.0.2" "SENT: 421 Lost connection[nl]"
"SMTPD" 2396 "2004-09-26 10:36:36.349" "64.136.20.164" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2396 "2004-09-26 10:36:36.629" "64.136.20.164" "RECEIVED: HELO outbound-mail.nyc.untd.com"
"SMTPD" 2396 "2004-09-26 10:36:36.629" "64.136.20.164" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 2396 "2004-09-26 10:36:36.869" "64.136.20.164" "RECEIVED: MAIL FROM:<arasheed@netzero.com>"
"SMTPD" 2396 "2004-09-26 10:36:36.869" "64.136.20.164" "SENT: 250 arasheed@netzero.com... Sender OK"
"SMTPD" 2396 "2004-09-26 10:36:37.130" "64.136.20.164" "RECEIVED: RCPT TO:<webmaster@hostingdrive.net>"
"SMTPD" 2396 "2004-09-26 10:36:37.150" "64.136.20.164" "SENT: 250 OK its for webmaster@hostingdrive.net"
"SMTPD" 2396 "2004-09-26 10:36:37.390" "64.136.20.164" "RECEIVED: DATA"
"SMTPD" 2396 "2004-09-26 10:36:37.390" "64.136.20.164" "SENT: 354 ok send! end with <crlf>.<crlf>"
"SMTPD" 2396 "2004-09-26 10:36:38.382" "64.136.20.164" "SENT: 250 Message queued (0.902 seconds)"
"SMTPD" 2396 "2004-09-26 10:36:38.652" "64.136.20.164" "RECEIVED: QUIT"
"SMTPD" 2396 "2004-09-26 10:36:38.842" "64.136.20.164" "SENT: 221 goodbye"
"APPLICATION" 2396 "2004-09-26 10:36:39.293" "SMTPDeliverer - Message 5: Delivering message from arasheed@netzero.com to webmaster@hostingdrive.net."
"APPLICATION" 2396 "2004-09-26 10:36:39.483" "SMTPDeliverer - Message 5: Message delivered successfully."
"SMTPD" 2284 "2004-09-26 10:38:00.239" "192.168.0.2" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2284 "2004-09-26 10:38:00.450" "192.168.0.2" "RECEIVED: EHLO slmuslim.net"
"SMTPD" 2284 "2004-09-26 10:38:00.460" "192.168.0.2" "SENT: 250-hmailserver[nl]250 AUTH LOGIN"
"SMTPD" 2284 "2004-09-26 10:38:00.460" "192.168.0.2" "RECEIVED: MAIL FROM:<noreply@paypal.com>"
"SMTPD" 2284 "2004-09-26 10:38:00.610" "192.168.0.2" "SENT: 250 noreply@paypal.com... Sender OK"
"SMTPD" 2284 "2004-09-26 10:38:00.620" "192.168.0.2" "RECEIVED: RCPT TO:<anything@slmuslim.net>"
"SMTPD" 2284 "2004-09-26 10:38:00.660" "192.168.0.2" "SENT: 550 unknown user <anything@slmuslim.net>"
"SMTPD" 2284 "2004-09-26 10:38:00.670" "192.168.0.2" "SENT: 421 Lost connection[nl]"
"SMTPD" 2284 "2004-09-26 10:41:15.350" "64.136.20.164" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2284 "2004-09-26 10:41:15.650" "64.136.20.164" "RECEIVED: HELO outbound-mail.nyc.untd.com"
"SMTPD" 2284 "2004-09-26 10:41:15.650" "64.136.20.164" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 2284 "2004-09-26 10:41:15.911" "64.136.20.164" "RECEIVED: MAIL FROM:<arasheed@netzero.com>"
"SMTPD" 2284 "2004-09-26 10:41:15.911" "64.136.20.164" "SENT: 250 arasheed@netzero.com... Sender OK"
"SMTPD" 2284 "2004-09-26 10:41:16.151" "64.136.20.164" "RECEIVED: RCPT TO:<webmaster@slmuslim.net>"
"SMTPD" 2284 "2004-09-26 10:41:16.151" "64.136.20.164" "SENT: 250 OK its for webmaster@slmuslim.net"
"SMTPD" 2284 "2004-09-26 10:41:16.411" "64.136.20.164" "RECEIVED: DATA"
"SMTPD" 2284 "2004-09-26 10:41:16.411" "64.136.20.164" "SENT: 354 ok send! end with <crlf>.<crlf>"
"SMTPD" 2284 "2004-09-26 10:41:17.353" "64.136.20.164" "SENT: 250 Message queued (0.871 seconds)"
"SMTPD" 2284 "2004-09-26 10:41:17.613" "64.136.20.164" "RECEIVED: QUIT"
"SMTPD" 2284 "2004-09-26 10:41:17.803" "64.136.20.164" "SENT: 221 goodbye"
"APPLICATION" 2284 "2004-09-26 10:41:17.984" "SMTPDeliverer - Message 7: Delivering message from arasheed@netzero.com to webmaster@slmuslim.net."
"APPLICATION" 2284 "2004-09-26 10:41:18.224" "SMTPDeliverer - Message 7: Message delivered successfully."
"SMTPD" 2284 "2004-09-26 10:44:52.903" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2284 "2004-09-26 10:44:53.103" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 2284 "2004-09-26 10:44:53.103" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 2284 "2004-09-26 10:44:53.303" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 2284 "2004-09-26 10:44:53.303" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 2284 "2004-09-26 10:44:53.503" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 2284 "2004-09-26 10:44:53.503" "63.120.72.50" "SENT: 221 goodbye"
"SMTPD" 2120 "2004-09-26 17:01:23.406" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 356 "2004-09-26 17:01:23.406" "63.120.72.50" "SENT: 220 (SMTP) hMailServer 3.2 2004-09-26 10:25:05"
"SMTPD" 2120 "2004-09-26 17:01:23.687" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 2120 "2004-09-26 17:01:23.687" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 356 "2004-09-26 17:01:23.707" "63.120.72.50" "RECEIVED: HELO appleisp.net"
"SMTPD" 356 "2004-09-26 17:01:23.737" "63.120.72.50" "SENT: 250 Hello. Pleased to meet you"
"SMTPD" 2120 "2004-09-26 17:01:23.887" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 2120 "2004-09-26 17:01:23.917" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 356 "2004-09-26 17:01:23.927" "63.120.72.50" "RECEIVED: MAIL FROM:<webmaster@hostingdrive.net>"
"SMTPD" 356 "2004-09-26 17:01:23.927" "63.120.72.50" "SENT: 550 smtp authentication required."
"SMTPD" 2120 "2004-09-26 17:01:24.127" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 356 "2004-09-26 17:01:24.127" "63.120.72.50" "RECEIVED: QUIT"
"SMTPD" 2120 "2004-09-26 17:01:24.127" "63.120.72.50" "SENT: 221 goodbye"
"SMTPD" 356 "2004-09-26 17:01:24.127" "63.120.72.50" "SENT: 221 goodbye"

arash
New user
New user
Posts: 8
Joined: 2004-09-12 19:56

Post by arash » 2004-09-27 08:07

I just realized that when I use for example - mail.mydomain.com for my smtp server I am receiving mail sent to another email address internally. However I am not receiving mail sent externally. I know my ISP blocks port 25 and so I have to use their smtp server to send mail. I am not however receiving mail internally when using their smtp server. How can I solve this problem?. If I use my isp's smtp I can send and receive externally but not internally. if I use my own smtp I can send and receive internally but not externally.. Can anyone solve this?.

Thanks.

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-09-27 12:24

Are your ISP blocking incoming traffic on port 25 as well? Have you set up MX records for your domain?

arash
New user
New user
Posts: 8
Joined: 2004-09-12 19:56

Post by arash » 2004-09-29 08:55

My isp blocks port 25. so I have to use their smtp server to send email. This is fine for sending email that is not local. I am not receiving email sent to a local address. If I want to receive email for local address I have to change the smtp server to mail.mydomain.com. then I am receiving mail fine. if I do this I am only receiving local mail and not receiving any mail sent to an outside address.. I think I have set up the mx records correct. I have a dynamic IP so I am using dns though zone edit.. can you may be show me how I need to setup the dns so I can double check to make sure it's right..

Thanks.

Post Reply