Page 1 of 1

ERR Mailbox already locked

Posted: 2004-09-03 08:42
by tusharksinha
Hello,
I am using hmailserver 3.2.2 Build 30. I am facing a problem with few accounts. It gives an error Message -ERR Mailbox already locked.
After restarting the Services through Hmailserver admin again this error message appears after 2-3 hours. My user has been using Outlook Express as the Email Client. We are not facing problem with any other POP3 Mail server.
I have seen another Post where it is mentioned by Martin that if the POP3 server does not receive a QUIT command then this problem may appear but Hmailserver automatically unlocks the Mailbox after 2 minutes.
But this is not happening. It permanently remains Locked till I restart the Services.

Sometimes within the Process of downloading messages, the error message comes - Receiving' reported error (0x8004210E) : 'Your mailbox is temporarily unavailable because another e-mail message is being delivered to it or another mail application is accessing it. The server responded: -ERR Mailbox already locked'

Posted: 2004-09-03 09:32
by polarunion
i experienced the same problem.

Posted: 2004-09-03 10:02
by martin
How long did you wait for it to get unlocked? Did you make sure that you weren't running any other POp3 client on another computer?

Posted: 2004-09-03 14:32
by tusharksinha
I've waited for 3-4 Hours before restarting & again it is giving the same problem.



Thanks
:arrow:

Posted: 2004-09-03 14:44
by tusharksinha
No there is no other POP3 Email Client Accessing the Account at the same Time.


Thanks

Posted: 2004-09-03 15:02
by martin
This error occurs if the client disconnects improperly. The mailbox is automatically be unlocked if the client disconnects imrpoperly, but if Windows does not notify hMailServer that the client has disconnected, hMailServer automatically assumes this after two minutes. Windows does not always do this, that's why the two minute timeout exists.

If you define two accounts in Outlook Express accessing the same mail box, you will get this problem. Are you sure that your user hasn't done this? Does this error always happen for the specifi cuser?
Could you turn on POP3 logging, tell the client to access the mail box again and post the log here?

Posted: 2004-09-03 18:33
by tusharksinha
Hi Martin,
You can see the POP3 logs for the user. Even after 5 hours the mailbox has not been unlocked. For Security reasons I have changed the Email Account name & Password as a Dummy value in the log shown below.

This is happening for a specific user. But don't know if the other users are facing the same Problem. This Client access the mails very frequently.
-----------------------------------------------------------------------------------

TCPIP" 2496 "2004-09-03 06:38:19.985" "POP3D - Connection from 212.165.146.244 accepted."
"POP3D" 3116 "2004-09-03 06:38:19.985" "212.165.146.244" "SENT: +OK (POP3) hMailServer 3.2 2004-09-03 00:55:54"
"POP3D" 3116 "2004-09-03 06:38:20.563" "212.165.146.244" "RECEIVED: USER demo@demoserver.com"
"POP3D" 3116 "2004-09-03 06:38:20.563" "212.165.146.244" "SENT: +OK Send your password"
"POP3D" 3116 "2004-09-03 06:38:21.266" "212.165.146.244" "RECEIVED: PASS xxxxxx"
"POP3D" 3116 "2004-09-03 06:38:21.266" "212.165.146.244" "SENT: -ERR Mailbox already locked"
"TCPIP" 3116 "2004-09-03 06:38:22.110" "POP3D - Connection to client 212.165.146.244 closed."



2496 "2004-09-03 10:49:55.242" "POP3D - Connection from 212.165.146.244 accepted."
"POP3D" 3508 "2004-09-03 10:49:55.242" "212.165.146.244" "SENT: +OK (POP3) hMailServer 3.2 2004-09-03 00:55:54"
" 3508 "2004-09-03 10:49:55.664" "212.165.146.244" "RECEIVED: USER demo@demoserver.com"
"POP3D" 3508 "2004-09-03 10:49:55.664" "212.165.146.244" "SENT: +OK Send your password"
3508 "2004-09-03 10:49:56.117" "212.165.146.244" "RECEIVED: PASS xxxxxx"
"POP3D" 3508 "2004-09-03 10:49:56.117" "212.165.146.244" "SENT: -ERR Mailbox already locked"
" 3508 "2004-09-03 10:49:56.585" "POP3D - Connection to client 212.165.146.244 closed."


2496 "2004-09-03 11:00:25.154" "POP3D - Connection from 212.165.146.244 accepted."
"POP3D" 3292 "2004-09-03 11:00:25.154" "212.165.146.244" "SENT: +OK (POP3) hMailServer 3.2 2004-09-03 00:55:54"
"POP3D" 3292 "2004-09-03 11:00:25.622" "212.165.146.244" "RECEIVED: USER demo@demoserver.com"
"POP3D" 3292 "2004-09-03 11:00:25.622" "212.165.146.244" "SENT: +OK Send your password"
"POP3D" 3292 "2004-09-03 11:00:26.200" "212.165.146.244" "RECEIVED: PASS xxxxxx"
"POP3D" 3292 "2004-09-03 11:00:26.200" "212.165.146.244" "SENT: -ERR Mailbox already locked"
"TCPIP" 3292 "2004-09-03 11:00:27.216" "POP3D - Connection to client 212.165.146.244 closed."


2876 "2004-09-03 11:05:29.041" "212.165.146.244" "SENT: +OK (POP3) hMailServer 3.2 2004-09-03 00:55:54"
"POP3D" 2876 "2004-09-03 11:05:29.478" "212.165.146.244" "RECEIVED: USER demo@demoserver.com"
"POP3D" 2876 "2004-09-03 11:05:29.478" "212.165.146.244" "SENT: +OK Send your password"
"POP3D" 2876 "2004-09-03 11:05:29.915" "212.165.146.244" "RECEIVED: PASS xxxxxx"
"POP3D" 2876 "2004-09-03 11:05:29.915" "212.165.146.244" "SENT: -ERR Mailbox already locked"
"TCPIP" 2876 "2004-09-03 11:05:30.494" "POP3D - Connection to client 212.165.146.244 closed."

Posted: 2004-09-03 19:21
by martin
Still can't understand how this can happen. I'll create a new build where I'll add a whole bunch of unlocks of the mailbox to ensure that it really get's unlocked when the client has left the server in any way.

Posted: 2004-09-04 10:01
by tusharksinha
Hi Martin,
FYI. The user has got 41 messages in the Mailbox. I just noticed that while the mails are downloading after 14-15 mailes the Connection is Lost & then the Mailbox remains Locked. It's never Unlocked till I restart the Services.


:arrow:

Posted: 2004-09-04 11:52
by Bram
Experienced the same problem.

Was using webmail. Downloading a message with a 10 mb attachment.
It took too long so i pusched the stop buttun in my browser. I exited the browser and tried to login agian. Mailbox locked error. I waited for a couple of minutes but still got the error. Just waited an half hour. same error. Stop start hmailserver. Problem solved

Posted: 2004-09-04 19:40
by tusharksinha
Hi Martin,
Hope you will soon releasing a New Build with the Mailbox Locking Problem Fixed. I am using the Hmailserver in the Production environment & got lot of my users on this server


Thanks in advance for your Excellent Work.


Tushar

Posted: 2004-09-04 19:47
by martin
Yes, it will be up shortly.

Posted: 2004-09-04 20:19
by martin
The new version is up now on the download page:
http://www.hmailserver.com/?page=show_m ... nloadid=37

It's still marked as unstable since no-one except me has tested it yet. Will you install this version and try it out? It should solve the mailbox lock problem you have experienced.

Posted: 2004-09-14 14:25
by ScottyWH
we are still having the problem also (http://www.hmailserver.com/forum/viewto ... =3938#3938)... my boss is fed up... I guess we are going to have to buy exchange :(

Posted: 2004-09-14 14:35
by ScottyWH
I just installed the version that you listed in this thread... I am not sure whether we will be able to stick with hmail at this stage even *if* the problem is solved, since, because of all the problems we've had, my boss is extremely frustrated with me for suggesting this software instead of exchange to begin with...

:(

Posted: 2004-09-14 14:41
by martin
I'm sad to hear that. Actually the first time... :-(

You shouldn't have any problems with locked mailboxes in the latest version. If you still have this, it's because Windows doesn't notify hMailServer that the user has disconnected. If Windows doesn't notify hMailServer that the TCP-IP connection has been dropped, hMailServer automatically timeout after two minutes and unlock the mailbox.

Posted: 2004-09-14 15:06
by ScottyWH
Well... I checked our latest log (from last night before upgrading to this new 3.2.4 b 33 - "unstable" build) and the user who always has this problem went for fifteen minutes between *any* email device checking the pop3 server and both times he was rejected access because the mailbox was locked... so at least I know I wasn't crazy...

Posted: 2004-09-14 18:14
by martin
How many users are using the mail server?

Posted: 2004-09-14 19:41
by ScottyWH
only about 20

Posted: 2004-09-21 20:47
by ScottyWH
so far so good with 3.2.4 b 33 ... and the boss hasn't forced me to switch to exchange yet :)

Posted: 2006-01-06 21:30
by cgountanis
I have same issue and I know what caused it. The server lost some drive info. I had to reinstall but did recover the DB so all the user info was intact. When I went to get email using pop3 it gave me like 100 emails with blank subjects then got the ERR- Locked Mailbox on second send rec.

Posted: 2006-01-06 21:33
by martin
Hmm. Did you restore the hMailServer data folder as well?

Posted: 2006-01-06 21:36
by cgountanis
No. I am sure that is the issue. I don't care if there are lost emails just need to refresh the system and not lose any user info. Would be nice to clean house and have an easy restore ability even if we clean up. Sometimes that to me is OK due to inactive users filling boxes with junk mail and never cleaning up. Thanks for the quick response.