Page 1 of 1

"You do not have access to this property / method"

Posted: 2006-11-13 00:18
by vpiscitelli
Just upgraded to hMailServer 4.3 - Build 246 from hMailServer 4.2.2 - Build 199. Copied the phpWebAdmin folder. Now, when I tried to log in using my email address and password (this worked before) I get this.

Code: Select all

Warning: (null)(): Invoke() failed: Exception occurred. Source: hMailServer COM library Description: You do not have access to this property / method. Ensure that hMailServer.Application.Authenticate() is called with proper login credentials. in C:\Program Files\Apache Group\Apache2\htdocs\<my domain>.com\html\phpWebAdmin\login.php on line 77

Fatal error: Call to a member function on a non-object in C:\Program Files\Apache Group\Apache2\htdocs\<my domain>.com\html\phpWebAdmin\login.php on line 78
I saw the post [HMS 4.3] Fatal error: Uncaught exception 'com_exception' but I am using Apache on 2003 Server and have copied the folder over.

Any ideas??

Re: "You do not have access to this property / method&q

Posted: 2006-11-13 00:29
by ^DooM^
vpiscitelli wrote:Just upgraded to hMailServer 4.2.2 - Build 199 from hMailServer 4.3 - Build 246. Copied the phpWebAdmin folder. Now, when I tried to log in using my email address and password (this worked before) I get this.
You mean you have upgraded TO 4.3 from 4.2.2?

If so take a look at this.

http://www.hmailserver.com/documentatio ... hpwebadmin

Posted: 2006-11-13 00:29
by cveillon

Posted: 2006-11-13 00:41
by vpiscitelli
^DooM^ - I did go through the install doc and have everything configured as specified in the doc. Never touched DCOM permissions as I am not using IIS but Apache.

cveillon - The solution in that post was that he forgot to copy the newest phpWebAdmin folder. I have done that.

Posted: 2006-11-13 23:53
by cveillon
Very strange. :roll:

I would double check these steps (excerpt from docs - thanks Doom) being very careful for mistyping:

# The file config.php contains the basic settings for PHPWebAdmin and needs to be modified to correctly adjust it for your system:

* Set the value of rootpath to your root web directory where PHPWebAdmin is placed.
Example:
$hmail_config['rootpath'] = "C:/wwwroot/PHPWebAdmin/";

* Set the value of rooturl to the URL where the PHPWebAdmin will be located.
Example:
$hmail_config['rooturl'] = "http://localhost/PHPWebAdmin/";

* Specify your username and password (hMailServer 3.x).
Example:
$hmail_config['admin'] = "administrator";
$hmail_config['adminpassword'] = "mysecretpassword";

# Open up php.ini, and make sure that short_open_tag is set to On


Hope this helps. :)

Chuck