SMTPDeliverer - Mess 43 Failed to connect to mydomain.org

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
qdoest
New user
New user
Posts: 3
Joined: 2004-07-26 13:16

SMTPDeliverer - Mess 43 Failed to connect to mydomain.org

Post by qdoest » 2004-07-26 13:39

Hi,

Let me first say that hMailServer is a great program!!
But i get an strange error on one of my computer. If i run it and i try to test the smtp then i receive this debug output in the log:

"DEBUG" 2060 "2004-07-26 13:15:17.107" "SMTPDeliverer::_RelayMessage()"
"DEBUG" 2060 "2004-07-26 13:15:17.117" "DNSResolver::GetEmailServers()"
"TCPIP" 2060 "2004-07-26 13:15:17.117" "DNSResolver - MX Lookup: mydomain.org"
"TCPIP" 2060 "2004-07-26 13:15:17.157" "DNSResolver - MX Lookup result for mydomain.org: 0 servers"
"DEBUG" 2060 "2004-07-26 13:15:17.157" "DNSResolver::~GetEmailServers()"
"DEBUG" 2060 "2004-07-26 13:15:17.157" "SMTPDeliverer::_DeliverSingleMessageToRemoteServer()"
"APPLICATION" 2060 "2004-07-26 13:15:38.218" "SMTPDeliverer - Message 43: Failed to connect to mydomain.org."
"DEBUG" 2060 "2004-07-26 13:15:38.218" "SMTPDeliverer::~_DeliverSingleMessageToRemoteServer() - E3"
"DEBUG" 2060 "2004-07-26 13:15:38.218" "SMTPDeliverer::~_RelayMessage() - E1"
"DEBUG" 2060 "2004-07-26 13:15:38.218" "SMTPDeliverer::~_RelayMessage() - E6"
"DEBUG" 2060 "2004-07-26 13:15:38.228" "SMTPDeliverer::_SenderWantReturnConversation()"
"DEBUG" 2060 "2004-07-26 13:15:38.228" "MySQLRecordset::Open()"
"DEBUG" 2060 "2004-07-26 13:15:38.238" "MySQLRecordset::~Open() - E4"
"DEBUG" 2060 "2004-07-26 13:15:38.248" "SMTPDeliverer::~_SenderWantReturnConversation()"
"APPLICATION" 2060 "2004-07-26 13:15:38.248" "SMTPDeliverer - Message 43: Message could not be delievered. Scheduling it for later delivery."


If i try it on another computer in my network where i also have hMailServer installed then i get:

"DEBUG" 2472 "2004-07-26 12:01:21" "SMTPDeliverer::_RelayMessage()"
"DEBUG" 2472 "2004-07-26 12:01:21" "DNSResolver::GetEmailServers()"
"TCPIP" 2472 "2004-07-26 12:01:21" "DNSResolver - MX Lookup: mydomain.org"
"TCPIP" 2472 "2004-07-26 12:01:21" "DNSResolver - MX Lookup result for mydomain.org: 0 servers"
"DEBUG" 2472 "2004-07-26 12:01:21" "DNSResolver::~GetEmailServers()"
"DEBUG" 2472 "2004-07-26 12:01:21" "SMTPDeliverer::_DeliverSingleMessageToRemoteServer()"
"DEBUG" 2472 "2004-07-26 12:01:21" "SocketConnection::SocketConnection()"
"DEBUG" 2472 "2004-07-26 12:01:21" "SocketConnection::HandleClient()"
"DEBUG" 2472 "2004-07-26 12:01:21" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2472 "2004-07-26 12:01:21" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2472 "2004-07-26 12:01:21" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 2472 "2004-07-26 12:01:21" "192.168.1.10" "RECEIVED: 220 mydomain.org WebShield SMTP V4.5 MR1a P0803.345 Network Associates, Inc. Ready at Mon Jul 26 12:01:56 2004"
"DEBUG" 2472 "2004-07-26 12:01:22" "SMTPClientConnection::_SendData()"


I also put "ComputerName" in the hMailServer.ini but still no luck.

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-26 14:24

enable the smtp logging let's have a look at what that says. also what type of setup do you have? any proxy's?

qdoest
New user
New user
Posts: 3
Joined: 2004-07-26 13:16

Post by qdoest » 2004-07-26 14:42

I don't have any proxies...what do you mean by smtp log? You mean smtp log of hmailserver or do you mean smtp log of my exchange server where i try to email?

I think it's an internal problem because he cannot even resolve my domain.

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-26 15:02

open hmailserver admin - go to logging and enable smtp logging.

it's most likely not a software problem so let's have a look at that first.

what other tests have you done that prove that this is an internal problem?
so you're trying to send an email to your own exchange server that is on your network?

what about dns? do you have some kind of network dns server? you see, it could be a hundred and one different things.. send over a copy of that smtp log from hmailserver and we'll have a look at it.

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-26 15:05

actually - it might also be helpful to have a look at the smtp conversation on the exchange side as well.. but that's secondary to the hmailserver log.

delete the existing one, attempt to send your message from the computer that it doesn't work from and then copy and paste that here.. you'll find the logs under c://program files/hmailserver/logs

qdoest
New user
New user
Posts: 3
Joined: 2004-07-26 13:16

Post by qdoest » 2004-07-26 15:08

Yes my dns server is also my exchange server.

"DEBUG" 828 "2004-07-26 15:08:17.299" "SMTPDeliverer::_GetPendingMessageCount()"
"DEBUG" 828 "2004-07-26 15:08:17.299" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:08:17.299" "MySQLRecordset::~Open() - E4"
"DEBUG" 828 "2004-07-26 15:08:17.299" "SMTPDeliverer::~_GetPendingMessageCount()"
"DEBUG" 1968 "2004-07-26 15:08:37.206" "SocketServer::Start()->~WSAWaitForMultipleEvents()"
"DEBUG" 1968 "2004-07-26 15:08:37.206" "SocketServer::Start()->WSAEnumNetworkEvents()"
"DEBUG" 1968 "2004-07-26 15:08:37.206" "SocketServer::Start()->~WSAEnumNetworkEvents()"
"DEBUG" 1968 "2004-07-26 15:08:37.206" "SocketServer::Start()->WSAAccept()"
"DEBUG" 1968 "2004-07-26 15:08:37.206" "SocketServer::Start()->~WSAAccept()"
"TCPIP" 1968 "2004-07-26 15:08:37.246" "SMTPD - Connection from 192.168.1.102 accepted."
"DEBUG" 1968 "2004-07-26 15:08:37.246" "SocketServer::Start()->WSAEnumNetworkEvents()"
"DEBUG" 1968 "2004-07-26 15:08:37.246" "SocketServer::Start()->~WSAEnumNetworkEvents()"
"DEBUG" 1968 "2004-07-26 15:08:37.246" "SocketServer::Start()->WSAWaitForMultipleEvents()"
"DEBUG" 2224 "2004-07-26 15:08:37.266" "SocketConnection::SocketConnection()"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::HandleClient()"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::_InternalHandleClient()"
"SMTPD" 2224 "2004-07-26 15:08:37.276" "192.168.1.102" "SENT: 220 (SMTP) hMailServer 3.2 2004-07-26 13:09:48"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.276" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.296" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.296" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.296" "192.168.1.102" "RECEIVED: EHLO zemblabizz.nl"
"SMTPD" 2224 "2004-07-26 15:08:37.306" "192.168.1.102" "SENT: 250-hmailserver[nl]250 AUTH LOGIN"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SMTPConnection::~_ParseASCII() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.306" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.326" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.326" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.326" "192.168.1.102" "RECEIVED: AUTH Login"
"SMTPD" 2224 "2004-07-26 15:08:37.336" "192.168.1.102" "SENT: 334 VXNlcm5hbWU6"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SMTPConnection::~_ParseASCII() - E9"
"DEBUG" 2224 "2004-07-26 15:08:37.336" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.346" "192.168.1.102" "RECEIVED: b3JkZXJzQHplbWJsYWJpenoubmw="
"SMTPD" 2224 "2004-07-26 15:08:37.346" "192.168.1.102" "SENT: 334 UGFzc3dvcmQ6"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SMTPConnection::~_ParseASCII() - E6"
"DEBUG" 2224 "2004-07-26 15:08:37.346" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.356" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.356" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.356" "192.168.1.102" "RECEIVED: emVtYmFsMzI="
"DEBUG" 2224 "2004-07-26 15:08:37.356" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.386" "MySQLRecordset::~Open() - E4"
"SMTPD" 2224 "2004-07-26 15:08:37.386" "192.168.1.102" "SENT: 235 authenticated."
"DEBUG" 2224 "2004-07-26 15:08:37.386" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.386" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.386" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.386" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.386" "SMTPConnection::~_ParseASCII() - E8"
"DEBUG" 2224 "2004-07-26 15:08:37.396" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.406" "192.168.1.102" "RECEIVED: MAIL FROM: <orders@zemblabizz.nl>"
"SMTPD" 2224 "2004-07-26 15:08:37.406" "192.168.1.102" "SENT: 250 orders@zemblabizz.nl... Sender OK"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.406" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.426" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.426" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.426" "192.168.1.102" "RECEIVED: RCPT TO: <q.doest@united-brands.nl>"
"DEBUG" 2224 "2004-07-26 15:08:37.436" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.476" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:37.476" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.476" "MySQLRecordset::~Open() - E4"
"SMTPD" 2224 "2004-07-26 15:08:37.486" "192.168.1.102" "SENT: 250 OK its for q.doest@united-brands.nl"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SMTPConnection::~_ParseASCII() - E12"
"DEBUG" 2224 "2004-07-26 15:08:37.486" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.506" "192.168.1.102" "RECEIVED: DATA"
"SMTPD" 2224 "2004-07-26 15:08:37.506" "192.168.1.102" "SENT: 354 ok send! end with <crlf>.<crlf>"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SMTPConnection::~_ParseASCII() - E17"
"DEBUG" 2224 "2004-07-26 15:08:37.506" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.546" "SocketConnection::~_WaitAndReceiveData() - E3"
"SMTPD" 2224 "2004-07-26 15:08:37.576" "192.168.1.102" "SENT: 250 Message queued (0.060 seconds)"
"DEBUG" 2224 "2004-07-26 15:08:37.576" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.576" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.576" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.576" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.586" "SocketConnection::_WaitAndReceiveData()"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "SocketConnection::~_WaitAndReceiveData() - E3"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "SMTPConnection::_ParseASCII()"
"SMTPD" 2224 "2004-07-26 15:08:37.596" "192.168.1.102" "RECEIVED: QUIT"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "Messages::Save()"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "Messages::Save() - Message iteration."
"DEBUG" 2224 "2004-07-26 15:08:37.596" "PersistentMessageADO::SaveObject()"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.596" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "PersistentMessageADO::~SaveObject() - E2"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "Messages::~Save()"
"SMTPD" 2224 "2004-07-26 15:08:37.606" "192.168.1.102" "SENT: 221 goodbye"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "SocketConnection::_SendData()"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "SocketConnection::_SendBinaryData()"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "SocketConnection::~_SendBinaryData() - E5"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "SocketConnection::~_SendData() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.606" "SMTPConnection::~_ParseASCII() - E3"
"DEBUG" 828 "2004-07-26 15:08:37.636" "SMTPDeliverer::_GetPendingMessageCount()"
"DEBUG" 828 "2004-07-26 15:08:37.636" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.636" "SocketConnection::~SocketConnection()"
"DEBUG" 828 "2004-07-26 15:08:37.636" "MySQLRecordset::~Open() - E4"
"DEBUG" 828 "2004-07-26 15:08:37.636" "SMTPDeliverer::~_GetPendingMessageCount()"
"DEBUG" 828 "2004-07-26 15:08:37.636" "SMTPDeliverer::_GetNextMessage() "
"TCPIP" 2224 "2004-07-26 15:08:37.636" "SMTPD - Connection to client 192.168.1.102 closed."
"DEBUG" 828 "2004-07-26 15:08:37.646" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:08:37.646" "MySQLRecordset::~Open() - E4"
"DEBUG" 828 "2004-07-26 15:08:37.646" "PersistentMessageADO::ReadObject()"
"DEBUG" 828 "2004-07-26 15:08:37.686" "PersistentMessageADO::_ParseRecipient()"
"DEBUG" 828 "2004-07-26 15:08:37.726" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:08:37.726" "MySQLRecordset::~Open() - E4"
"DEBUG" 828 "2004-07-26 15:08:37.726" "PersistentMessageADO::~_ParseRecipient() - E2"
"DEBUG" 828 "2004-07-26 15:08:37.726" "PersistentMessageADO::~ReadObject()"
"DEBUG" 828 "2004-07-26 15:08:37.726" "SMTPDeliverer::~_GetNextMessage() "
"DEBUG" 828 "2004-07-26 15:08:37.736" "SMTPDeliverer::_GetPendingMessageCount()"
"DEBUG" 828 "2004-07-26 15:08:37.736" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:08:37.736" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:37.736" "SMTPDeliverer::DeliverMessage() "
"APPLICATION" 2224 "2004-07-26 15:08:37.736" "SMTPDeliverer - Message 44: Delivering message from orders@zemblabizz.nl to q.doest@united-brands.nl."
"DEBUG" 2224 "2004-07-26 15:08:37.736" "SMTPDeliverer::_SubmitSingleMessage()"
"DEBUG" 2224 "2004-07-26 15:08:37.736" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:08:37.736" "SMTPDeliverer::~_GetPendingMessageCount()"
"DEBUG" 2224 "2004-07-26 15:08:37.776" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:37.776" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:37.776" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:37.776" "VirusScanner::Scan()"
"DEBUG" 2224 "2004-07-26 15:08:37.776" "VirusScanner::~Scan() - E1"
"DEBUG" 2224 "2004-07-26 15:08:37.786" "SMTPDeliverer::_RelayMessage()"
"DEBUG" 2224 "2004-07-26 15:08:37.786" "DNSResolver::GetEmailServers()"
"TCPIP" 2224 "2004-07-26 15:08:37.786" "DNSResolver - MX Lookup: united-brands.nl"
"TCPIP" 2224 "2004-07-26 15:08:37.796" "DNSResolver - MX Lookup result for united-brands.nl: 0 servers"
"DEBUG" 2224 "2004-07-26 15:08:37.796" "DNSResolver::~GetEmailServers()"
"DEBUG" 2224 "2004-07-26 15:08:37.796" "SMTPDeliverer::_DeliverSingleMessageToRemoteServer()"
"APPLICATION" 2224 "2004-07-26 15:08:58.745" "SMTPDeliverer - Message 44: Failed to connect to united-brands.nl."
"DEBUG" 2224 "2004-07-26 15:08:58.745" "SMTPDeliverer::~_DeliverSingleMessageToRemoteServer() - E3"
"DEBUG" 2224 "2004-07-26 15:08:58.745" "SMTPDeliverer::~_RelayMessage() - E1"
"DEBUG" 2224 "2004-07-26 15:08:58.745" "SMTPDeliverer::~_RelayMessage() - E6"
"DEBUG" 2224 "2004-07-26 15:08:58.745" "SMTPDeliverer::_SenderWantReturnConversation()"
"DEBUG" 2224 "2004-07-26 15:08:58.745" "MySQLRecordset::Open()"
"DEBUG" 2224 "2004-07-26 15:08:58.745" "MySQLRecordset::~Open() - E4"
"DEBUG" 2224 "2004-07-26 15:08:58.755" "SMTPDeliverer::~_SenderWantReturnConversation()"
"APPLICATION" 2224 "2004-07-26 15:08:58.755" "SMTPDeliverer - Message 44: Message could not be delievered. Scheduling it for later delivery."
"DEBUG" 2224 "2004-07-26 15:08:58.755" "PersistentMessageADO::SetNextTryTime()"
"DEBUG" 2224 "2004-07-26 15:08:58.755" "PersistentMessageADO::~SetNextTryTime()"
"DEBUG" 2224 "2004-07-26 15:08:58.755" "SMTPDeliverer::~DeliverMessage() - E2"
"DEBUG" 828 "2004-07-26 15:09:37.748" "SMTPDeliverer::_GetPendingMessageCount()"
"DEBUG" 828 "2004-07-26 15:09:37.748" "MySQLRecordset::Open()"
"DEBUG" 828 "2004-07-26 15:09:37.748" "MySQLRecordset::~Open() - E4"
"DEBUG" 828 "2004-07-26 15:09:37.748" "SMTPDeliverer::~_GetPendingMessageCount()"

polarunion
Normal user
Normal user
Posts: 245
Joined: 2004-04-05 20:21
Location: Ottawa, Canada
Contact:

Post by polarunion » 2004-07-26 15:34

Code: Select all

"TCPIP" 2224 "2004-07-26 15:08:37.796" "DNSResolver - MX Lookup result for united-brands.nl: 0 servers"

that was in the last few lines... try doing this with another dns server and see if you get the same results.. i doubt that you will. I dont' know a whole lot about dns servers - but maybe you can check to see if united-brands.nl is listed in the dns server that you have hmailserver pointing to.

this is not an application problem - this is a dns resolving problem. let us know what you dig up.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-07-26 23:20

This _could_ be a application problem but Polarunion is right that it doesn't seem to do so. hMailServer does a simple MX lookup but can't find any server. :-\

What OS are you using (Windows version)
What's the IP of your DNS server? (I can connect to it and see if I get the same error)

Post Reply