550 Sender verify failed - Allow blank sender address is on

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
dennismeng
New user
New user
Posts: 17
Joined: 2004-05-05 11:50

550 Sender verify failed - Allow blank sender address is on

Post by dennismeng » 2006-08-01 14:36

Hi,

When sending to a specific domain, I keep getting the error message "Message: 550 Sender verify failed.".

I read it should be solved, if I check on the allow blank sender address.
Unfortunately, this didn't change anything, even though I restartet the Hmailserver.
I'm running ver. 4.2 of Hmailserver on a Win2003 server.

Snip from log looks like this:
**********************
"SMTPC" 2668 "2006-08-01 11:26:20.296" "64.118.84.14" "SENT: HELO boogies.dk"
"SMTPC" 2668 "2006-08-01 11:26:20.406" "64.118.84.14" "RECEIVED: 250 drive17.trustyservers.com Hello boogies.dk [80.196.193.130]"
"SMTPC" 2668 "2006-08-01 11:26:20.406" "64.118.84.14" "SENT: MAIL FROM:<xxxxx@boogies.dk>"
"SMTPC" 2668 "2006-08-01 11:26:20.515" "64.118.84.14" "RECEIVED: 250 OK"
"SMTPC" 2668 "2006-08-01 11:26:20.515" "64.118.84.14" "SENT: RCPT TO:<yyyy@kel-elethnion.org>"
"SMTPD" 8312 "2006-08-01 11:26:20.875" "127.0.0.1" "SENT: 220 Boogies.dk Mailserver"
"SMTPD" 8312 "2006-08-01 11:26:20.984" "127.0.0.1" "RECEIVED: HELO [127.0.0.1]"
"SMTPD" 8312 "2006-08-01 11:26:20.984" "127.0.0.1" "SENT: 250 Hello."
"SMTPD" 8312 "2006-08-01 11:26:21.093" "127.0.0.1" "RECEIVED: MAIL FROM:<>"
"SMTPD" 8312 "2006-08-01 11:26:21.093" "127.0.0.1" "SENT: 550 sender address must be specified."
"SMTPD" 8312 "2006-08-01 11:26:21.218" "127.0.0.1" "RECEIVED: QUIT"
"SMTPD" 8312 "2006-08-01 11:26:21.218" "127.0.0.1" "SENT: 221 goodbye"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-Callback setup failed while verifying <xxxxx@boogies.dk>"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-Called: 80.196.193.130"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-Sent: MAIL FROM:<>"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-Response: 550 sender address must be specified."
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-The initial connection, or a HELO or MAIL FROM:<> command was"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-rejected. Refusing MAIL FROM:<> does not help fight spam, disregards"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-RFC requirements, and stops you from receiving standard bounce"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-messages. This host does not accept mail from domains whose servers"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-refuse bounces."
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550 Sender verify failed"
"APPLICATION" 2668 "2006-08-01 11:26:21.250" "SMTPDeliverer - Message 86196: Message delivery thread completed."

**********

What can possibly be wrong? :)

Regards,
Dennis

koncept
Normal user
Normal user
Posts: 185
Joined: 2006-06-02 23:41
Contact:

Post by koncept » 2006-08-01 15:22

i think these lines here tell you exactly why

Code: Select all

"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-The initial connection, or a HELO or MAIL FROM:<> command was"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-rejected. Refusing MAIL FROM:<> does not help fight spam, disregards"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-RFC requirements, and stops you from receiving standard bounce"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-messages. This host does not accept mail from domains whose servers"
"SMTPC" 2668 "2006-08-01 11:26:21.234" "64.118.84.14" "RECEIVED: 550-refuse bounces." 

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2006-08-01 19:41

(You have disabled "Allow empty sender address" in the SMTP/AntiSpam settings. This setting is enabled by default and you should enable it again if you want to be able to send to that email.)

User avatar
[PT]Cableguy
New user
New user
Posts: 25
Joined: 2007-02-22 11:09
Location: Portugal

Post by [PT]Cableguy » 2007-02-22 15:34

Hi there:

I'm experiencing some problems sending emails from my internal mail server to my external server.
I don't know what the problem is, since i CAN send emails from my local account to GMAIL.com accounts, but when i send to ######.pt it shows this message:
Your message did not reach some or all of the intended recipients.

Sent: Thu, 22 Feb 2007 13:26:38 -0000
Subject: test between domains

The following recipient(s) could not be reached:

bruno.vaz@######.pt
Error Type: SMTP
Error Description: Error message from remote server
Message: 550 Sender verify failed.
What can i do on my server to allow the delivery from my internal mail ?

btw: i have ENABLED: "Allow empty sender address" and DISABLED: "Check that sender has DNS-MX records".
Thanks in advance. :wink:
Last edited by [PT]Cableguy on 2007-03-05 15:47, edited 1 time in total.
aka: Bruno Vaz

hMailServer-4.3.1-B253 + phpwebadmin + roundcubemail-0.1beta2.2 + clamwin-0.88.7

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-22 15:59

http://www.hmailserver.com/documentatio ... r_messages

Check section Sender verification failed.

User avatar
[PT]Cableguy
New user
New user
Posts: 25
Joined: 2007-02-22 11:09
Location: Portugal

Post by [PT]Cableguy » 2007-02-22 17:33

WOW, thanks for the fast reply martin. :wink:
Sender verification failed wrote:3 - The recipients SMTP server looks up a MX record for the domain example.com.
Duhhhh....sometimes i feel so dumb. :roll:
Obviously there isn't any domain.private online...so i've done the following:

1 - Instaled and configured DynamicDNS client (no-ip.org)
2 - Created a new domain using the dynamicdns
3 - Created one email account for testing
4 - Configured email-client for the dynamicdns
5 - Sent an email to the server online

SUCCESSS !!!! Thanks a bunch for this amazing software and support.
You're the MAN....martin. :wink:
aka: Bruno Vaz

hMailServer-4.3.1-B253 + phpwebadmin + roundcubemail-0.1beta2.2 + clamwin-0.88.7

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-22 18:18

You're welcome. =)

intothemiddle
New user
New user
Posts: 4
Joined: 2007-05-01 18:26

SMTP Issue

Post by intothemiddle » 2007-05-01 18:37

Hi,

The mail server has been up and running for some time without issue.

I've checked out the topic and forum on it and everything seems to be fine. It only seems to happen on select address entries.

Can anyone shine light on it?

I've tried the switching 'check DNS-MX records' and 'allow empty sender address'... currently I have 'check DNS-MX' UNTICKED, and allow empty sender address TICKED.

I've also UNTICKED spf.

Hope you can help. Seems to have just started naturally occuring that we've had a few members of staff being unable to send to a few people.

Rob

------------

Your message did not reach some or all of the intended recipients.
Sent: Tue, 1 May 2007 14:35:31 +0100
Subject: Random Subject

The following recipient(s) could not be reached:
*@*.co.uk
Error Type: SMTP
Error Description: Error message from remote server
Message: 550 Sender verify failed.

MailDaemon
hMailServer

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-05-01 18:39

You should have "Allow empty sender address" switched on.

If the MX records for your domain isn't set up properly, you'll get this problem.

intothemiddle
New user
New user
Posts: 4
Joined: 2007-05-01 18:26

Post by intothemiddle » 2007-05-02 10:40

Empty sender is ticked/switched on.

As I said, the domain and mail server had been working for over a year!

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-05-02 11:53

From the error it shows
Error Description: Error message from remote server
Message: 550 Sender verify failed.
That error is from the server you are trying to send to. You should contact them and ask them why they are blocking you.

Also check out your DNS and SPF records just in case they are incorrect or have altered at http://dnsreport.com

intothemiddle
New user
New user
Posts: 4
Joined: 2007-05-01 18:26

Post by intothemiddle » 2007-05-02 12:07

When I try the DNS Report on that for our mail.website.com I get:

ERROR: The parent servers say that the domain mail.*.com does not have any NS records (although they may have some other information on that zone). I can not do a DNS report on a hostname (such as mail.example.com) or a domain name that does not have its own zone.]

And the mail test resulted in:

Getting MX record for mail.*.com (from local DNS server, may be cached)... There is no MX record for mail.*.com! That's bad.
Checking for an A record... Got it!

However, in the admin panel on the account I've given it an MX record?

My main problem will be that who its hosted with is impossible to contact, takes forever to get through to them (123-reg) =(

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-05-02 12:52

I use 123-reg myself to buy domains but have never used them for my DNS, I always transfer them to my own nameservers and use my own DNS. If you have the capability to run your own DNS server then I would highly recommend it.

I would say this is the reason why you are being blocked unfortunately. You will either have to persevere and try to get through to 123-reg or run your own dns server. I guess the other alternative is to use something like http://www.zoneedit.com/ but I have never attempted to use a service like this although a few others on here have recommended it before.

Post Reply