Problem to send out message

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Problem to send out message

Post by PeterChan » 2020-06-08 06:41

Hi,
I am able to send out message using Telnet but I cannot do the same in Outlook and it does keep on prompting me below, even if I've put correct user account and password.
5.png

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Problem to send out message

Post by mattg » 2020-06-08 09:20

Try sender in the form sender@example.com

If that doesn't work, then please run these diagnostics and post the results
viewtopic.php?f=20&t=30914
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-09 15:19

Hi,
Here are the details of issue encountered:
"DEBUG" 3756 "2020-06-09 16:29:35.632" "TCP connection started for session 11"
"IMAPD" 3756 11 "2020-06-09 16:29:35.632" "113.255.209.159" "SENT: * OK IMAPrev1"
"IMAPD" 3804 11 "2020-06-09 16:29:35.632" "113.255.209.159" "RECEIVED: bgt2 CAPABILITY"
"IMAPD" 3804 11 "2020-06-09 16:29:35.648" "113.255.209.159" "SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL STARTTLS NAMESPACE RIGHTS=texk[nl]bgt2 OK CAPABILITY completed"
"IMAPD" 3756 11 "2020-06-09 16:29:35.648" "113.255.209.159" "RECEIVED: 1d7g LOGIN "sender" ***"
"IMAPD" 3756 11 "2020-06-09 16:29:35.648" "113.255.209.159" "SENT: 1d7g BAD STARTTLS is required."
"DEBUG" 3804 "2020-06-09 16:29:36.460" "The read operation failed. Bytes transferred: 0 Remote IP: 113.255.209.159, Session: 11, Code: 2, Message: End of file"
"DEBUG" 3804 "2020-06-09 16:29:36.460" "Ending session 11"
and here is the error got
[SMTP] MailClient.Accounts.ConnectionException: Invalid server reply when connecting: 'Unexpected end of stream.'.
when trying to connect to hMailserver, using Thunderbird.

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Problem to send out message

Post by mattg » 2020-06-10 02:03

So Outlook or Thunderbird??

you logs say that STARTTLS is required for whatever port was used for IMAP
IN your mail client, either outlook or Thunderbird, you need to set the connection security to StartTLS (Thunderbird Outlook newer versions) or TLS (Outlook older versions) (Or SSL on iPhones, or no security in PHP)

They all use slightly different terminology unfortunately
If you need help, please list the options that you have
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-10 03:59

Hi,
What can be the reason below?
6.png

Virinum
Normal user
Normal user
Posts: 139
Joined: 2018-11-23 14:42
Location: Germany

Re: Problem to send out message

Post by Virinum » 2020-06-10 07:26

mattg wrote:
2020-06-08 09:20
Try sender in the form sender@example.com
For the username don’t just use "user". Use the full email address instead.

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-10 09:39

Hi,
I put whole email address as user name but I got same issue below
7.png

Virinum
Normal user
Normal user
Posts: 139
Joined: 2018-11-23 14:42
Location: Germany

Re: Problem to send out message

Post by Virinum » 2020-06-10 10:04

screenshot.png

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-10 11:28

Thanks a lot.
I put full email address below but I still got same issue.
8.png

Virinum
Normal user
Normal user
Posts: 139
Joined: 2018-11-23 14:42
Location: Germany

Re: Problem to send out message

Post by Virinum » 2020-06-10 12:35

mattg wrote:
2020-06-08 09:20
If that doesn't work, then please run these diagnostics and post the results
viewtopic.php?f=20&t=30914
Then please run the diagnostics script.

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Problem to send out message

Post by mattg » 2020-06-10 12:39

Probably autobanned yourself - common with Thunderbird auto testing for server details
Check your IP ranges for your IP
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-11 05:59

Hi,
I've enabled the relevant ports (in Firewall), but I still have got the following:
9.png

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Problem to send out message

Post by mattg » 2020-06-11 08:23

that not what we asked

If you continue to do what you want, rather than what we ask, we will be limited in our ability to help..
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

PeterChan
Normal user
Normal user
Posts: 87
Joined: 2018-06-23 15:45

Re: Problem to send out message

Post by PeterChan » 2020-06-11 08:45

Hi,
Sorry. See IP ranges below.
11.png

Post Reply