Page 1 of 1

Error in Log file

Posted: 2020-01-24 09:43
by PeterChan
Hi,
What to check, due to error below, in Log file?
"ERROR" 1472 "2020-01-24 11:51:45.944" "Severity: 1 (Critical), Code: HM5028, Source: ADOConnection::Connect, Description: Error when connecting to database. Microsoft OLE DB Provider for SQL Server Cannot open database "hMailserver" requested by the login. The login failed. Check your database settings in hMailServer.ini."
"ERROR" 1472 "2020-01-24 11:51:50.977" "Severity: 1 (Critical), Code: HM5028, Source: ADOConnection::Connect, Description: Error when connecting to database. Microsoft OLE DB Provider for SQL Server Cannot open database "hMailserver" requested by the login. The login failed. Check your database settings in hMailServer.ini."

Re: Error in Log file

Posted: 2020-01-24 11:23
by Dravion
Your Database Username or Password or both is wrong.

Re: Error in Log file

Posted: 2020-01-24 13:42
by PeterChan
Thanks. How to re-configure user, due to password issue?

Re: Error in Log file

Posted: 2020-01-24 17:23
by Dravion
PeterChan wrote:
2020-01-24 13:42
Thanks. How to re-configure user, due to password issue?
This goes for any Database hMailServer is supporting (except for MS-SQL-CE Internal Database).

First of all, you need to know the SQL-Database server Administrator's Username and its Password.
Only a Database Server Administrator Account can Setup a new DB Username+Password. hMailServer can and will not create a SQL-Database User for you,
so you need to type in your Database Administrators Username+Password (bad practice) or you create a Database User for hMailServer to connect with before you
are trying to install hMailServer.

Re: Error in Log file

Posted: 2020-01-27 17:30
by PeterChan
Thanks.

I did finish hMailserver setup before this. If I want to use other user account, does it mean I can re-run hMailserver to re-configure other user account?

Re: Error in Log file

Posted: 2020-01-28 03:10
by mattg
Assuming that you have no data that you wish to keep

Uninstall hMailserver
Delete hmailserver folder and all subfolders, especially the hmailserver.ini

Reinstall hmailserver