diagnostic error

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
cuiting813
New user
New user
Posts: 1
Joined: 2020-01-07 12:23

diagnostic error

Post by cuiting813 » 2020-01-07 12:26

someone who can help me ? I follow the video:
https://www.youtube.com/watch?v=ht6gK0hGfPA
every step is correct, but I have error:

Test: Collect server details
hMailServer version: hMailServer 5.6.7-B2425
Database type: MySQL

Test: Test IPv6
IPv6 support is available in operating system.

Test: Test outbound port
SMTP relayer not in use. Attempting mail.hmailserver.com:25...
Local address is 35.223.93.114.
Trying to connect to host mail.hmailserver.com...
Trying to connect to TCP/IP address 5.189.183.138 on port 25.
ERROR: Unable to bind to address 35.223.93.114.

Test: Test backup directory
ERROR: Backup directory has not been specified.

Test: Test MX records
Trying to resolve MX records for everyrains.com...
Host name found: mail.everyrains.com

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain everyrains.com...
Trying to connect to host mail.everyrains.com...
Trying to connect to TCP/IP address 35.223.93.114 on port 25.
ERROR: It was not possible to connect.
ERROR: Was not able to open connection.

Test: Test message file locations
Relative message paths are stored in the database for all messages.

Test: Test IP range configuration
No problems were found in the IP range configuration.

User avatar
nitro
Normal user
Normal user
Posts: 34
Joined: 2018-11-08 16:31
Location: Spain

Re: diagnostic error

Post by nitro » 2020-01-07 12:50

It seems a port error, check the following link to check that they are configured correctly.

https://www.hmailserver.com/forum/view ... 906cd0221d


You must also ensure that the ports are routed to your computer. If I telnet to port 25 of your ip, the server does not respond to me.
Production 5.6.8-B2489.22.RvDH W.Server 2016 Datace [2x Intel Xeon E5-2660 8GB RAM]
Staging 5.7-B2490 W.Server 2008 R2 Stand [Intel Pentium 4 4GB RAM]

User avatar
mattg
Moderator
Moderator
Posts: 20561
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: diagnostic error

Post by mattg » 2020-01-07 16:37

run this and post the results: https://www.hmailserver.com/forum/viewt ... 20&t=30914

I think you have a value in SMTP >> Advanced >> bind to
You should leave that blank unless you KNOW that you need it
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply