Page 1 of 1

Possible hMail Setting?

Posted: 2019-08-07 20:06
by dlee5400
Configuration/Layout:

1) hMailServer 5.6.7-B2425 installed on a Windows Server
2) Company uses a third-party spam service that routes emails to this server
3) Company use AfterLogic for the web mail portion
3) Company uses Outlook 365 as Windows 10 clients
4) I have developed a web-portal on IIS/.NET that sends mail via the above. When it does it CC's the company any emails it generates.
5) The IIS server and hMailServer are hosted on the same Windows Server.

The issue I have is when I send off the web-portal I receive the CC'ed emails in AfterLogic (confirming it was sent to hMailServer from IIS/.NET) but our Outlook clients doesn't receive these emails. The stranger part is we receive every other email sent to the company. I feel that there must be a setting for configuration 5 above but can't determine what it is.

Does this ring a bell with anyone?

Thanks,
David

Re: Possible hMail Setting?

Posted: 2019-08-08 01:07
by mattg
Can you please enable all logging, deliberately create the issue, wait 90 seconds and then post all logs created

Are Outlook machines definitely connecting to hMailserver?

Re: Possible hMail Setting?

Posted: 2019-08-08 15:58
by dlee5400
The Outlook clients are definitely logging in. In fact, and I hope not waste your time, I see we are receiving email from the .NET system to our "accounting" email which is hosted in Outlook. I will study the STMP client in .NET and see if there is a rule violation when it comes to the account that isn't seeing the email.

I will post below the log file just in case you see something obvious but this is looking more like a IIS/.NET mail object issue.

Re: Possible hMail Setting?

Posted: 2019-08-08 16:00
by dlee5400
Hey Matt, How do I post the Log file. The "Attachments" don't allow .LOG as a type and the Post Editor is stating too many characters?

Thanks,
David

Re: Possible hMail Setting?

Posted: 2019-08-08 16:06
by Dravion
Hit the reply button, scroll down, there is a tab at the bottom
[Options|Attachements]

Select Attachements and hit the "Add files" Button.

If log files are not allowed, put your hMailServer log files (and if you have - your other log files) into a ZIP-Archiv and attache it to your next reply.

Re: Possible hMail Setting?

Posted: 2019-08-08 16:09
by dlee5400
hmailserver_2019-08-08.zip
(93.19 KiB) Downloaded 49 times

Re: Possible hMail Setting?

Posted: 2019-08-08 16:23
by Dravion
Do you use POP3?

It looks like you use IMAP for receiving Emails with your Outlook 365 Email Client.

For clarification:
1) You use IMAP and can access all Emails sent by your IIS/ASP.NET Scripts by Afterlogic, correct?
2) Your Outlook 365 IMAP Clients cannot see the same Emails you see in Afterlogic, correct?

Hi looked at you log file. There is no hint of any Error what so ever.
There is indeed a false PTR Debug Message, but this doesn't prevent hMailServer SMTP to deliver Emails.

Looks like Outlook 365 is the Problem.

Do the following:
Download and Install Mozilla Thunderbird on 1 of the Office 365 Win10-Computer and try to access you Emails via IMAP.

PS: Don't use POP3 at this time, because POP3 will download your Email and its gone on the server while IMAP does not.

Re: Possible hMail Setting?

Posted: 2019-08-08 16:35
by dlee5400
I do use both styles. I guess I thought POP3 only allowed copy of the message where as IMAP allows manipulations such as delete etc.? This particular email box is shared by several as a central email.

Thanks,
David

Re: Possible hMail Setting?

Posted: 2019-08-08 16:37
by dlee5400
I will do as you asked on the new client. But note that its not getting delivered in any of the clients that access that inbox with or with out IMAP or SMTP.

Thanks again,
David

Re: Possible hMail Setting?

Posted: 2019-08-08 16:50
by Dravion
dlee5400 wrote:
2019-08-08 16:35
I do use both styles. I guess I thought POP3 only allowed copy of the message where as IMAP allows manipulations such as delete etc.? This particular email box is shared by several as a central email.

Thanks,
David
This can be a Problem!

The first Email Client which connects via POP3 will download all its emails locally and delete all Emails it has downloaded on
a POP3-Server.This is POP3 Default behavior and one of it's Problems (all POP3 Email Server will work like this).
Some Email Clients may have options to only fetch Emails via POP3 and not delete it on Server but, you shouldn't rely on
something like this, especially if you have shared Inboxes. That's why IMAP was invented.

Re: Possible hMail Setting?

Posted: 2019-08-10 19:18
by dlee5400
Hey ALL, thanks for the input. I am still working on this issue and will have some questions once I finish going through the client settings. We have three computers and two phones that use this particular inbox. I still have one computer to go and then I will update the post with some follow up questions to fully understand how the server is working.

Thanks,
David