Null / empty message problem

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Null / empty message problem

Post by cijiro » 2017-10-05 22:20

Hi,
some my users have trouble with mailserver (using hmailserver),
sometimes, once a week/month they have null / empty message at mailbox,
message is absolutely without content and other data at webmail,
problem is´, if this message is at mailbox, Outlook gets error at send and receive (but sending and receiving)
and
Thunderbird stops receiving new message, without error.

I try to find messages at SQL, but it's look, that messages not exist, and at data folder isn't null size files.

Only solution for this is login to mailbox through webmail a delete message, webmail says, message cannot be moved to recycle bin and must be deleted, after delete everything works again.

What I have is, what can be a source of problem and is there any solution to autodelete this messages?

Thanks Bob

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-05 23:42

Have you excluded the hmailserver data directory from AntiVIrus scanning?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-06 08:08

Hi Mattg,

thanks for reply, as I look, data directory currently not excluded, is this solution?
Can you tell me, how can I found this "missing" message? If as I thinking it's deleted by AV, file not exist, but must stay at SQL, right?
Please, let me know, how can I identify message, I need some info about the message.

I try to exclude folder, and let to know if it helps.

Thanks so much for reply.

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-06 08:10

messages are not in the SQL database, only metadata about the message is stored in the database

Does your anti-virus have a 'chest'?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-06 11:23

Hello Mattg,

I found new info, today new empty message "arrive", i found it at AV (using adaware AV) log, bud .eml is at its place and accesible,
because of it, I think this is not AV problem, what are you thinking?
Have any idea, what I can try (one solution is to try turn off AV, but I cant do that)

Thanks for ideas

PS:
and as I see, message is at slq too, but at webmail it's as empty message and mailclients not see it

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-06 12:01

Mattg,

now I found only difference from other normal message, it's MESSAGELOCKED column, ever message has 0 and only this problematic message has 1,
what this means?

Thanks

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-07 08:07

I just had a good look at my database
I had 105K+ with MessageLocked =1 out of 185K messages

(But I use IMAP)

Found this with a search >> viewtopic.php?p=96274#p96274

I stopped the hMailserver service and set all values in MessageLocked column to 0, then restarted the hMailsevrer service without issue. You could try that. How many messages have a MessageLocked value of 1?
Is there some IMAP client also connecting to your hMailserver for this account (perhaps a phone)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-07 17:17

Hi Mattg,

I had about 1200000 messages, and as I see, about 88000 has MessageLocked=1,
I have respect for changing SQL directly, but now I try to change MessageLocked from 1 to 0 for "zero" message, after HMS start nothing, changed, MessageLocked stays at 0, but nothing changed for client and webmail, then I think, that's not a problem.

There are clients what connecting through IMAP and POP3 too, if "zero" message arrive, interesting is, the smartphone get's new messages, but desktop clients not, Outlook get's error, Thunderbird stop receiving messages.

Finaly, I absolutely don't know, what can be the problem,
hardware is at good condition,
hardware has power reserve,
"zero" messages is at it's place at data folder
"zero" messages are at SQL (using MSSQL)
everything look perfect, but isn't.

Have you any idea?

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-07 18:15

supplement for previous message:
I make some scripting and I have no files at filesystem what's not at SQL, and have no SQL records for files that's not exist at filesystem, ntfs right's are OK too

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-08 02:00

So, desktop users with Thunderbird and Outlook are using POP3?


What is the message 'flag' status? >> https://www.hmailserver.com/documentati ... ct_message

I'm wondering if the message is flagged as read, and then won't download via POP3

As a hint, here is how I mark messages as read automatically in some conditions. I call this function from an account level rule.

Code: Select all

Sub MarkAsRead(oMessage)
	oMessage.Flag(1) = true
	oMessage.save
End Sub
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-08 08:03

Hi Mattg,

users with Thunderbird uses POP3 and if message arrive, client stops getting all new messages,
Outlook users using POP3 and getting error on every send/receive, and using IMAP too, and then they have not have problems to receive new messages, but have problem to open content of messages in OUtlook.

Message flag is unread, suprisly it can be changed, but nothing happens, message has only delivery date, but no subject, recipient, content, .... I'm sending screenshots from 2 webmail client's (red dot marks "zero" messages).

What is main problem, "zero" message block user for receiving new messages and I don't know about it, because at filesystem, at SQL it seems to be everything OK, and only solution for this problem is delete message through webmail, but user must tell me about it and sometimes it takes long time from user see there's a problem, tell me about and I find and delete it.
Attachments
Untitled-4.jpg
Untitled-2.jpg

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-09 03:26

I think those messages are moved to junk or spam by mail client and that folder needs to be purged...
(deleted messages aren't actually deleted, just copied to trash and marked for deletion)

ALSO, you should exclude the data directory from AntiVirus scanning -
This is NOT removing or switching off your antivirus, just stopping it from accessing messages in the data directory...
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

cijiro
New user
New user
Posts: 22
Joined: 2017-10-05 22:08

Re: Null / empty message problem

Post by cijiro » 2017-10-09 19:11

Hi Mattg,

these messages can't be moved by client, because this happens at weekend, when nobody using this account,
I tried to exclude data folder and waiting, if problem message comes again.

User avatar
mattg
Moderator
Moderator
Posts: 20000
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Null / empty message problem

Post by mattg » 2017-10-09 23:29

I mean by mail client software, not person using the system - This could be automated
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply