Cannot connect with any Outlook client anymore

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
Nautijacko
New user
New user
Posts: 4
Joined: 2016-07-17 00:54

Cannot connect with any Outlook client anymore

Post by Nautijacko » 2016-07-17 02:07

I am running 5.4.2-B1964 on a local server for at least 2 years, fetching POP3 from our Startlogic Hosting Webmail service and using their SMTP as relayer. I did not install myself, and unfortunately I do not have much experience with hMailserver. 3 days ago I deleted a few email accounts on the Startlogic server as we were not using them since a while. Unfortunately, one of this account was the account used as credential for the SMTP relayer. After deleting this account the SMTP would not work anymore (obviously). It took me a while to figure out why the SMTP was not working and changed the credentials in the settings "SMTP" "delivery of email" page as well as on the "routes" "mywebsite.com" general page.
Since then, none of the Outlook client accounts can login The window "enter your user name and password" pops up at each intent and the credentials are not working. I tried to reenter the credentials in the user accounts, and pretty much everything I could think of. I have now no access to none of our accounts and email trails. We are in dire need of help. :(

User avatar
mattg
Moderator
Moderator
Posts: 19810
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot connect with any Outlook client anymore

Post by mattg » 2016-07-17 02:17

in hMailserver accounts are in the form 'accountname@domainname.com', and not just 'accountname'

Make sure that your mail clients are doing this.
Nautijacko wrote:3 days ago I deleted a few email accounts on the Startlogic server as we were not using them since a while. Unfortunately, one of this account was the account used as credential for the SMTP relayer. After deleting this account the SMTP would not work anymore (obviously). It took me a while to figure out why the SMTP was not working and changed the credentials in the settings "SMTP" "delivery of email" page as well as on the "routes" "mywebsite.com" general page.
You probably didn't need to change the routes, just the 'SMTP Relayer' in delivery of email page.

This should NOT have affected your outlook clients in any way. You have done something else to break them.

Nautijacko wrote:I have now no access to none of our accounts and email trails. We are in dire need of help. :(
Enable all logging.

Change the password on ONE account within hmailserver under the domain >> The account
In Outlook use username in the form 'accountname@domainname.com', and not just 'accountname'
set the password as set in hMailserver, check the 'remember this password' checkbox.

If it doesn't connect, show all logging created from when you start logging until you get a connection error in Outlook
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Nautijacko
New user
New user
Posts: 4
Joined: 2016-07-17 00:54

Re: Cannot connect with any Outlook client anymore

Post by Nautijacko » 2016-07-17 07:09

I will try this in the morning and post the logs. Thanks.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Cannot connect with any Outlook client anymore

Post by percepts » 2016-07-17 14:03

if you have an hmail backup from before you did the deletes, you should be able to unzip it (if it was zipped) and look in the xml file to see exactly what the setting were before you did the delete. You can then just recreate manually that user account using the info in the xml file.

And you could of course just restore to your last backup before you did the deletes but you would lose any mails you sent/received since then if yo are using IMAP.

I am assuming you have a very recent backup from just before the deletes you did.

Nautijacko
New user
New user
Posts: 4
Joined: 2016-07-17 00:54

Re: Cannot connect with any Outlook client anymore

Post by Nautijacko » 2016-07-17 20:30

OK,
- I have changed the password of one of the accounts and setup a new outlook account for this user. look at the screen shots. I also am trying to join the .log file, but it give me an invalid file extension message.
- I also have a backup (one month old unfortunately for the full backup but daily for the data), I restored the hMailServer directory it in a new separate directory and copied over the installation in c:/Program Files (x86)/hMailServer/ all the sub directories, but the 'data' and the 'logs' directory that I left as they were. Same diference....
Attachments
outlook account setup.jpg
hMail setup Steven.jpg

User avatar
jimimaseye
Moderator
Moderator
Posts: 7950
Joined: 2011-09-08 17:48

Re: Cannot connect with any Outlook client anymore

Post by jimimaseye » 2016-07-17 22:51

Check your IP RANGES to ensure that device has not been 'banned' from previous failures (other wise you will still get this error even with correct login details).
HMS 5.6.6 B2383 on Win Server 2008 R2 Foundation, + 5.6.7-B2415 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
mattg
Moderator
Moderator
Posts: 19810
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot connect with any Outlook client anymore

Post by mattg » 2016-07-18 00:04

Copy the contents of the log file and post as text in your post, or better still use the handlers
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
Dravion
Senior user
Senior user
Posts: 1330
Joined: 2015-09-26 11:50
Location: Germany
Contact:

Re: Cannot connect with any Outlook client anymore

Post by Dravion » 2016-07-19 22:46

Make sure your hMailServer Windows Operating System doesnt block your connection attemps.

The Windows Firewall needs open Inbound and Outbound port permissions

Try the following:
1) Open a Command prompt as Administrator
2) Type in the commands starting with netsh, this will enable the needed ports
25, 110, 143, 587 for incomning and outgoing connections.

#SMTP#
netsh advfirewall firewall add rule name="SMTP" dir=in action=allow protocol=TCP localport=25
netsh advfirewall firewall add rule name="SMTP" dir=out action=allow protocol=TCP localport=25

#Submission#
netsh advfirewall firewall add rule name="SMTPS" dir=in action=allow protocol=TCP localport=587
netsh advfirewall firewall add rule name="SMTPS" dir=out action=allow protocol=TCP localport=587

#IMAP#
netsh advfirewall firewall add rule name="IMAP" dir=in action=allow protocol=TCP localport=143
netsh advfirewall firewall add rule name="IMAP" dir=out action=allow protocol=TCP localport=143

#POP3#
netsh advfirewall firewall add rule name="POP3" dir=in action=allow protocol=TCP localport=110
netsh advfirewall firewall add rule name="POP3" dir=out action=allow protocol=TCP localport=110
64-Bit builds of hMailserver

hMailServer-5.6.+ (HCD) https://github.com/hMailServer-ComDevs/hmailserver
hMailServer-5.6.+ (LTS) https://github.com/Dravion/hMailServer/releases

Post Reply