Blank Email message

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Blank Email message

Post by ahmed.elabd » 2014-07-03 08:08

I have Hmailserver 5.3 installed on Windows server 2008, I'm using MSSQL 2008 DB server.
I have like a 1750 Domains on this mail server.

I have the following two main issues that I cant get rid of.

- Some times any new/old message with attachment is just a blank page like attached.
Work around that temporarily clear this issue is to restart the Hmailserver service.

- When the Quee folder "Data" reaches the 2000 .eml files, the hmailserver hangs.

Your help I really appreciated.
Attachments
Blank Message.png
Blank Message ex..

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-07-03 10:49

Is there an ERROR log created at this time?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-07-04 01:44

This is the problem, I'm not able to trace any strange errors in that time. :(

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-07-04 02:05

Do other mail clients have the same issue with the 'blank' email at the same time?

I'm wondering if you have just exhausted your hardware capacity.
What are your hardware specs?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-10-30 12:39

I was doubting that it might be a HARDWARE issue, the I've transferred the mail to a new server with a higher specs, it was fine at the begening, but now I got the same issue. :(

I noticed that when I re-indexed all the hmail db tables, the issue was gone. "It is MSSQL 2008 DB"
Attached is a screen shot from the Taskmanger on the server.

Please I need your help to define the root cause of this issue.
Attachments
taskmgr.png

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Blank Email message

Post by percepts » 2014-10-30 17:57

what version of hmail are you using now. 5.3 is very old and has a several issues that have been fixed with latest version 5.5.2 and even better 5.6 beta.

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-11-05 10:17

I'm not sure that the update will solve this problem. also I notice that when hmailserver.exe process reaches about 1.8 GB memory usage this issue appears.

when the issue occurs, I see in the error log something like the following.

"ERROR" 27992 "2014-11-04 00:00:08.903" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 9340 "2014-11-04 00:00:17.468" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 9424 "2014-11-04 00:00:24.363" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 28392 "2014-11-04 00:00:42.943" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 8180 "2014-11-04 00:01:06.904" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 22032 "2014-11-04 00:01:27.559" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 20084 "2014-11-04 00:01:49.321" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 8564 "2014-11-04 00:02:16.543" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 23708 "2014-11-04 00:02:21.301" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 20684 "2014-11-04 00:02:24.280" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 8348 "2014-11-04 00:02:28.804" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 20612 "2014-11-04 00:02:32.299" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 22724 "2014-11-04 00:02:35.856" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 29336 "2014-11-04 00:02:38.320" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 5308 "2014-11-04 00:02:43.765" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 13772 "2014-11-04 00:02:47.836" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 12740 "2014-11-04 00:02:57.118" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 16648 "2014-11-04 00:03:06.572" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 23868 "2014-11-04 00:03:30.846" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 6460 "2014-11-04 00:03:45.167" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 15220 "2014-11-04 00:03:54.558" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 9880 "2014-11-04 00:04:15.025" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 9176 "2014-11-04 00:04:40.453" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 26296 "2014-11-04 00:04:57.675" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 23012 "2014-11-04 00:05:02.387" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 24936 "2014-11-04 00:05:07.082" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 28544 "2014-11-04 00:05:11.185" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 28864 "2014-11-04 00:05:16.099" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 5464 "2014-11-04 00:05:21.403" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."


Any Ideas please? Your help is really appreciated.

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-11-05 12:36

ahmed.elabd wrote:I'm not sure that the update will solve this problem. also I notice that when hmailserver.exe process reaches about 1.8 GB memory usage this issue appears.
There was something recently about people reaching that limit and there was something that they changed... just looking for the post
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-11-05 15:43

I'm trying to search the forum but still no clue on that memory thing :cry:
Thank you for your help, appreciated.

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Blank Email message

Post by percepts » 2014-11-05 17:27

ahmed.elabd wrote:I'm not sure that the update will solve this problem.
You're not sure so you are not going to take the advice given. Good luck.

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-11-06 08:59

You're not sure so you are not going to take the advice given. Good luck.
If you sure that this issue is in that specific version of hmail and you sure that the upgrade will do the trick, I will do it.
but the thing is this is a production server and the upgrade is not easy as you might imagine.

I have Wepsitepanel Version 1.0.1 installed and I have no options to upgrade it to a newer version that supports the new version of Hmailserver.

Thank you,

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-11-06 16:19

viewtopic.php?f=7&t=26317&p=160610#p160610
read the warnings, and the rest of the thread.


I'm not certain, but I think that this may have made into the main build in the 5.4s (Many of Bill's fixes did, although not all)
Percepts may well be correct that this has been fixed in the latest versions.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-11-09 16:00

mattg wrote:viewtopic.php?f=7&t=26317&p=160610#p160610
read the warnings, and the rest of the thread.
Thanks so much mattg, it is really appreciated, that solved my issue, I will keep it monitored.

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-11-09 16:02

so what exactly solved your issue?

Did you go with Bill's Alpha build, or did you update to latest stable?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

prisma
Senior user
Senior user
Posts: 310
Joined: 2010-07-09 13:16

Re: Blank Email message

Post by prisma » 2014-11-10 11:53

I'm surprised still nobody is asking 'Why does hmailserver consume so much memory?'. I reported a memory leak months ago while moving many emails through IMAP folders with thunderbird. This is a big problem `cause a mailserver admin can't never prevent people from moving their emails around.

Are you able to provoke a memory leak (memory increases but never decreases) while moving many emails around? Would be interesting to know that.

ahmed.elabd
New user
New user
Posts: 9
Joined: 2014-03-19 13:27

Re: Blank Email message

Post by ahmed.elabd » 2014-11-10 17:10

I modify the hmailserver.exe to set the flag : "App can handle >2gb address space"

I did it with "CFF Explorer", it's explain in this forum
=> http://www.pso-world.com/forums/showthread.php?t=199993
Before, when I just reaches the 900 MB memory usage, I face the Blank message issue.
Now the Hmailserver.exe process reaches about 1.7 GB Memory usage and I Plank Message issue is gone.

Regards,

User avatar
mattg
Moderator
Moderator
Posts: 20305
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Blank Email message

Post by mattg » 2014-11-11 00:33

Thanks
Added to github as an issue
https://github.com/hmailserver/hmailserver/issues/61
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: Blank Email message

Post by martin » 2014-11-11 12:50

This will be addressed in 5.6.
Martin Knafve
martin@hmailserver.com
https://twitter.com/knafve

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: Blank Email message

Post by martin » 2014-11-18 19:58

Just an update on this: hMailServer 5.6 will be released a bit earlier than I intended, so the fix for this issue will be included in 5.7 instead.
Martin Knafve
martin@hmailserver.com
https://twitter.com/knafve

Post Reply