Cannot send email between accounts within domain

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 01:09

I have a couple accounts setup in himailserver using outlook as clients. For example: user1@domain.com, user2@domain.com etc. If I want to use the isp smtp server to send email between user1 and user2, it will not send and it will say "SENT: -ERR Invalid command in current state."but sending outside like gmail or yahoo is o.k. One more note is if I use himailserver as smtp server instead, it can send between each other.

User avatar
mattg
Moderator
Moderator
Posts: 20794
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot send email between accounts within domain

Post by mattg » 2012-10-09 01:38

I think you are confused.
That error is for something completely different.

If the account is hosted locally, it will ALWAYS be delivered locally.

Can you please 1. show hMailserver diagnostics, and 2. enable all logging, recreate the issue, wait 90 seconds (important) and post the logs here
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 08:11

Mattg, I just did what you said. I tried to send from johnny@taiyicktiles.com to sales@taiyicktiles.com for a test message. Then, my isp server mailer-daemon@biznetvigator.com bounces back a message to johnny@taiyicktiles.com saying recipient sales@taiyicktiles.com fails permanently. If you need more info, please let me know. Thanks!
Attachments
log.rar
(7.11 KiB) Downloaded 114 times

User avatar
mattg
Moderator
Moderator
Posts: 20794
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot send email between accounts within domain

Post by mattg » 2012-10-09 08:47

In the middle of that log

Code: Select all

"DEBUG"	2028	"2012-10-09 13:52:31.644"	"Creating session 4581"
"SMTPD"	2028	4581	"2012-10-09 13:52:31.644"	"210.87.250.175"	"SENT: 220 mail.taiyicktiles.com ESMTP"
"SMTPD"	2016	4581	"2012-10-09 13:52:31.660"	"210.87.250.175"	"RECEIVED: EHLO imsantv95.netvigator.com"
"SMTPD"	2016	4581	"2012-10-09 13:52:31.660"	"210.87.250.175"	"SENT: 250-mail.taiyicktiles.com[nl]250-SIZE 20480000[nl]250 AUTH LOGIN"
"SMTPD"	1988	4581	"2012-10-09 13:52:31.675"	"210.87.250.175"	"RECEIVED: MAIL FROM:<johnny@taiyicktiles.com> SIZE=2466"
"TCPIP"	1988	"2012-10-09 13:52:31.894"	"DNS lookup: 175.250.87.210.zen.spamhaus.org, 0 addresses found: (none), Match: False"
"TCPIP"	1988	"2012-10-09 13:52:32.050"	"DNS lookup: 175.250.87.210.bl.spamcop.net, 0 addresses found: (none), Match: False"
"DEBUG"	1988	"2012-10-09 13:52:32.050"	"Spam test: SpamTestDNSBlackLists, Score: 0"
"DEBUG"	1988	"2012-10-09 13:52:32.050"	"Total spam score: 0"
"SMTPD"	1988	4581	"2012-10-09 13:52:32.081"	"210.87.250.175"	"SENT: 250 OK"
"SMTPD"	2032	4581	"2012-10-09 13:52:32.705"	"210.87.250.175"	"RECEIVED: RCPT TO:<sales@taiyicktiles.com>"
"SMTPD"	2032	4581	"2012-10-09 13:52:32.705"	"210.87.250.175"	"SENT: 530 SMTP authentication is required."
"DEBUG"	2032	"2012-10-09 13:52:32.705"	"AWStats::LogDeliveryFailure"
"SMTPD"	2012	4581	"2012-10-09 13:52:32.814"	"210.87.250.175"	"RECEIVED: RSET"
"DEBUG"	2012	"2012-10-09 13:52:32.814"	"Deleting message file"
"SMTPD"	2012	4581	"2012-10-09 13:52:32.814"	"210.87.250.175"	"SENT: 250 OK"
"TCPIP"	2028	"2012-10-09 13:52:32.861"	"TCPConnection - Posting AcceptEx on 0.0.0.0:25"
Your mail client didn't try to authenticate when sending
What mail client are you using?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 09:31

We use outlook 2003

User avatar
mattg
Moderator
Moderator
Posts: 20794
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot send email between accounts within domain

Post by mattg » 2012-10-09 09:57

From memory

In outlook >>account settings >> [Select the account] >> view or change >> more options >> Sending >> check 'my servers requires authentication', then check 'same as POP3'
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 10:50

It still does not work. I thought that setting only means the smtp server needs to login in order to send but my isp smtp does not need any authenication. Here is the log.
Attachments
hmailserver_2012-10-09.rar
(112.79 KiB) Downloaded 95 times

User avatar
Rainer
Normal user
Normal user
Posts: 166
Joined: 2007-06-21 13:40
Location: Zweibrücken - Germany

Re: Cannot send email between accounts within domain

Post by Rainer » 2012-10-09 11:46

Hello, maybe your IP is blocked by auto-ban!
Rainer Noa

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 11:53

Auto banned by who? Please specific.

User avatar
Rainer
Normal user
Normal user
Posts: 166
Joined: 2007-06-21 13:40
Location: Zweibrücken - Germany

Re: Cannot send email between accounts within domain

Post by Rainer » 2012-10-09 12:05

Hello johnyu2012,

please look in the admin-window for the Advanced-item.
Click on the + and then click on IP-Ranges - then you can see your IP-Ranges.
Maybe your IP blocked by the auto-ban-function; IP-Ranges created by the Auto-Ban-Function are red!
The settings for auto-ban you can find under: Acvanced/Auto-ban.
Rainer Noa

User avatar
mattg
Moderator
Moderator
Posts: 20794
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Cannot send email between accounts within domain

Post by mattg » 2012-10-09 12:34

johnyu2012 wrote:I thought that setting only means the smtp server needs to login in order to send but my isp smtp does not need any authenication.
The log earlier showed a mail client logging into a hMailserver, not logging onto your ISP SMTP server.

For future logs shown here, please rename the old log in your log directory, before you run further tests. That latest log is too large to work with effectively and look for any errors. That latest log is nearly 2 Mb.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 14:17

Here is the new log with much smaller size. Thanks!
Attachments
hmailserver_2012-10-09.zip
(6.44 KiB) Downloaded 96 times

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Cannot send email between accounts within domain

Post by ^DooM^ » 2012-10-09 14:28

According to that log you are not authenticating in your client.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

johnyu2012
Normal user
Normal user
Posts: 101
Joined: 2012-09-11 06:33

Re: Cannot send email between accounts within domain

Post by johnyu2012 » 2012-10-09 14:59

I solve the problem. In the ip range of the default internet range, I uncheck the require smtp authenication for local to local address then it works. I try to create a range for my lan and uncheck this setting, it does not work. I think it is because I am using the isp smtp server so it is not within the lan. Thank you for all the help anyway!

Post Reply