530 SMTP authentication is required

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
trev.pope
New user
New user
Posts: 5
Joined: 2012-04-19 09:48

530 SMTP authentication is required

Post by trev.pope » 2012-04-19 09:53

Hi,

I've successfully set up hmailserver, I can send and receive emails through an email client no problem at all.

But, when emails are attempted to be sent from my e-commerce platform it fails with '530 SMTP authentication is required', the e-commerce platform is using PHP and the mail() function, does anyone have any idea why this might be happening?

Many thanks

Trev

User avatar
mattg
Moderator
Moderator
Posts: 21113
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: 530 SMTP authentication is required

Post by mattg » 2012-04-19 12:09

is the ecommerce platform on the same server? different machine same LAN? or internet?

What IP range settings do you have?
Please list all IP ranges and their individual settings
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

trev.pope
New user
New user
Posts: 5
Joined: 2012-04-19 09:48

Re: 530 SMTP authentication is required

Post by trev.pope » 2012-04-19 20:50

Code: Select all

"SMTPD"	2592	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"SENT: 220 home2roost.co.uk ESMTP"
"SMTPD"	2592	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"RECEIVED: HELO WIN-AELV6L10RE7"
"SMTPD"	2592	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"SENT: 250 Hello."
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"RECEIVED: MAIL FROM:<sales@domain.co.uk>"
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"SENT: 250 OK"
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"RECEIVED: RCPT TO:<trev.pope@domain.com>"
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"SENT: 530 SMTP authentication is required."
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"RECEIVED: QUIT"
"SMTPD"	3556	2122	"2012-04-19 19:26:50.477"	"217.194.213.13"	"SENT: 221 goodbye"
Here is what the log says.

And i've attached two images detailing my settings.

Thank you.
Attachments
settings2.jpg
settings1.jpg

trev.pope
New user
New user
Posts: 5
Joined: 2012-04-19 09:48

Re: 530 SMTP authentication is required

Post by trev.pope » 2012-04-19 21:05

The e-commerce is running on the same machine, a VPS.

The 'local to external email address' checkbox was checked under IP Ranges/Internet under 'Require SMTP Authentication', i have unchecked this and it now works, but am I leaving the server open to being used to send spam email doing this?

Many thanks

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: 530 SMTP authentication is required

Post by ^DooM^ » 2012-04-19 23:56

"217.194.213.13" "RECEIVED: MAIL FROM:<sales@domain.co.uk>"
That ip is not 127.0.0.1
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

trev.pope
New user
New user
Posts: 5
Joined: 2012-04-19 09:48

Re: 530 SMTP authentication is required

Post by trev.pope » 2012-04-20 13:02

Very true. That must mean that the e-commerce software fires the mail away from the server only to come back in as that IP is that of the server. The e-commerce software is set up to use 'localhost' so any idea's how this is happening?

Unchecking the tick box mentioned earlier has solved the problem allowing me to send from local email address to external email address but I am concerned that this could leave it open to being used to send spam email, is this possible?

Cheers

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: 530 SMTP authentication is required

Post by ^DooM^ » 2012-04-20 13:20

The only box that should not be ticked for auth is external to local. All others should be ticked.

Add a new IP range with 217.194.213.13 as the upper and lower ip address, give it a priority of 30 and disable authentication as you please. This will only allow email from that single IP to send without auth.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

trev.pope
New user
New user
Posts: 5
Joined: 2012-04-19 09:48

Re: 530 SMTP authentication is required

Post by trev.pope » 2012-04-20 14:49

Cheers Doom, i'll give this a go tonight - much appreciated!!

jr3151006
Normal user
Normal user
Posts: 31
Joined: 2011-02-03 14:57

Re: 530 SMTP authentication is required

Post by jr3151006 » 2013-06-28 16:53

If both servers are on the same subnet, disable the option 'local to local', save and then restart the hmailserver.

User avatar
mattg
Moderator
Moderator
Posts: 21113
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: 530 SMTP authentication is required

Post by mattg » 2013-06-29 01:09

jr3151006 wrote:If both servers are on the same subnet, disable the option 'local to local', save and then restart the hmailserver.
Ah NO
local to local in hMailserver isn't talking about LAN IP addresses. local to local is talking about from a domain hosted on the hmailserver, to a domain hosted on the hmailserver. It is about email addresses, not IP addresses
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply