Help. Outlook cannot connect to hMailServer

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Help. Outlook cannot connect to hMailServer

Post by associates » 2011-12-19 01:21

Hi,

I desperately need your help. I have problem with my Outlook 2010 connecting to the hMailServer 5.3-B1617. However, I can login through squirrelmail. But when I open out Outlook, i received an error message saying "Outlook cannot synchronize subscribed folders. Error: Cannot connect to the server".

I have subnet of 8 IP addresses. The mail server running hMailServer is assigned to a static IP address of 123.76.54.162. And I have a Netgear router assigned to a static IP address of 123.76.54.163.

All LAN network sits behind the Netgear router. I have disabled the firewall on both ends (my laptop and the mail server).

I am at a loss. So just wonder if anyone might be able to help me out.

Thank you in advance

User avatar
mattg
Moderator
Moderator
Posts: 21268
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Help. Outlook cannot connect to hMailServer

Post by mattg » 2011-12-19 01:45

On the machine with Outlook can you telnet the machine with hMailserver?

I'm guessing not.
Probably due to the router not allowing 'loopback'
a quick and dirty fix is to add the IP address of your hmailserver to the C:\Windows\system32\Drivers\etc\hosts file, or use the IP address of the hmailserver in your Outlook account settings.

If you can telnet, then
enable all logging in hmailserver, try to connect again from outlook and post the logs please
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Re: Help. Outlook cannot connect to hMailServer

Post by associates » 2011-12-19 01:51

Hi,

I do not know why but it works now. I just deleted my email account from the Outlook and recreated it, and it worked right away. I found that I need to recreate email account when there is a connection issue.

But if there are any other explanation to this. Love to hear about it.

Thank you

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Re: Help. Outlook cannot connect to hMailServer

Post by associates » 2011-12-19 01:55

Thank you Mattg for your reply.

Yes, when I got stuck, I did try to ping the server from my laptop and I did get replies back. Like I said, if I did not use Outlook to check mails but use squirrelmail instead, I would not have noticed if there were some issues with outlook connecting to the server.

Many thanks

User avatar
mattg
Moderator
Moderator
Posts: 21268
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Help. Outlook cannot connect to hMailServer

Post by mattg » 2011-12-19 01:59

Glad you got it working

FYI 'ping' is different than 'telnet', and either of those will operate in isolation and give different results, depending on settings
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply