cannot connect to outgoing SMTP server

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

cannot connect to outgoing SMTP server

Post by associates » 2011-04-12 08:04

Hi,

I am running hMailServer version 5.3-B1617 at the moment as my mail server. I have a question I need help with.

Since I use Outlook 2010 to check all my emails at my office, I have had problem with sending from my Outlook when I am not in the office, in particularly, at my client's premises where I could get some Internet connection there. I believe I've got all the settings (incoming server and outgoing server (SMTP)) correctly configured in my Outlook.

I keep getting the error message saying Outlook cannot connect to the outgoing SMTP server.

I wonder if there are any ways of getting around this problem.

Any help would be greatly appreciated.

Thank you in advance

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: cannot connect to outgoing SMTP server

Post by mattg » 2011-04-12 08:22

This is possibly because the ISP that you are connecting through is blocking port 25 traffic.

Set hMailserver to ADDITIONALLY use port say 2525 for SMTP, and set that same port number in Outlook account settings...
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Re: cannot connect to outgoing SMTP server

Post by associates » 2011-04-13 01:18

Thanks Mattg for your reply.

I've given my provider a call to request if they could unblock port 25 for me and they did it for me on the spot. This was yesterday afternoon at around 3:30pm. If it worked, I'd have expected to be able to send emails out by now and I checked it again today with outlook but with no luck so far.

Anyway, they told me to use SMTP roaming: mailr.westnet.com.au, port no: 2525.

I logged into hMailServer Administrator > Settings > Protocols > SMTP. In the Delivery of e-mail, I put that roaming into the SMTP relayer and clicked Save. This did not work either.

I do not know if this is to do with ASSP blocking the traffic. I have ASSP installed to prevent spam from getting through.

Just to double check with you - is it under Settings > Advanced > TCP/IP ports to add another port 2525 for SMTP with TCP/IP address 0.0.0.0.

Thank you very much for your help. really appreciated it.

User avatar
mattg
Moderator
Moderator
Posts: 21257
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: cannot connect to outgoing SMTP server

Post by mattg » 2011-04-13 07:44

associates wrote:Just to double check with you - is it under Settings > Advanced > TCP/IP ports to add another port 2525 for SMTP with TCP/IP address 0.0.0.0.
Yep

You will also need to forward this new port from your router to your server and allow traffic for it through the firewall.

Unless you use the SMTP relayer normally, leave that blank.
The problem that I suspect is that you cant reach your hmailserver, not that your hmailserver can't reach outwards...
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

Post Reply