hMailServer crashes/stops

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
blakito
Normal user
Normal user
Posts: 30
Joined: 2010-09-15 14:27

Re: hMailServer crashes/stops

Post by blakito » 2010-12-16 14:13

Glad to hear about the update !

Since i moved to Squirrel the server didnt crashed anymore so i will stick with the latest stable version for now.

Congrats for the great work, you guys are amazing.

PS. I couldnt find any donate options around the website, is there a way to contribute with this project ?

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2010-12-20 19:49

Bill,

How we making out???

Steve

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: hMailServer crashes/stops

Post by Bill48105 » 2010-12-20 20:34

You tried 5.3.4 Steve? Hadn't received any feedback since it was posted..
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

mpdyson
Normal user
Normal user
Posts: 30
Joined: 2007-01-16 14:51
Location: UK

Re: hMailServer crashes/stops

Post by mpdyson » 2010-12-20 22:03

Have been running new Beta since released with no problems/crashes.

Fingers crossed :D

Mark

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2010-12-30 20:08

Hey Bill,

Just checking in are we getting close??? I would run the beta, but I haven't had the time to setup and test here...too many other things going on! Backup solutions, etc!!!


Steve
Happy New Year!!!!!

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: hMailServer crashes/stops

Post by Bill48105 » 2010-12-30 20:26

Close to what Steve? 5.3.4 beta is out as is new 5.4 alpha, both with potential fixes for the buffer/iocp issue. I've tested & tested & tested & cannot get the buffer/iocp thing to happen but does not mean it is fixed or that there are not new/other bugs.. In addition to us spending countless hours testing we are waiting for others to test & let us know..

Often these bugs are tough to reproduce & might require very unique/specific conditions to occur (or to check that new bugs haven't been introduced..) so we rely on as many people as possible testing as possible & is point of beta/alpha releases. ;) Unfortunately seems people don't take the time to test & report back promptly so we sit & wait & wait and even then can only assume there are no bugs vs possibility people just didn't bother to take the time to test or let us know.. :shock:

Thanks, Happy New Year to you as well! :)
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

guppy
New user
New user
Posts: 10
Joined: 2009-08-05 02:46

Re: hMailServer crashes/stops

Post by guppy » 2011-01-04 18:52

Just to let you know I've been using 5.3.4 beta on two different production servers now without it crashing for about 2 weeks. This version appears to be ok and stable. I initially thought my problem was down to RoundCube being updated. They've since updated again from 0.4.2 to 0.5 RC which i'm not looking to implement right now. I'm not sure if RoundCube caused the issue or something strange with Blackberry connections via IMAP but this Beta seems to have rectified it.

Thank you Martin & Bill!

Regards,
Guppy

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: hMailServer crashes/stops

Post by Bill48105 » 2011-01-04 22:09

guppy wrote:Just to let you know I've been using 5.3.4 beta on two different production servers now without it crashing for about 2 weeks. This version appears to be ok and stable. I initially thought my problem was down to RoundCube being updated. They've since updated again from 0.4.2 to 0.5 RC which i'm not looking to implement right now. I'm not sure if RoundCube caused the issue or something strange with Blackberry connections via IMAP but this Beta seems to have rectified it.

Thank you Martin & Bill!

Regards,
Guppy
Thanks for the update Guppy. Glad to hear it is working better & hoping it stays that way. :)

It is important to note it is always a good idea to limit what all you change/update at once & to keep track of what changes when so that if problems arise you have an idea of what to focus on and maybe undo. ;)
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

codamedia
Normal user
Normal user
Posts: 83
Joined: 2006-02-11 21:34

Re: hMailServer crashes/stops

Post by codamedia » 2011-01-06 14:31

guppy wrote:Just to let you know I've been using 5.3.4 beta on two different production servers now without it crashing for about 2 weeks. This version appears to be ok and stable. I initially thought my problem was down to RoundCube being updated. They've since updated again from 0.4.2 to 0.5 RC which i'm not looking to implement right now. I'm not sure if RoundCube caused the issue or something strange with Blackberry connections via IMAP but this Beta seems to have rectified it.

Thank you Martin & Bill!

Regards,
Guppy
I just thought I would weigh in here. I don't believe that RoundCube was your problem, as I've been experiencing this problem without RC on my box. With the steady increase of this this problem over the past year or so - I would bet it is related more to Blackberry/iPhone/other connections as more and more people are using them. Of course, I'm no expert so this is pure speculation.

Thanks for this update! Glad to hear you have the beta on a production server and it is working fine - I'll have to bite the bullet and do the same (backup, backup, backup - LOL).

mpdyson
Normal user
Normal user
Posts: 30
Joined: 2007-01-16 14:51
Location: UK

Re: hMailServer crashes/stops

Post by mpdyson » 2011-01-06 14:52

I have been running the Beta on my production server since it was released and from several crashes a week I now have had none since install.

Mail levels down in past 2 week because of Christmas but up again this week so I am sure it would have crashed before by now.

Looks good to me :D

Demiurge
New user
New user
Posts: 4
Joined: 2011-01-23 17:11

Re: hMailServer crashes/stops

Post by Demiurge » 2011-01-26 10:05

I use hMailServer 5.3.4 - 1913 beta on my production server with 2 domains, 25 accounts, roundcube webmail about 2 weeks and it is stable, no crashes. hMailServer 5.3.3 crashed 1 time per week.

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2011-02-03 19:47

Bill,

I finally couldn't take it any longer...put 5.3.4 in and 12 days without any issues!!!!! About 20 mins ago I noticed that the interface didn't look quite right when I logged into the server and when I attempted to click on any thing I would see error messages like the one below:

The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

ExceptionType: COMException
HelpLine:
Message: The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))
Source: Interop.hMailServer
StackTrace: at hMailServer.StatusClass.get_UndeliveredMessages()
at hMailServer.Administrator.ucStatus.RefreshDeliveryQueue()
at hMailServer.Administrator.ucStatus.buttonRefreshDeliveryQueue_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
TargetSite: System.String get_UndeliveredMessages()

no matter what I clicked on I would get one of these...a reboot corrects it but any clues????


Steve

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: hMailServer crashes/stops

Post by martin » 2011-02-03 19:50

Did you try to just restart Administrator?

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2011-02-03 20:07

No I didn't try that...I had to step out for a bit but i wanted to add that I was getting these same errors in 5.3.3 as well...

Steve

User avatar
mattg
Moderator
Moderator
Posts: 21042
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer crashes/stops

Post by mattg » 2011-02-04 01:45

How do you you do backups of hMailserver?
Is there another reason that you might start and stop the hMailserver Service?

I find that if the hMailserver GUI is left open when the service is restarted these sort of errors occur.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2011-02-04 22:03

In fairness to the questions that you asked, when I had the 5.3.3 running I was seeing these almost everytime the program would crash. Since upgrading to the 5.3.4 version it ran for 12 days without so much as a hiccup. I attempted to check mail, and noticed that the webmail interface wasn't responding and when I logged into the server and attempted to do anything I was getting several of the error messages posted earlier. Looking at error logs system wide reveals nothing that gives me any idea what is causing this. I am happy that the system stayed functional for the 12 days that it did as I was having to reboot it 2 and 3 times a day. We are running this in VMWare and there never seems to be a problem with the machine cause you have full functionality, hmail just stops working.

ciclonite
Normal user
Normal user
Posts: 54
Joined: 2010-12-13 19:24

Re: hMailServer crashes/stops

Post by ciclonite » 2011-02-05 18:07

Hi, Have you recently installed some update to OS? Have you try to reboot VM?

kcadmin
New user
New user
Posts: 17
Joined: 2009-03-29 17:30

Re: hMailServer crashes/stops

Post by kcadmin » 2011-02-09 00:50

Standard updates were ran and when this occurs I usually just reboot the VM session. As I said previously, this issue started when I had 5.3.3 installed. The previous version of Hmail that we were running, which was 4.x.x, never had an issue like this, but in order to keep the server up to date a change was needed and here we are!

porcupine
Normal user
Normal user
Posts: 40
Joined: 2007-03-12 09:02

Re: hMailServer crashes/stops

Post by porcupine » 2011-11-25 06:44

I would like to add my experiences with the head-scratching caused by errors:
HM5136
HM4208
HM5339

Although it might seem obvious that these are network errors we automatically think that its related purely to the application and that there is nothing that we can do on the server setup side to help. As with many odd problems it can be a combination of both. Running many instances of hMailServer I had the chance to scratch my head in different ways, the problem showed itself in different ways with different frequencies on different systems:-
  • - one local admin had mistakenly installed Symantec Endpoint Protection with all of the features enabled, in this case Network Threat Protection caused the above errors.
    - one instance was running on a server that also had Netlimiter 2.0 installed, Netlimiter never worked well with hMailServer even back in v3 days but was left on the server to monitor traffic and provide reporting but caused the above errors.
    - if you are running in a VM using Vmware you should note some generally good preparations to make:
    • 1) Vmware (on Windows at least) does not like Broadcom's acceleration features, you should disable as many of the TCP/UDP/Checksum offload features as possible along with TCP Chimney.
      2) If you are using teaming you should not have the Vmware Bridge Protocol enabled on the teamed NIC, only on the individual physical NIC's.
      3) Always run the latest version of Vmware, eg Vmware Server 2.0.2 and keep the VM's at the latest hardware version, eg v7.
      4) Adding more virtual CPU's is always nice but has been known to cause some hiccups, I would say that if you have taken care of the above you should be OK but always worth reducing things back down to 1 vCPU and restest.

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: hMailServer crashes/stops

Post by Bill48105 » 2013-11-08 20:26

For anyone having IOCP crashes/hangs please try the latest experimental & give us feedback thanks!
http://www.hmailserver.com/forum/viewto ... 02#p155302
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

Post Reply