HOWTO: Use ASSP with hMailServer

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
petter
Normal user
Normal user
Posts: 41
Joined: 2006-08-04 23:39

Post by petter » 2006-08-06 22:25

I am doing: 'telnet localhost [port]' on that computer so that should not matter. But, Yes, there are no firewalls at all. This computer is sitting with static IP without anything in between.

Thanks
Petter

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-08-06 22:29

Actually, Ignore that :P I just reread what you were doing.

Naughty me for not reading properly. You need to restart hm service when you change the port (not just the server) in services.msc

User avatar
TheAngryPenguin
Senior user
Senior user
Posts: 341
Joined: 2004-10-11 20:51

Post by TheAngryPenguin » 2006-08-06 22:32

Good catch Doom. And IIRC, you also need to restart the ASSP service when you change /its/ port.

petter
Normal user
Normal user
Posts: 41
Joined: 2006-08-04 23:39

Post by petter » 2006-08-06 22:37

Doom,

Thank you for helping. Can not believe it was that easy. I have been using the control inside hMS up until now. As soon as I shutdown hMS, hMS MySQL, and ASSP. Then changed ports in hMS, then started ASSP and hMS it worked.

Not sure why restarting the hMS service inside hMS did not do it.

Thanks a million
~Petter

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-08-07 01:09

The hms admin panel just connects to the hms service. If the admin panel shut down the service instead of just "turning it off" it would no longer be connected to the service and would never be able to restart it :)

Glad you managed to get it working now ;)

Sune
Normal user
Normal user
Posts: 59
Joined: 2005-09-21 20:11
Location: Denmark
Contact:

Post by Sune » 2006-08-10 22:00

Hmm, is there any way to configure ASSP just to forward all packets (except the spam of course) to hMailServer? Currently i seem to be forced to configure all IP ranges that relay should be accepted for in ASSP, and pop-before-smtp needs a file with users as far as i can see?

My point is to be able to use the ip ranges added in hMailServer as the ones to accept relay from, and meanwhile to be able to allow users to pop-before-smtp.

nok
Normal user
Normal user
Posts: 32
Joined: 2006-04-10 22:18

Post by nok » 2006-08-15 23:41

all mail is prefixed with *** SPAM *** using ASSP 1.1.0 (the auto MSI install).


Looking to upgrade the version but i can't find a simple upgrade from ASSP 1.1.0???

minsik
Normal user
Normal user
Posts: 92
Joined: 2006-08-03 13:08
Location: South Australia

Post by minsik » 2006-09-21 14:16

had the devil of a job getting Assp to work, could install but not start the service until i acccendently found that the Assp directory but be capitals on windows xp. sp2 with all updates.


like perl addservice -i c:\assp\assp.pl c:\ASSP


this solved by problem after several days of frustrations etc!

kishoyian
New user
New user
Posts: 19
Joined: 2006-09-01 20:25

http://127.0.0.1:55555

Post by kishoyian » 2006-10-02 06:47

I have tried installing ASSP twice now and the processes go on smmothly until i come to the point of pointing my browser to http://127.0.0.1:55555 and i get the
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.
Does anybody know why????My web server is up and running ok.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-02 09:49

have you started the ASSP service?

kishoyian
New user
New user
Posts: 19
Joined: 2006-09-01 20:25

Post by kishoyian » 2006-10-02 18:59

Hi DooM,
I actually did start the using perl addservice.pl -s and following these directions.
http://www.hmailserver.com/forum/viewto ... ea0f76313a

I have a SonicWall firewall. Could this be the problem?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-02 19:05

Does the service actually start?

Have you tried disabling your firewall and trying it?

kishoyian
New user
New user
Posts: 19
Joined: 2006-09-01 20:25

Post by kishoyian » 2006-10-02 19:30

When i run the script it does not give me a message if the service was started or not but it takes me back to C:\ASSP in the command prompt. Iam assuming that it is starting. How would i i check if it is starting? Iam not by the server right now but i can access it through remote desktop so i cannot be able to physically disable it.

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2006-10-03 09:23

Have a look at:

http://assp.sourceforge.net/fom/cache/1.html

In particular it may be of your interest:

http://assp.sourceforge.net/fom/cache/3.html

In particular this is probably what you are looking for:

http://assp.sourceforge.net/fom/cache/12.html

Please use those old docs, the new Wiki is under construction.
My perfect combination:
hMailServer 5.6.1 (B2208), ASSP 1.3.3.8 (antispam), Clamav 0.98.6 (antivirus)

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-03 11:51

To check if a service is running or not goto Start->Run and type in

services.msc

and hit enter.

kishoyian
New user
New user
Posts: 19
Joined: 2006-09-01 20:25

Post by kishoyian » 2006-10-03 20:31

Hi Doom,
I checked the ASSP service and it seems to be running Anti-spam SMTP proxystatus is Started. So it must be something else. I will try iprat suggestions and report back. Thanks guys.

kishoyian
New user
New user
Posts: 19
Joined: 2006-09-01 20:25

Post by kishoyian » 2006-10-07 08:23

I still get the error mesage below when i point my broswer to http://127.0.0.1:55555 even after trying all the suggestions here.I guess i might have to look for another spam software.
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

iprat
Normal user
Normal user
Posts: 247
Joined: 2005-05-20 16:50
Location: Barcelona, EU
Contact:

Post by iprat » 2006-10-09 09:43

If you still want to run ASSP I would encourage you to write a post explaining your issues at http://assp.sourceforge.net forums, I would recommend the "HELP" forum.
My perfect combination:
hMailServer 5.6.1 (B2208), ASSP 1.3.3.8 (antispam), Clamav 0.98.6 (antivirus)

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2006-10-12 08:14

Hi,

I was wondering if i could get some advices here. After reading all the posts regarding the ASSP, i'm interested in having one for my HMailServer. I've been getting a lot of 20 to 25 spams during a day. Now, my concern is because i'm currently using Merak MailServer and all mails are in it, i'd like to transfer them all across to HMailServer. my question is do i install and set up HMailserver and ASSP first before transferring the mails over or install, set up HMailServer and transfer the mails across first and then set up the ASSP.

Your advice is greatly appreciated.

Thank you in advance

minsik
Normal user
Normal user
Posts: 92
Joined: 2006-08-03 13:08
Location: South Australia

Post by minsik » 2006-10-21 13:59

id suggest a email change first , get it all working etc then after a few days add the assp. Assp is a little bit if fiddling around and configeration to get the best out of it! Good luck
Windows XP
hmailserver (latest beta allways) (except db versions)
test config, trying to convince the boss to use hmail!
ASSP - front end SPam killer

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-21 15:01

associates wrote:Hi,

I was wondering if i could get some advices here. After reading all the posts regarding the ASSP, i'm interested in having one for my HMailServer. I've been getting a lot of 20 to 25 spams during a day. Now, my concern is because i'm currently using Merak MailServer and all mails are in it, i'd like to transfer them all across to HMailServer. my question is do i install and set up HMailserver and ASSP first before transferring the mails over or install, set up HMailServer and transfer the mails across first and then set up the ASSP.

Your advice is greatly appreciated.

Thank you in advance
I'd recommend you upgrade to 4.3 and forget about ASSP. you only get a few emails a day and setting up and training assp for 20 - 25 spam emails a day seems like a lot of work. Install 4.3 copy over your users and emails and turn on greylisting, spf and surble spam protection in hmail.

This should all but eliminate the few spam emails you get a day.

Cheers!
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

manuelc140
New user
New user
Posts: 19
Joined: 2006-03-18 03:15
Contact:

Post by manuelc140 » 2006-10-21 18:29

hi. when i set everything on test mode.. i can't send/receive emails..
im using 4.3 b240

manuelc140
New user
New user
Posts: 19
Joined: 2006-03-18 03:15
Contact:

Post by manuelc140 » 2006-10-22 09:24

finally got it working.. hehe whew...so now its on test mode. so im going to manually set spam and notspam mails right? then run rebuildspamdb.pl twice a day..should i wait for at least a week before i take it out on test mode?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-22 12:15

I waited a month before I took my test server out of test mode. Then when 4.3 came out i removed ASSP. Upto you though the longer you train it the more accurate it will be.

ansu2723
Normal user
Normal user
Posts: 51
Joined: 2004-07-15 08:53

Error

Post by ansu2723 » 2006-10-27 08:32

C:\ASSP>perl addservice.pl -i c:\assp\assp.pl c:\assp
Can't locate Win32/Daemon.pm in @INC (@INC contains: C:/Perl
b .) at addservice.pl line 1.
BEGIN failed--compilation aborted at addservice.pl line 1.

What is the problem?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-10-27 12:57

Did you do as the howto told you?
Download and install ActivePerl, version 5.6.1.638 -- in my experience, version 5.8.7.813 was unstable and kept on crashing. Grab the MSI package - registration is not required. During its install, select all defaults.

From Start>Programs>ActiveState Active Perl..., launch the "Perl Package Manager" and execute the following command:

Code: Select all

install http://www.roth.net/perl/packages/win32-daemon.ppd

Naylin
New user
New user
Posts: 2
Joined: 2006-12-08 12:06
Location: Michigan

Post by Naylin » 2006-12-08 12:18

Well try as I might, I can't get ASSP service to start....I'm running:

XP sp2
ActivePerl 5.8.8.187 (and don't really wanna change it if I don't have to)
Win32-Daemon 0.2003.06.17

I've tried all combinations of uppercase and lowercase letters in the command lines too!

Any help would be appreciated.
--Naylin

fedaykin
New user
New user
Posts: 1
Joined: 2006-12-08 13:02

Post by fedaykin » 2006-12-08 13:10

hello everyone and thanks for all the info posted above.

I have a W2k3 with hMail 4.3 and latest ASSP set up. It's working almost fine, except that I don't seem to have all the emails automatically copied in the c:\assp\spam directory. Yes, I am in Test mode. When rebuilding the database and other maintenance related task, I have noticed that the paths reported by the scripts are a bit inaccurate, like : c:\assp/spam . Notice the /. I think my problem comes from this. How can I fix this? Any idea about the auto-copy issue?
thanx.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2006-12-08 13:45

You should be asking this on the ASSP forums not the hmailserver forums.

http://sourceforge.net/forum/?group_id=69172

Naylin
New user
New user
Posts: 2
Joined: 2006-12-08 12:06
Location: Michigan

Post by Naylin » 2006-12-08 14:39

Never mind folks... I got it figured out, but not really, but what I had to do was run it as a non-service... aka just run it with:

perl assp.pl

Go into the configuration with my browser, and set all that up, and then it started as a service no problem.

Oh and btw, I figured that since this was a topic about how to set it up with hMailServer and since there's been several other questions, that it was alright to ask here... excuse me for my mistake.

Thanks anyway,
--Naylin

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2006-12-28 02:48

For those who want to use ASSP, you should follow the installation guides on ASSP website for that is going to be more up to date.
http://www.asspsmtp.org/wiki/Quick_Start_for_Win32

Also using the perl version 5.6 (mentioned in this guide) and not the latest version 5.8 will cause a "The page cannot be displayed" problem with the webinterface for versions ASSP 1.1.2 and upwards.

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-01-01 07:49

Hi,

I was wondering if i could get some help here. I've run into problem where i got an error page when trying to get to the page http:\\127.0.0.1:55555. I think i know where i made the mistake. I have extracted the ASSP_1.2.5 to C:\ASSP. Inside the C:\ASSP folder, there is another ASSP folder where it's got all the docs, .pl, and so on. I have added service to windows. So, instead of only C:\ASSP\assp.pl, it's C:\ASSP\ASSP\assp.pl. i think this is the cause. I have tried to type in on the browser http:\\localhost:55555\ASSP. This didn't work.

Then, i started it all over again by removing the C:\ASSP folder (the entire folder), re-created C:\ASSP folder, re-extracted the ASSP folder, and copy all the files from the ASSP folder to C:\ASSP. Next, run the command prompt again. I got the following message

c:\ASSP>perl addservice.pl -i c:\ASSP\assp.pl c:\ASSP
Failed to add ASSP service: The specified service already exists.

I don't know how to get this to work. My question is How to remove the service ASSP from windows XP ONLY. I hope i don't have to uninstall the ActivePERL.

Thank you in advance

Ohem
New user
New user
Posts: 5
Joined: 2006-12-16 15:30

Post by Ohem » 2007-01-01 08:23

associates wrote:Hi,

I was wondering if i could get some help here. I've run into problem where i got an error page when trying to get to the page http:\\127.0.0.1:55555. I think i know where i made the mistake. I have extracted the ASSP_1.2.5 to C:\ASSP. Inside the C:\ASSP folder, there is another ASSP folder where it's got all the docs, .pl, and so on. I have added service to windows. So, instead of only C:\ASSP\assp.pl, it's C:\ASSP\ASSP\assp.pl. i think this is the cause. I have tried to type in on the browser http:\\localhost:55555\ASSP. This didn't work.

Then, i started it all over again by removing the C:\ASSP folder (the entire folder), re-created C:\ASSP folder, re-extracted the ASSP folder, and copy all the files from the ASSP folder to C:\ASSP. Next, run the command prompt again. I got the following message

c:\ASSP>perl addservice.pl -i c:\ASSP\assp.pl c:\ASSP
Failed to add ASSP service: The specified service already exists.

I don't know how to get this to work. My question is How to remove the service ASSP from windows XP ONLY. I hope i don't have to uninstall the ActivePERL.

Thank you in advance
To remove the service, type the following in the prompt: perl addservice.pl -u

In order to make ASSP work as a service you need to install Win32::Daemon within Perl and since it's a bit hard to get i was nice enough to upload it for you: http://rapidshare.com/files/9722562/Daemon.zip.html

You need to extract all the files into the ASSP folder, and then install it through ActivePerl (you also need to specify the directory where Daemon is located, which is in the ASSP directory). Then edit the assp.pl as the HOW-TO says, then you install the service through the prompt: "perl addservice.pl -i C:\ASSP\assp.pl C:\ASSP". Afterwards it should say it's installed, then try run it with the command: "perl addservice.pl -s".

The ASSP service should be activated and running, you can confirm this by typing this in your browser, "http://127.0.0.1:55555"

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-01-02 02:09

Thank you Ohem for your reply.

I still get "IE cannot display the webpage" when typed in "http://127.0.0.1:55555" to the webbrowser. I checked the ASSP service under control panel, administrative tools, Services and it's already started (Anti-Spam Smtp Proxy - status: Started). I don't understand why i could not get in.

Ohem, i did not install win32 Daemon from the link you gave me. I actually followed the How-To which was written by TheAngryPenguin. After having installed ActivePerl-5.6.1.638-MSWin32-x86.msi, i followed the following procedure,

From Start>Programs>ActiveState Active Perl..., launch the "Perl Package Manager" and execute the following command:
Code:
install http://www.roth.net/perl/packages/win32-daemon.ppd

But strangely, the service is started with no problem at all. There must be somthing missing there. I need your help. I don't mind installing win32-daemon.zip from the site you pointed to me but i just want to make sure that i do not do the same thing twice.

Thank you in advance

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2007-01-02 03:38

raymond wrote:For those who want to use ASSP, you should follow the installation guides on ASSP website for that is going to be more up to date.
http://www.asspsmtp.org/wiki/Quick_Start_for_Win32

Also using the perl version 5.6 (mentioned in this guide) and not the latest version 5.8 will cause a "The page cannot be displayed" problem with the webinterface for versions ASSP 1.1.2 and upwards.
Quoting what I posted (4 posts ago...) :roll:

You should use the latest perl 5.8 and not 5.6.

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-01-02 09:33

Thank you Raymond for your reply.

Sorry that i did not see your post there.

I downloaded ActivePerl-5.8.8.819-MSWin32-x86-267479.msi and run it. It all went ok. However, i got problem here. In the Quick Start for Win32 doc, it says that "At the PPM (Perl Package Manger) command line". I could not find the PPM command line. I clicked on Start → Programs → Activestate Perl 5.8.8 build 819 → Perl Package Manager. A popup window of PPM showed up and it looks completely different from the windows command line. I tried to install the win32-daemon but did not know how.

Just wanna check with you whether i have downloaded the right version. I noticed that under ActivePerl 5.8.8.819, there are two version for windows
but i chose windows(x86) then MSI package.

Thank you in advance

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2007-01-02 09:48

You can open up the command prompt (windows) and type this:

Code: Select all

ppm install http://www.roth.net/perl/packages/win32-daemon.ppd
The version you have downloaded is correct.

You will also need to uninstall the ASSP service and then reinstall it before it will work.

olanjouw
Normal user
Normal user
Posts: 35
Joined: 2006-05-20 18:17

assp config

Post by olanjouw » 2007-01-08 15:42

Hi i know that this isnt the best place to ask questions about assp
Unfortunately my post in assp forum didnt get answered so hopefully the 'guru's' here can help me with my basic beginners questions

i managed to install assp on a win 2003 server
in test mode the most spam is catched (in subject i see [SPAM]***
however i have some problems with configurating

Cant find the whitelist, where is this file located?
is this in assp directory, then whitelist file isnt there
In Accept all mail i did add 127.0.0.1|213.*.*.* (local host address where is emailed from)
dont see any entries in maillog about adding to white list What is it what im doing wrong here?
update -- finally found the place where i could add manually a whiteklist address, now i have a file and additionas are automaticaaly added.



what is the spamerror? i see a errormessage in config, in the wiki is stated that you have to change this?

"Initial Configuration
At a minimum you’ll want to change values for "Web Admin Password", "Accept All Mail", "Local Domains", "Spam Error", and "Spam Addresses". "

where do i have to fill in the emailaddress where i can forward spam to so that it will be added to the filter?

Sometimes i see in maillog that an email is relay blocked from 1 pc in my network to a valid external email address? (host pc is added to accept all email) any ideas?

also spam is automaticsally placed in assp\spam folder, the assp\notspam folder isnt filled automatically.
i put manually faulted addressed emails from spam to notspam folder
is this correct?

where are the error/spam and error/notspam directories for?

Thanks for the help!

nautme
New user
New user
Posts: 5
Joined: 2007-01-18 17:53

Test mode not working properly?

Post by nautme » 2007-01-18 18:02

I've installed ASSP version 1.2.6 and ActivePerl 5.8.8.819 for hMailServer using this tutorial and the one at http://www.hmailserver.com/documentatio ... o_use_assp. I believe I'm in test mode, but as the documentation doesn't reflect the newest version of the software, I cannot be sure. I've enabled the Bayesian Test Mode, under the Test Modes option, but I'm not getting any files in the SPAM folder. In the NOTSPAM folder, I'm only getting emails that have been sent between users on my domain. I'm still getting plenty of SPAM and HAM that are not getting placed in either folder. I've reviewed the ASSP documentation, but I'm still at a loss. Any help is appreciated.

I've also posted this on the ASSP forum, but this seems a bit more active.

Thanks in advance!

nautme
New user
New user
Posts: 5
Joined: 2007-01-18 17:53

WGET

Post by nautme » 2007-01-18 21:32

One other quick question... The tutorial mentions "Download WGET for Windows and extract wget.exe to your Windows directory." There is no further mention of this. Is this used? If so, what for?

Thanks.

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2007-01-19 01:53

I would suggest you look at the installation guide on the official ASSP website. The ones located here are out of date.
http://www.asspsmtp.org/wiki/Quick_Start_for_Win32

You need to install several perl modules not just the one (win32-daemon) mentioned in these out of date guides and is possibly the reason for ASSP not working properly.

WGET is not a requirement and it isn't used.

nautme
New user
New user
Posts: 5
Joined: 2007-01-18 17:53

Post by nautme » 2007-01-19 20:40

raymond: thanks for your reply. I hadn't found that guide and it appears that it was the missing Perl packages that were the problem. Thanks for you help!

SnOOp-DiZZle
New user
New user
Posts: 2
Joined: 2007-01-30 19:42

Post by SnOOp-DiZZle » 2007-01-30 20:15

I have a questions, I seem to have this setup correctly. Once I go live and use ASSP as a proxy outbound mail works fine, all incoming mail from forein domains i.e. yahoo.com get blocked with the error relay attempt blocked for: me@localdomain. There is a immediate bounce 530 relaying not allowed.

I have set the following please tell me if I am doing something wrong:

Under Relay::
LocalDomain* [Blank]
Local Domains File: localdomains.txt
Relay Host File; Accecpt All Mail.

User avatar
nikolasd
Normal user
Normal user
Posts: 39
Joined: 2006-10-10 21:40
Location: .gr

Post by nikolasd » 2007-01-31 13:05

This is an ASSP question. You should ask on ASSP forums.

The problem is that your Relay settings are completely wrong. Check the installation instructions at http://www.asspsmtp.org/wiki/Quick_Start_for_Win32

SnOOp-DiZZle
New user
New user
Posts: 2
Joined: 2007-01-30 19:42

Post by SnOOp-DiZZle » 2007-01-31 17:33

Thanks, I got that fixed.

QuoVadis
Normal user
Normal user
Posts: 35
Joined: 2007-02-09 13:02
Location: Trier, Germany

Post by QuoVadis » 2007-03-15 10:32

Just a little script to tag the subject with the spam confidence. I needed this to adjust the "Bayesian Confidence Level". The spam prefix in ASSP must be set to [SPAM] instead of ***SPAM***.
Sub OnDeliverMessage(oMessage)
Dim strSubject

strSubject = oMessage.Subject
With oMessage

If (InStr(strSubject, "[SPAM]") > 0) Then
.Subject = Replace(strSubject, "[SPAM]", "[SPAM C=" & .HeaderValue("X-Assp-Bayes-Confidence") & "]")
.Save
End If
End With
End Sub

racman
Normal user
Normal user
Posts: 107
Joined: 2006-02-06 16:14

Post by racman » 2007-03-16 20:34

Hi All,

I am trying to install ASSP to deal with all these spam issues. I am attempting to setup assp a per theMadPenguin's tutorial but when I attempt o install assap as a service I get the following error:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\ASSP>perl addservice.pl -i C:\ASSP\assp.pl C:\ASSP
'perl' is not recognized as an internal or external command,
operable program or batch file.

C:\ASSP>


Please can anyone provide me with some help here? Perhaps, there is something am not doing correctly.

Many thanks ...

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2007-03-17 00:28

pccsq1 wrote:'perl' is not recognized as an internal or external command, operable program or batch file.
Have you installed the latest version of ActivePerl?
http://www.activestate.com/Products/ActivePerl/?psbx=1
If you have then ActivePerl (C:\Perl\bin\) should be in your windows PATH.
http://www.computerhope.com/issues/ch000549.htm

I also recommend you look at the installation guide on the official ASSP website. The ones located here are out of date.
http://www.asspsmtp.org/wiki/Quick_Start_for_Win32

racman
Normal user
Normal user
Posts: 107
Joined: 2006-02-06 16:14

Post by racman » 2007-03-17 02:17

I have installed ActivePerl. It is located in my C:\Apache2\Perl\Bin directory and not (C:\Perl\bin\) .

I have looked at the installation manual of ASSP and am following the directions but stuck where I described in my post.

Many thanks ..

raymond
Normal user
Normal user
Posts: 135
Joined: 2006-11-30 07:13
Location: Australia

Post by raymond » 2007-03-17 03:52

pccsq1 wrote:It is located in my C:\Apache2\Perl\Bin directory and not (C:\Perl\bin\) .
You can choose to add C:\Apache2\Perl\Bin to your windows PATH (http://www.computerhope.com/issues/ch000549.htm) or attempt to run perl from the installation folder. IE C:\ASSP>C:\Apache2\Perl\Bin\perl.exe addservice.pl -i C:\ASSP\assp.pl C:\ASSP

duke16
Normal user
Normal user
Posts: 40
Joined: 2007-03-20 12:13

Post by duke16 » 2007-04-18 14:26

Is it more efficient to have ASSP run Clam Antivirus or hMailServer?

chiacy
New user
New user
Posts: 2
Joined: 2007-04-21 12:56

To run ASSP as service on some W2K machine

Post by chiacy » 2007-04-22 14:49

srand wrote:Also meant to mention that this is the error from the window event log:

"Timeout (30000 milliseconds) waiting for the Anti-Spam Smtp Proxy service to connect."

Am new here. found the solution. you need to run as daemon, goto http://localhost:55555, check run as service under network setup, click apply changes at the bottom of the page, stop the daemon by clicking X on the CMD windows (somehow ^C dont work). run as service again with c:\assp> addservice.pl -s

everything should work fine.

I was setting up 2 servers, one works and the other dont. this is what I have found.

editing the assp.pl on As a Service stuff dont seems to work on W2K server but works on W2K station

Rgds,
chiacy

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-05-14 10:29

Hi,

I wonder if anyone might be able to help me out. Today, i was trying to implement the ASSP and have been trying to follow the instruction of how to set for ASSP configuration but it didn't work.

I have changed the HMS SMTP port from 25 to 125, then re-started it. After that, i re-started the ASSP service. When i did telnet 127.0.0.1 25, i got no response. Then, i changed it all back to where it was namely HMS back to 25, i got reply as follows

220 http://www.mydomain.com.au ESMTP

Have i missed out on anything? at first i thought, it might be due to the firewall. Then, i turned off the firewall and still no reply when doing the telnet.

Any ideas?

Thank you in advance

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-05-14 19:10

How did you restart hmail? You need to restart the service in services.msc not just stop and start hmail from the admin.

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-05-15 01:54

Thank you for your reply.

The way i re-started both Hmail and ASSP was via the services.msc and what i did was right-click on the Hmail and selected "restart" and i did the same way for ASSP. I have made sure ASSP to listen to 25 and Hmail changed from 25 to 125. Next, restarted them both through the services.msc.

It didn't work last night so i changed the port back to 25 for Hmail and everything's back to normal. I don't understand why it didn't reply when test the ASSP on port 25.

Any ideas as to how to troubleshoot this.

Thank you in advance

User avatar
Bram
Senior user
Senior user
Posts: 417
Joined: 2004-05-24 22:57
Location: The Netherlands
Contact:

Post by Bram » 2007-05-15 06:15

Have you sent assp to forward to port 125?
Have you put your domain in local domains (assp)?
What is the smtp (telnet port 25) response when you have assp running?
What is the smtp (telnet port 125) response when you have hmailserver running?

associates
Normal user
Normal user
Posts: 162
Joined: 2006-01-30 04:48

Post by associates » 2007-05-15 07:38

Thank you Bram for your reply.

I'm not sure if there is a forward to 125. what i changed in the ASSP administration page was
Have you sent assp to forward to port 125?
-SMTP destination: 127.0.0.1:125
-listen to Port 25
-The rest are set based on what in the "How To" install ASSP

Have you put your domain in local domains (assp)?
it said 127.0.0.1 and that should be local address i set in the ASSP administration configuration page. I left the Hmail server unchanged except for the TCP Port from 25 to 125 under settings - protocol - SMTP(delivery of e-mail)

What is the smtp (telnet port 25) response when you have assp running?
after re-starting both Hmail and ASSP through services.msc, i got nothing back in reply (just blank) in the MS-DOS command. i tried telnet port 125, no response either.

What is the smtp (telnet port 125) response when you have hmailserver running?
no replies either

The weird thing is that after stopping the ASSP service and re-starting Hmail with the port changed back to 25, it all works like before. However, i tested something different today. The ASSP service still on the stopping mode, i changed the Port in Hmail from 25 to 125 and re-started the Hmail. Surprisingly, when i did telnet 25, i got reply 220 http://www.mydomain.com.au ESMTP. Then i tried telnet 125, it said connecting to 127.0.0.1...could not open connection to the host, on port 125. connect failed. I don't understand what's happening. i thought it should've said "220 http://www.mydomain.com.au ESMTP" but it didn't when telnet 125 because i set the port to 125 in Hmail. It seems to me that no matter what port i changed it to in Hmail, it still listens to port 25.

Is this to do with Hmail or something else? i've Hmailserver 4.4 B270 set up and running.

Thank you in advance

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-05-15 10:30

I suggest running this program to see exactly what is running on what port.

http://www.microsoft.com/technet/sysint ... pView.mspx

User avatar
danny6167
Senior user
Senior user
Posts: 472
Joined: 2007-02-07 15:24
Location: Western Australia
Contact:

Post by danny6167 » 2007-05-15 12:07

there is a command line command
netstat -a -b
that should tell u the same thing
Run as administrator

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-05-15 13:27

Or Netstat. I prefur TCPView as it is easy on the eyes, free and can see at a glance what program is using what port.

Post Reply