Mail Slow to Exit Que

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
User avatar
PeterK2003
Normal user
Normal user
Posts: 126
Joined: 2005-07-20 17:08
Location: Catawissa, PA

Mail Slow to Exit Que

Post by PeterK2003 » 2010-06-29 18:14

I have noticed that both incoming and outgoing mail seems to sit in the que for a rather long time...maybe 10-15 mins.

I haven't noticed any errors in the logs.

Anyone else notice something like this?


I am running the latest beta release(5.3.3 bxxxx).

User avatar
PeterK2003
Normal user
Normal user
Posts: 126
Joined: 2005-07-20 17:08
Location: Catawissa, PA

Re: Mail Slow to Exit Que

Post by PeterK2003 » 2010-06-29 18:21

EX:

Code: Select all

"SMTPD"	1000	332	"2010-06-29 12:04:58.941"	"1.2.3.4"	"SENT: 220 Hello World!"
"SMTPD"	1000	332	"2010-06-29 12:04:59.020"	"1.2.3.4"	"RECEIVED: EHLO mail1134c.mkt003.com"
"SMTPD"	1000	332	"2010-06-29 12:04:59.020"	"1.2.3.4"	"SENT: 250-mail.xxx.com[nl]250-SIZE[nl]250 AUTH LOGIN"
"SMTPD"	1000	332	"2010-06-29 12:04:59.082"	"1.2.3.4"	"RECEIVED: MAIL FROM:<v-coifep_dcnpbpdni_fijajlc_fijajlc_a@bounce.mkt003.com>"
"SMTPD"	1000	332	"2010-06-29 12:04:59.566"	"1.2.3.4"	"SENT: 250 OK"
"SMTPD"	1000	332	"2010-06-29 12:04:59.629"	"1.2.3.4"	"RECEIVED: RCPT TO:<xxx@xxx.com>"
"SMTPD"	1000	332	"2010-06-29 12:04:59.645"	"1.2.3.4"	"SENT: 250 OK"
"SMTPD"	1000	332	"2010-06-29 12:04:59.707"	"1.2.3.4"	"RECEIVED: DATA"
"SMTPD"	1000	332	"2010-06-29 12:04:59.707"	"1.2.3.4"	"SENT: 354 OK, send."
"SMTPD"	1464	332	"2010-06-29 12:05:04.504"	"1.2.3.4"	"SENT: 250 Queued (4.797 seconds)"
"APPLICATION"	2620	"2010-06-29 12:05:04.504"	"SMTPDeliverer - Message 149448: Delivering message from v-coifep_dcnpbpdni_fijajlc_fijajlc_a@bounce.mkt003.com to xxx@xxx.com. File: C:\Server\hMailServer\Data\{2267F0FA-3835-40A4-B763-FDFB9C56C74D}.eml"
"SMTPD"	1468	332	"2010-06-29 12:05:04.691"	"1.2.3.4"	"RECEIVED: QUIT"
"SMTPD"	1468	332	"2010-06-29 12:05:04.691"	"1.2.3.4"	"SENT: 221 goodbye"
"APPLICATION"	2620	"2010-06-29 12:09:53.785"	"SMTPDeliverer - Message 149448: Message delivery thread completed."
This one took 5 mins to deliver. Is there anyway that i can tell what hmail is doing during that time?

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: Mail Slow to Exit Que

Post by Bill48105 » 2010-06-29 19:23

By time the delay happens the email receipt had already completed (quite/goodbye) but your logs don't show AntiVirus/Spam scans etc.. Do you have debug logging enabled? I'd bet one of those scans is the delay unless the sender refuses to close the connection & hmail is waiting.. Debug should show more.
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

User avatar
PeterK2003
Normal user
Normal user
Posts: 126
Joined: 2005-07-20 17:08
Location: Catawissa, PA

Re: Mail Slow to Exit Que

Post by PeterK2003 » 2010-06-29 19:38

ok i'll try that....

User avatar
PeterK2003
Normal user
Normal user
Posts: 126
Joined: 2005-07-20 17:08
Location: Catawissa, PA

Re: Mail Slow to Exit Que

Post by PeterK2003 » 2010-06-29 20:38

My virus scanning server took a crap.

Thanks

Post Reply