trouble with autoban

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
westdam
Senior user
Senior user
Posts: 728
Joined: 2006-08-01 21:24
Location: Padova, Italy
Contact:

trouble with autoban

Post by westdam » 2010-05-24 09:00

hi guys

i've got a strange error with autoban on a .1769 stable release.


i've got a hmailserver fully installed, working and configured correctly.on the same machine there's a roundcube installation working and configured correctly.

i've got 3 ip ranges set up.
internet (same as default): priority 10 accept delivery from ext to local, local to local, local to external but not external to external. needs authentication from local to ext, local to local, and for security reason external to external ( if someone can "spoof" ip address i've thought ) . external to local is NOT checked of course. antispam and anvirus is checked.


My computer (localhost): priority 99 , accept delivery from ALL , require auth from local to external, external to external, local to local. antivirus is checked, antispam is unchecked.

LAN (my lan ) : as mycomputer priority 30


autoban is ACTIVE.

autoban lockdown localhost due to too much invalid login.

why???

westdam
Senior user
Senior user
Posts: 728
Joined: 2006-08-01 21:24
Location: Padova, Italy
Contact:

Re: trouble with autoban

Post by westdam » 2010-05-24 09:26

sorry missed a thing : the login is done on roundcube webmail installed on the same machine.
the account is the same ( info@domain ) and block localhost ip address.
cant figure out why. right now i've disabled autoban.

User avatar
mattg
Moderator
Moderator
Posts: 20554
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: trouble with autoban

Post by mattg » 2010-05-24 10:14

if there is a autoban with a prioity of 20 and another IP range coving the same IP with a hogher priority the higher priority should just overrule the Autoban IP.

Did the Autoban Range actually prevent connections from Localhost?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: trouble with autoban

Post by ^DooM^ » 2010-05-24 10:48

Can you show roundcube connections in the log being denied access?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

westdam
Senior user
Senior user
Posts: 728
Joined: 2006-08-01 21:24
Location: Padova, Italy
Contact:

Re: trouble with autoban

Post by westdam » 2010-05-24 13:41

ok, i'll try tro reproduce it.

right now autoban is disabled. so i've to wait for the logs.


yeah the localhost is HIGHER ( priority 99 ) than the autoban range.(20)

Post Reply