530 SMTP authentication is required

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

530 SMTP authentication is required

Post by scarob » 2009-12-23 19:07

Hi,
i need help with my installation.

My server is not able to send mail.
In the log i read 530 SMTP authentication is required

authentication in the client is enabled (i have tested with outlook express nd thunderbird with same result).

I have a static IP
I have configured DNS (IP, MX record ecc)
The host name is correct

**************************************************

The diagnostic result is:

Test: Collect server details
hMailServer version: hMailServer 5.3-B1617
Database type: MSSQL Compact

Test: Test IPv6
IPv6 support is not available in operating system.

Test: Test outbound port
SMTP relayer not in use. Attempting mail.hmailserver.com:25
Trying to connect to host mail.hmailserver.com...
Trying to connect to TCP/IP address 216.128.26.134 on port 25.
Connected successfully.

Test: Test MX records
Trying to resolve MX records for XXXXXXXXXXXXXX...
Host name found:XXXXXXXXXXXXX

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain XXXXXXXXXXX...
Trying to connect to host XXXXXXXXXXXX...
Trying to connect to TCP/IP address 127.0.0.1 on port 25.
Connected successfully.

**************************************************
My log file:

"DEBUG" 3912 "2009-12-23 17:50:40.722" "Creating session 36"
"SMTPD" 3912 36 "2009-12-23 17:50:40.722" "82.XX.XX.XX" "SENT: 220 XXXXXXXXXXXXXX ESMTP"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "RECEIVED: XXXXXXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "SENT: 502 Use HELO/EHLO first."
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "RECEIVED: HELO XXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "SENT: 250 Hello."
"SMTPD" 3912 36 "2009-12-23 17:50:41.003" "82.XX.XX.XX" "RECEIVED: MAIL FROM: <info@xxxxxxxxx.it>"
"DEBUG" 3912 "2009-12-23 17:50:41.003" "Total spam score: 0"
"SMTPD" 3912 36 "2009-12-23 17:50:41.019" "82.XX.XX.XX" "SENT: 250 OK"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "RECEIVED: RCPT TO: <XXXXX@gmail.com>"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "SENT: 530 SMTP authentication is required."
"DEBUG" 3912 "2009-12-23 17:50:41.112" "AWStats::LogDeliveryFailure"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "RECEIVED: QUIT"
"DEBUG" 3912 "2009-12-23 17:50:41.206" "Deleting message file"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "SENT: 221 goodbye"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Closing TCP/IP socket"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Ending session 36"

******************************************

IP RANGE SETTING
Internet
Allow connection: SMTP POP3 IMAP
Other: ANTISPAM ANTIVIRUS

Allow deliveries from :
local - local = yes
local - external = yes
external - local = yes
external - external = no

SMTP require authentication
local - local = yes
local - external = yes
external - local = no
external - external = no


Can you help me please?
Last edited by scarob on 2009-12-23 19:10, edited 1 time in total.

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: 530 SMTP authentication is required

Post by martin » 2009-12-23 19:08

Your client is not using SMTP authentication...

Check that you've enabled SMTP auth and not just POP3/IMAP authentication.

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-23 19:17

Code: Select all

Your client is not using SMTP authentication...
Client auth is enable, look the image attached
Attachments
auth_image.jpg

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: 530 SMTP authentication is required

Post by martin » 2009-12-23 19:20

Well, that looks correct. Let's go back to your SMTP session again:

Code: Select all

"DEBUG" 3912 "2009-12-23 17:50:40.722" "Creating session 36"
"SMTPD" 3912 36 "2009-12-23 17:50:40.722" "82.XX.XX.XX" "SENT: 220 XXXXXXXXXXXXXX ESMTP"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "RECEIVED: XXXXXXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "SENT: 502 Use HELO/EHLO first."
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "RECEIVED: HELO XXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "SENT: 250 Hello."
"SMTPD" 3912 36 "2009-12-23 17:50:41.003" "82.XX.XX.XX" "RECEIVED: MAIL FROM: <info@xxxxxxxxx.it>"
"DEBUG" 3912 "2009-12-23 17:50:41.003" "Total spam score: 0"
"SMTPD" 3912 36 "2009-12-23 17:50:41.019" "82.XX.XX.XX" "SENT: 250 OK"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "RECEIVED: RCPT TO: <XXXXX@gmail.com>"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "SENT: 530 SMTP authentication is required."
"DEBUG" 3912 "2009-12-23 17:50:41.112" "AWStats::LogDeliveryFailure"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "RECEIVED: QUIT"
"DEBUG" 3912 "2009-12-23 17:50:41.206" "Deleting message file"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "SENT: 221 goodbye"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Closing TCP/IP socket"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Ending session 36"
You've replaced some words by XXXXX here. On the second line, it seems like you've replaced something the client sent to the server:
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "RECEIVED: XXXXXXXXXXX"

Can you tell us what it is? Your client tries to do something, which hMailServer rejects. It could be related to your problem.

If you're using a Cisco router, you should disable the SMTP fixup feature in the router. That could cause this issue.

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-23 19:30

I have no access to the router! Can i solve my problem?

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: 530 SMTP authentication is required

Post by martin » 2009-12-23 19:45

Maybe you can read my entire post and reply to it? What about those X'es?

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-24 10:55

"TCPIP" 3912 "2009-12-24 09:50:23.909" "TCPConnection - Posting AcceptEx on 0:0"
"DEBUG" 3912 "2009-12-24 09:50:23.909" "Creating session 53"
"SMTPD" 3912 53 "2009-12-24 09:50:23.909" "82.57.XXX.XX" "SENT: 220 decimo.daXXXXXXX.com ESMTP"
"SMTPD" 3912 53 "2009-12-24 09:50:24.003" "82.57.XXX.XX" "RECEIVED: HELO XXXubu"
"SMTPD" 3912 53 "2009-12-24 09:50:24.003" "82.57.XXX.XX" "SENT: 250 Hello."
"SMTPD" 3912 53 "2009-12-24 09:50:24.081" "82.57.XXX.XX" "RECEIVED: MAIL FROM: <info@XXXXXXXXonline.it>"
"DEBUG" 3912 "2009-12-24 09:50:24.081" "Total spam score: 0"
"SMTPD" 3912 53 "2009-12-24 09:50:24.097" "82.57.XXX.XX" "SENT: 250 OK"
"SMTPD" 3912 53 "2009-12-24 09:50:24.175" "82.57.XXX.XX" "RECEIVED: RCPT TO: <datXXXXXX@gmail.com>"
"SMTPD" 3912 53 "2009-12-24 09:50:24.175" "82.57.XXX.XX" "SENT: 530 SMTP authentication is required."
"DEBUG" 3912 "2009-12-24 09:50:24.175" "AWStats::LogDeliveryFailure"
"SMTPD" 3912 53 "2009-12-24 09:50:24.253" "82.57.XXX.XX" "RECEIVED: QUIT"
"DEBUG" 3912 "2009-12-24 09:50:24.253" "Deleting message file"
"SMTPD" 3912 53 "2009-12-24 09:50:24.253" "82.57.XXX.XX" "SENT: 221 goodbye"
"DEBUG" 2336 "2009-12-24 09:50:24.253" "Closing TCP/IP socket"
"DEBUG" 2336 "2009-12-24 09:50:24.253" "Ending session 53"
"TCPIP" 3952 "2009-12-24 09:50:24.675" "TCPConnection - Posting AcceptEx on 0:0"
"DEBUG" 3952 "2009-12-24 09:50:24.691" "Creating session 54"
"POP3D" 3952 54 "2009-12-24 09:50:24.691" "82.57.XXX.XX" "SENT: +OK POP3"
"POP3D" 3952 54 "2009-12-24 09:50:24.784" "82.57.XXX.XX" "RECEIVED: AUTH"
"POP3D" 3952 54 "2009-12-24 09:50:24.800" "82.57.XXX.XX" "SENT: -ERR Invalid command in current state."
"DEBUG" 3952 "2009-12-24 09:50:24.972" "Ending session 54"

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: 530 SMTP authentication is required

Post by ^DooM^ » 2009-12-24 13:44

Please PM martin with an un-altered log
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-24 14:00

i have sent un-altered log to martin this morning

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-28 13:18

no reply for me?

User avatar
mattg
Moderator
Moderator
Posts: 21367
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: 530 SMTP authentication is required

Post by mattg » 2009-12-28 15:33

It is Christmas. Much of the world stops for a few days at least....be patient.

That second log snippet is different than the first.
In the line

Code: Select all

RECEIVED: MAIL FROM: <info@xxxxxxxxx.it 
is this a local active domain and a locally hosted, active account on that domain


Also, don't forget to answer Martin's questions (bolded for your reference)
martin wrote:Well, that looks correct. Let's go back to your SMTP session again:

Code: Select all

"DEBUG" 3912 "2009-12-23 17:50:40.722" "Creating session 36"
"SMTPD" 3912 36 "2009-12-23 17:50:40.722" "82.XX.XX.XX" "SENT: 220 XXXXXXXXXXXXXX ESMTP"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "RECEIVED: XXXXXXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "SENT: 502 Use HELO/EHLO first."
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "RECEIVED: HELO XXXXXXX"
"SMTPD" 3912 36 "2009-12-23 17:50:40.894" "82.XX.XX.XX" "SENT: 250 Hello."
"SMTPD" 3912 36 "2009-12-23 17:50:41.003" "82.XX.XX.XX" "RECEIVED: MAIL FROM: <info@xxxxxxxxx.it>"
"DEBUG" 3912 "2009-12-23 17:50:41.003" "Total spam score: 0"
"SMTPD" 3912 36 "2009-12-23 17:50:41.019" "82.XX.XX.XX" "SENT: 250 OK"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "RECEIVED: RCPT TO: <XXXXX@gmail.com>"
"SMTPD" 3912 36 "2009-12-23 17:50:41.112" "82.XX.XX.XX" "SENT: 530 SMTP authentication is required."
"DEBUG" 3912 "2009-12-23 17:50:41.112" "AWStats::LogDeliveryFailure"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "RECEIVED: QUIT"
"DEBUG" 3912 "2009-12-23 17:50:41.206" "Deleting message file"
"SMTPD" 3912 36 "2009-12-23 17:50:41.206" "82.XX.XX.XX" "SENT: 221 goodbye"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Closing TCP/IP socket"
"DEBUG" 3384 "2009-12-23 17:50:41.206" "Ending session 36"
You've replaced some words by XXXXX here. On the second line, it seems like you've replaced something the client sent to the server:
"SMTPD" 3912 36 "2009-12-23 17:50:40.816" "82.XX.XX.XX" "RECEIVED: XXXXXXXXXXX"

Can you tell us what it is? Your client tries to do something, which hMailServer rejects. It could be related to your problem.

If you're using a Cisco router, you should disable the SMTP fixup feature in the router. That could cause this issue.
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: 530 SMTP authentication is required

Post by martin » 2009-12-28 19:40

The client was saying CAPA. Not sure why he X'd it out since it's not secret in any way.

Either way, your client is not using SMTP authentication. The client doesn't even try to use it.

Here's the possible reasons:
- You have not enabled SMTP authentication in your client.
- You have multiple accounts, one with SMTP auth enabled and one without.
- Some software inbetween hMailServer and your client is updating the TCP/IP traffic.

Have you tried connecting from the computer where hMailSever is running?

scarob
New user
New user
Posts: 16
Joined: 2007-06-13 09:51

Re: 530 SMTP authentication is required

Post by scarob » 2009-12-29 11:43

- You have not enabled SMTP authentication in your client.
Tested with 3 different mail client (outlook express, thunderbird, opera) with AUTHENTICATION ACTIVE
- You have multiple accounts, one with SMTP auth enabled and one without.
Only one account is currently configured on the client and on the server
Have you tried connecting from the computer where hMailSever is running?
Yes, and the server work perfectly!!!
- Some software inbetween hMailServer and your client is updating the TCP/IP traffic.
Finally i think this is the problem, but my server is hosted in a sever farm and i have no access to the firewall config.

Can i by-pass the problem without renounce the autentication?
Thank for help

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: 530 SMTP authentication is required

Post by martin » 2009-12-29 19:09

Why are you running the server in the farm if they mess up the TCP/IP traffic and doesn't let you adjust this?

You should contact them and ask them about it before you try to fix the option. Maybe they can change this behavior for you.

You could configure your email client not to use SMTP auth and configure hMailServer not to require it, but then spammers could send email through your server to other servers. Your server would get blacklisted in minutes..

Post Reply