Authentication through Active Directory...

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Authentication through Active Directory...

Post by gaganuiit » 2009-06-20 13:04

I am currently working on implementing an intranet mail server for a university.
I am using :
1. hMailServer ofcourse at the back end
2. Horde Webmail at the front end
3. And I am using XAMPP to host my mailserver.

Now i want to integrate my Active Directory users so that i am able to provide authentication thorugh active directory credentials (Username, Password).
How can i do this?
Plz help..

User avatar
mattg
Moderator
Moderator
Posts: 21114
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Authentication through Active Directory...

Post by mattg » 2009-06-20 15:59

http://www.hmailserver.com/documentatio ... ce_account
Active directory connection (near the bottom)
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Re: Authentication through Active Directory...

Post by gaganuiit » 2009-06-23 12:55

thanks brother.
I will go through it and then give u the feedbacks as to how i went about it..
If u find anything else please do post.. :)

gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Re: Authentication through Active Directory...

Post by gaganuiit » 2009-06-26 17:03

Can somebody please post me a step by step example as to how can i make users log in with their active directory accounts.
I have the Active Directory and the Mail Server both on the same server.
And what i want from a remote client is to use the same accounts for using the mail service.
I am not able to make the A.D Domain and the Mail Server Domain communicate to each other.

Reply back as i am running out of time. :|

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Authentication through Active Directory...

Post by ^DooM^ » 2009-06-26 22:44

So you connected the account to the AD domain yes?
adimg.png
adimg.png (6.11 KiB) Viewed 4549 times
All the AD integration does with hMail is use AD password for auth rather than internal. Is this what you were trying to achieve?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Re: Authentication through Active Directory...

Post by gaganuiit » 2009-06-27 13:27

I was trying to use both the username as well as the password of AD accounts to log in to mail accounts.
Have you ever tried it out.
I mean authenticating users with their AD credentials on the horde webmail account with of-course hmailserver as back end.
Anyway thanks.
Do post if u try it out.
Roflamo... :)

gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Re: Authentication through Active Directory...

Post by gaganuiit » 2009-06-29 10:58

I was trying to use the Active Directory feature of hMailServer 4.4.2 B275.
Now my scenario is:
I have a Windows Server 2003 installed.
On that very machine i have installed hMailserver, XAMPP and Horde Webmail
On this machine i have an Active Directory with domain name hpu.com.
The FQDN is server.hpu.com
Now i have a user named gagan in that active directory with an assigned password.

Now in hMailServer i have the domain hpu.com and a user gagan too.
In the Active Directory properties of that very user i am giving the details as follows:
Domain
hpu.com
User name
gagan

And now when i am trying to login into Horde with gagan's Active Directory password i am unable to do so.
Have a look at this.
Any solutions please...

The error message returned by horde webmail is:->
Login failed because your username or password was entered incorrectly.
Attachments
details.JPG
Details

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Authentication through Active Directory...

Post by ^DooM^ » 2009-06-29 11:40

username uses the full email address iirc.

http://www.hmailserver.com/forum/viewto ... =7&t=15350
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

gaganuiit
New user
New user
Posts: 28
Joined: 2009-06-20 12:34

Re: Authentication through Active Directory...

Post by gaganuiit » 2009-06-29 13:09

can you just post me an example based on my scenario that i have defined over here in my earlier post.?
and what is iirc?
Thanks for the script...

One thing more that i would like to tell you is that i used the full username i.e user@hpu.com and the A.D password corresponding to that....
But still the same error.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Authentication through Active Directory...

Post by ^DooM^ » 2009-06-29 14:39

Anything reported in the error log or debug/application logging?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

Post Reply