Upgrade from 1.2.0 to the latest version

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
goransv
New user
New user
Posts: 7
Joined: 2005-03-10 16:03
Location: Sweden
Contact:

Upgrade from 1.2.0 to the latest version

Post by goransv » 2005-03-10 16:31

Hi,
i am about to upgrade my hmail server from 1.2.0 to the latest version. I am happy with how it works, except that it sometimes stop receiving mail and the webmail hasn´t work from the begining. I am planing to test it on my own server first and then if it works as expected use it for my customers.

I se that it has happen things since I first began to use hamil. Now I wonder what I have to think of when I upgrade from 1.2.0 to the latest version? I am using mySQL server 4.0.13 on a windows 2000 server. I have not found any information when I searched this forum and the rest of the site except info about uppgrading from 3. something to 3.. somethingelse. I think that if there hasn´t been anny changes in the db it should be easy to upgrade...

Thanks in advance,

/göran

User avatar
TheAngryPenguin
Senior user
Senior user
Posts: 341
Joined: 2004-10-11 20:51

Post by TheAngryPenguin » 2005-03-10 17:48

WTF is 1.2.0? I didn't realize that it existed. The earliest stable version listed on the website is 3.0

goransv
New user
New user
Posts: 7
Joined: 2005-03-10 16:03
Location: Sweden
Contact:

Post by goransv » 2005-03-11 10:20

I think that in 2000 or 2001 this was the stable version.... Did I say that i hate to upgrade software every other month! 8)

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-03-11 11:13

Theoretically, it should be possible to upgrade from 1.2 to 3.4. But if you have waited this long I suggest you wait for 3.4.1 since it will be put up as stable in a few days.

There are a huge amount of changes in the database between 1.2 and 3.4. This is because there is a large amount of changes between the two versions. But your domains, accounts and messages should be intact.

I don't even have a copy of the 1.2 installation. If you have a copy of it, it would be nice if you could put it up somewhere on the web so that I can download it. Partly because it would simply be nice to have, and partly because I could then make sure that upgrading from a such early version to the latest works properly. Then I can test it on a clean VMWare machine before you do it yourself.

goransv
New user
New user
Posts: 7
Joined: 2005-03-10 16:03
Location: Sweden
Contact:

Post by goransv » 2005-03-11 17:42

Ok nice! I have found a copy from 2002-12-04. I could not see wich version it was but I think it is 1.2. Here is the URL: http://www.gsopen.org/hmailserver/

ric melia
Normal user
Normal user
Posts: 33
Joined: 2004-12-13 15:11

Post by ric melia » 2005-03-29 12:14

martin wrote:if you have waited this long I suggest you wait for 3.4.1 since it will be put up as stable in a few days.
any news on how close 3.4.1 is to being released as stable?

Post Reply