messages bounced with 530 SMTP authentication is required

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
akerber00
New user
New user
Posts: 16
Joined: 2008-06-04 05:28

messages bounced with 530 SMTP authentication is required

Post by akerber00 » 2008-06-04 05:31

Every email I send to accounts I have set up in hmail server get bounced with the error message above. I check the hmail log, and it is sending the error message, so it is getting to the correct address. This is most likely a simple setting somewhere, but I have not been able to find it. Can anyone tell me what I did wrong/need to change.

User avatar
mattg
Moderator
Moderator
Posts: 21304
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: messages bounced with 530 SMTP authentication is required

Post by mattg » 2008-06-04 05:51

akerber00 wrote:530 SMTP authentication is required
You need to configure your email client to 'require authentication' to send e-mails.

Remember to use account@domain.com with the correct password.

Matt
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

akerber00
New user
New user
Posts: 16
Joined: 2008-06-04 05:28

Re: messages bounced with 530 SMTP authentication is required

Post by akerber00 » 2008-06-04 14:36

No, the problem is on the hmailserver side. I send the email from myaccount@gmail.com. Hmailserver returns the error message on the send that authentication is required. Its not when I try to get the mail from hmailserver, its when a foreign account sends it that the problem occurs.

This was sent back to the sending account:

The original message was received at Tue, 3 Jun 2008 08:57:10 -0400 from dbakerber.net [70.88.80.81]

----- The following addresses had permanent fatal errors ----- <andy@dbakerber.net>
(reason: 530 SMTP authentication is required.) <admin@dbakerber.net>
(reason: 530 SMTP authentication is required.)

This was in the hmailserver log:

DEBUG" 2300 "2008-06-03 22:26:06.022" "Socket::Socket(ID: 7)"
"SMTPD" 2300 7 "2008-06-03 22:26:06.022" "209.85.200.169" "SENT: 220 dbakerber.net ESMTP"
"SMTPD" 2300 7 "2008-06-03 22:26:06.100" "209.85.200.169" "RECEIVED: EHLO wf-out-1314.google.com"
"SMTPD" 2300 7 "2008-06-03 22:26:06.100" "209.85.200.169" "SENT: 250-hmailserver[nl]250-SIZE[nl]250 AUTH LOGIN"
"SMTPD" 2300 7 "2008-06-03 22:26:06.162" "209.85.200.169" "RECEIVED: MAIL FROM:<andrew.kerber@gmail.com>"
"DEBUG" 2300 "2008-06-03 22:26:06.256" "BLCheck::ClientExistsInDNSBL()"
"DEBUG" 2300 "2008-06-03 22:26:06.256" "BLCheck::_GetRevertedIP"
"DEBUG" 2300 "2008-06-03 22:26:06.256" "BLCheck::~_GetRevertedIP"
"TCPIP" 2300 "2008-06-03 22:26:06.256" "DNS - INAddr lookup: 169.200.85.209.zen.spamhaus.org"
"TCPIP" 2300 "2008-06-03 22:26:06.365" "DNSResolver - INAddr Lookup result for 169.200.85.209.zen.spamhaus.org: 0 responses"
"DEBUG" 2300 "2008-06-03 22:26:06.365" "BLCheck::~ClientExistsInDNSBL()"
"DEBUG" 2300 "2008-06-03 22:26:06.365" "BLCheck::ClientExistsInDNSBL()"
"DEBUG" 2300 "2008-06-03 22:26:06.365" "BLCheck::_GetRevertedIP"
"DEBUG" 2300 "2008-06-03 22:26:06.365" "BLCheck::~_GetRevertedIP"
"TCPIP" 2300 "2008-06-03 22:26:06.365" "DNS - INAddr lookup: 169.200.85.209.bl.spamcop.net"
"TCPIP" 2300 "2008-06-03 22:26:06.443" "DNSResolver - INAddr Lookup result for 169.200.85.209.bl.spamcop.net: 0 responses"
"DEBUG" 2300 "2008-06-03 22:26:06.443" "BLCheck::~ClientExistsInDNSBL()"
"SMTPD" 2300 7 "2008-06-03 22:26:06.443" "209.85.200.169" "SENT: 250 OK"
"SMTPD" 2300 7 "2008-06-03 22:26:06.522" "209.85.200.169" "RECEIVED: RCPT TO:<andy@dbakerber.net>"
"SMTPD" 2300 7 "2008-06-03 22:26:06.522" "209.85.200.169" "SENT: 530 SMTP authentication is required."
"DEBUG" 2300 "2008-06-03 22:26:06.522" "AWStats::LogDeliveryFailure"
"SMTPD" 2300 7 "2008-06-03 22:26:06.600" "209.85.200.169" "RECEIVED: QUIT"
"DEBUG" 2300 "2008-06-03 22:26:06.600" "PersistentMessage::DeleteFile()"

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: messages bounced with 530 SMTP authentication is required

Post by ^DooM^ » 2008-06-04 15:08

Ok then untick require authentication for deliveries to local accounts in the internet ip range.

This is not on by default.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

akerber00
New user
New user
Posts: 16
Joined: 2008-06-04 05:28

Re: messages bounced with 530 SMTP authentication is required

Post by akerber00 » 2008-06-04 15:20

Yes, that fixed it. I must have turned that on when I was debugging some firewall issues I had earlier thanks.

One more question, hopefully the last one. In the log is this conversation when checking the pop3 account. Why am I getting the '-ERR Invalid command in current state' error message? :

"DEBUG" 3180 "2008-06-04 08:12:37.459" "TransparentTransmissionBuffer::Initialize()"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "SENT: +OK POP3"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "RECEIVED: AUTH "
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "SENT: -ERR Invalid command in current state."
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "RECEIVED: USER andy"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "SENT: +OK Send your password"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "RECEIVED: PASS xxxxxxxxxx"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "SENT: +OK Mailbox locked and ready"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "RECEIVED: STAT"
"POP3D" 3180 37 "2008-06-04 08:12:37.459" "10.12.1.1" "SENT: +OK 0 0"
"POP3D" 3180 37 "2008-06-04 08:12:37.537" "10.12.1.1" "RECEIVED: QUIT"
"POP3D" 3180 37 "2008-06-04 08:12:37.537" "10.12.1.1" "SENT: +OK POP3 server saying goodbye..."
"TCPIP" 3180 "2008-06-04 08:12:37.553" "Disconnecting socket 1020 for session 37"
"DEBUG" 3180 "2008-06-04 08:12:37.553" "Socket::~Socket(ID: 37)"

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: messages bounced with 530 SMTP authentication is required

Post by ^DooM^ » 2008-06-04 15:26

Your client sends the AUTH command which hMail is not expecting, your client then continues on as normal. I wouldn't worry about it if it is working correctly. There are lots of mail servers out there and some work in slightly different ways as the RFC's are open to user interpretation. As long as all servers and clients concerned handle errors properly as hMail and your client did then just ignore it.

I am assuming you are using Outlook with the auth if available crap turned on and if so that only works with exchange servers as it is a proprietary feature if my limited memory serves.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

kirk
New user
New user
Posts: 1
Joined: 2008-06-19 18:51

Re: messages bounced with 530 SMTP authentication is required

Post by kirk » 2008-06-19 19:17

^DooM^ wrote:Your client sends the AUTH command which hMail is not expecting, your client then continues on as normal.

I'm having the exact same problem using POP3 from Outlook 2007. It is sending an AUTH that hMail doesn't like. hMail is replying with an ERR that causes Outlook to declare the connection a failure.
I wouldn't worry about it if it is working correctly.
It isn't working for POP3. I can get it to work for IMAP, but some users need POP3 access instead.

All authorization is off, except for the "My outgoing server (SMTP) requires authorization" box.

So, the bottom line is that it looks like Outlook is set up as correctly as I can set it up, and it can't connect to hMail using POP3.

Any further insight would be appreciated.

Thanks,
Kirk

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: messages bounced with 530 SMTP authentication is required

Post by martin » 2008-06-19 22:28

So, the bottom line is that it looks like Outlook is set up as correctly as I can set it up, and it can't connect to hMail using POP3.
I doubt that's the bottom line...

Exactly what error message does hMailServer give you when you fail to authenticate?
What do you see in the hMailServer log if you enable logging of POP3?

User avatar
mattg
Moderator
Moderator
Posts: 21304
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: messages bounced with 530 SMTP authentication is required

Post by mattg » 2008-06-20 02:18

kirk wrote:I'm having the exact same problem using POP3 from Outlook 2007. It is sending an AUTH that hMail doesn't like....All authorization is off, except for the "My outgoing server (SMTP) requires authorization" box.
G'day Kirk,

The reason that Outlook sends an AUTH is because you have selected (in outlook) 'My outgoing server (SMTP) requires authorization'.

You need to either setup hmailserver to require authorisation, and leave the outlook setting 'My outgoing server (SMTP) requires authorization' selected, or

leave hMailserver to NOT require authorisation and uncheck the outlook setting 'My outgoing server (SMTP) requires authorization'.
Server and client need to be doing the same thing...

Matt
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

hongz
New user
New user
Posts: 4
Joined: 2011-07-01 17:19
Location: MA, USA

Re: messages bounced with 530 SMTP authentication is require

Post by hongz » 2011-07-01 17:35

^DooM^ wrote:Ok then untick require authentication for deliveries to local accounts in the internet ip range.

This is not on by default.
Thanks for the tip. It solved my problem.

I was sending email using Comcast smtp service, and External to local email addresses under Require SMTP authentication was unchecked, but the email deliveries were still rejected. I unchecked all check boxes under Require SMTP authentication and the problem has been solved.

Hong

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: messages bounced with 530 SMTP authentication is require

Post by Bill48105 » 2011-07-01 17:42

Hong,
You definitely don't want to uncheck all of the 'require authentication' boxes for internet range or your server will be abused by spammers! Make note of your current ranges & their values & click the "Default" button on the ip ranges main page to put it bake to safe settings..
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

hongz
New user
New user
Posts: 4
Joined: 2011-07-01 17:19
Location: MA, USA

Re: messages bounced with 530 SMTP authentication is require

Post by hongz » 2011-07-01 18:58

Thanks, Bill, for the advice.

I was a bit hesitant but got very frustrated by the problem which suddenly occurred even though I did not change anything.

Now I leave the following two checked:
Local to external email addresses
External to external email addresses.

Could you point to a place where I can read more about how spammer can abuse the the mail server?

Hong

Bill48105
Developer
Developer
Posts: 6192
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: messages bounced with 530 SMTP authentication is require

Post by Bill48105 » 2011-07-01 19:10

hongz wrote:Thanks, Bill, for the advice.

I was a bit hesitant but got very frustrated by the problem which suddenly occurred even though I did not change anything.

Now I leave the following two checked:
Local to external email addresses
External to external email addresses.

Could you point to a place where I can read more about how spammer can abuse the the mail server?

Hong
You'll need to do some research but I named off most of the big ones I could think of. There is TONS online regarding being open relay to spammers.
Not sure if you read up the IP ranges info from hmail docs or not:
http://www.hmailserver.com/documentatio ... e_ipranges
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

hongz
New user
New user
Posts: 4
Joined: 2011-07-01 17:19
Location: MA, USA

Re: messages bounced with 530 SMTP authentication is require

Post by hongz » 2011-07-01 19:30

Thanks, Bill.

Now I understand more. The current configuration should be fairly safe.

Hong

cliftonm
New user
New user
Posts: 1
Joined: 2017-06-30 14:31

Re: messages bounced with 530 SMTP authentication is required

Post by cliftonm » 2017-06-30 14:33

As absurd as this may sound, check the spelling of your username@domainname - I just spent two hours trying to diagnose this problem only to discover I incorrectly spelled my domain name. :(

Post Reply