Failed to connect

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Failed to connect

Post by ojpd » 2008-03-28 02:44

Hello.
I can send emails to gmail and anothers servers, but I havent succes with hotmail neither yahoo. Hotmail not give me any reply and with yahoo, I can read it in the logs : "failed to connect"(with the 10 yahoo`s servers) . I have a spf txt record in my dns server, but when I try to test it, I have a result different to my server name(85.pool85-52-195.static.orange.es. vs http://www.pisoenrivas.com ). I have asked to my ISP and they said me there's all ok, and I think that perhaps a problem with it. I have the port 25 open beacause I can to send mails, but I cant undestand why the mails cant find the destinatary in yahoo and hotmail. My ip is static and I use v4.4.1 B273(Excuse me for my english)

**********************************************************
http://www.dnsstuff.com/tools/ipall.ch?ip=85.52.195.85
IP address: 85.52.195.85
Reverse DNS: 85.pool85-52-195.static.orange.es.
Reverse DNS authenticity: [Verified]

Return mail sended to <verifier-feedback@port25.com>.
==========================================================
Summary of Results
==========================================================
SPF check: pass
DomainKeys check: neutral
DKIM check: neutral
Sender-ID check: pass
SpamAssassin check: ham

==========================================================
Details:
==========================================================

HELO hostname: http://www.pisoenrivas.com
Source IP: 85.52.195.85
mail-from: oscar@pisoenrivas.com

----------------------------------------------------------
SPF check details:
----------------------------------------------------------
Result: pass
ID(s) verified: smtp.mail=oscar@pisoenrivas.com
DNS record(s):
pisoenrivas.com. 3600 IN TXT "v=spf1 a mx ptr ~all"
pisoenrivas.com. 28800 IN A 85.52.195.85

****************************************************************************
LOGS
"DEBUG" 4076 "2008-03-28 01:25:17.812" "TransparentTransmissionBuffer::Initialize()"
"SMTPD" 4076 264 "2008-03-28 01:25:17.812" "127.0.0.1" "SENT: 354 OK, send."
"DEBUG" 4076 "2008-03-28 01:25:17.812" "PMADO:SaveObject()"
"DEBUG" 4076 "2008-03-28 01:25:17.812" "Adding message to database. File: C:\Archivos de programa\hMailServer\Data\{AAB27390-53F3-45FD-B5C2-8946642FB6AD}.eml"
"DEBUG" 4076 "2008-03-28 01:25:18.015" "PMADO:~SaveObject()"
"DEBUG" 4076 "2008-03-28 01:25:18.015" "Message added. File: C:\Archivos de programa\hMailServer\Data\{AAB27390-53F3-45FD-B5C2-8946642FB6AD}.eml"
"DEBUG" 4076 "2008-03-28 01:25:18.015" "Application::SubmitPendingEmail()"
"DEBUG" 4076 "2008-03-28 01:25:18.015" "Application::~SubmitPendingEmail()"
"SMTPD" 4076 264 "2008-03-28 01:25:18.031" "127.0.0.1" "SENT: 250 Queued (0.000 seconds)"
"TCPIP" 4076 "2008-03-28 01:25:18.031" "Created accept socket 1824 on listening socket 1360"
"SMTPD" 4064 264 "2008-03-28 01:25:18.031" "127.0.0.1" "RECEIVED: QUIT"
"DEBUG" 4076 "2008-03-28 01:25:18.031" "Socket::Socket(ID: 265)"
"SMTPD" 4064 264 "2008-03-28 01:25:18.031" "127.0.0.1" "SENT: 221 goodbye"
"TCPIP" 4064 "2008-03-28 01:25:18.031" "Disconnecting socket 1856 for session 264"
"DEBUG" 4064 "2008-03-28 01:25:18.031" "Socket::~Socket(ID: 264)"
"DEBUG" 4056 "2008-03-28 01:25:18.125" "SD::DeliverMessage"
"DEBUG" 4064 "2008-03-28 01:25:18.296" "PMADO:SaveObject()"
"APPLICATION" 4056 "2008-03-28 01:25:18.343" "SMTPDeliverer - Message 178: Delivering message from oscar@pisoenrivas.com to xxx@hotmail.com, yyy@yahoo.com. File: C:\Archivos de programa\hMailServer\Data\{AAB27390-53F3-45FD-B5C2-8946642FB6AD}.eml"
"DEBUG" 4064 "2008-03-28 01:25:18.359" "Adding message to database. File: C:\xxxx\pisoenrivas.com\oscar\E0\{E0140B88-0875-45E7-BC88-45D6D322A865}.eml"
"DEBUG" 4056 "2008-03-28 01:25:18.359" "RuleApplier::ApplyRules"
"DEBUG" 4056 "2008-03-28 01:25:18.359" "RuleApplier::~ApplyRules"
"DEBUG" 4056 "2008-03-28 01:25:18.375" "PMADO:CopyMailContentsFrom()"
"DEBUG" 4056 "2008-03-28 01:25:18.375" "PMADO:~CopyMailContentsFrom()"
"DEBUG" 4056 "2008-03-28 01:25:18.375" "PMADO:SaveObject()"
"DEBUG" 4056 "2008-03-28 01:25:18.375" "Adding message to database. File: C:\xxxx\hMailServer\Data\{B9CF6125-DCE9-49B1-8A11-CFCAA1BAF859}.eml"
"DEBUG" 4064 "2008-03-28 01:25:18.421" "PMADO:~SaveObject()"
"TCPIP" 4064 "2008-03-28 01:25:18.421" "Disconnecting socket 376 for session 265"
"DEBUG" 4064 "2008-03-28 01:25:18.421" "Socket::~Socket(ID: 265)"
"DEBUG" 4056 "2008-03-28 01:25:18.625" "PMADO:~SaveObject()"
"DEBUG" 4056 "2008-03-28 01:25:18.640" "Application::SubmitPendingEmail()"
"DEBUG" 968 "2008-03-28 01:25:18.671" "PersistentMessage::ReadObject()"
"DEBUG" 4056 "2008-03-28 01:25:18.671" "Application::~SubmitPendingEmail()"
"DEBUG" 968 "2008-03-28 01:25:18.687" "PersistentMessage::~ReadObject()"
"DEBUG" 4056 "2008-03-28 01:25:18.687" "SD::_DeliverToLocalAccounts"
"TCPIP" 4076 "2008-03-28 01:25:18.703" "Created accept socket 1768 on listening socket 1360"
"DEBUG" 4056 "2008-03-28 01:25:18.703" "SD::~_DeliverToLocalAccounts"
"DEBUG" 4076 "2008-03-28 01:25:18.703" "Socket::Socket(ID: 266)"
"DEBUG" 4056 "2008-03-28 01:25:18.703" "SD::_DeliverToExternalAccounts"
"TCPIP" 4056 "2008-03-28 01:25:18.703" "DNS - MX Lookup: hotmail.com"
"DEBUG" 3620 "2008-03-28 01:25:18.750" "SD::DeliverMessage"
"TCPIP" 4056 "2008-03-28 01:25:18.843" "DNS - MX Result: 12 IP addresses were found."
"DEBUG" 4056 "2008-03-28 01:25:18.906" "SD::_InitiateExternalConnection"
"APPLICATION" 3620 "2008-03-28 01:25:18.921" "SMTPDeliverer - Message 180: Delivering message from oscar@pisoenrivas.com to oscar@lindopiso.com. File: C:\Archivos de programa\hMailServer\Data\{B9CF6125-DCE9-49B1-8A11-CFCAA1BAF859}.eml"
"DEBUG" 4056 "2008-03-28 01:25:18.968" "Socket::Socket(ID: 267)"
"DEBUG" 3620 "2008-03-28 01:25:19.000" "RuleApplier::ApplyRules"
"DEBUG" 3620 "2008-03-28 01:25:19.031" "RuleApplier::~ApplyRules"
"DEBUG" 4076 "2008-03-28 01:25:19.078" "PMADO:SaveObject()"
"DEBUG" 3620 "2008-03-28 01:25:19.078" "SD::_DeliverToLocalAccounts"
"DEBUG" 3620 "2008-03-28 01:25:19.093" "RuleApplier::ApplyRules"
"DEBUG" 3620 "2008-03-28 01:25:19.093" "RuleApplier::~ApplyRules"
"DEBUG" 3620 "2008-03-28 01:25:19.093" "PMADO:CopyMailContentsFrom()"
"DEBUG" 3620 "2008-03-28 01:25:19.093" "PMADO:~CopyMailContentsFrom()"
"DEBUG" 3620 "2008-03-28 01:25:19.156" "Adding message to database. File: C:\Archivos de programa\hMailServer\Data\lindopiso.com\oscar\B9\{B9CF6125-DCE9-49B1-8A11-CFCAA1BAF859}.eml"
"DEBUG" 4076 "2008-03-28 01:25:19.187" "PMADO:~SaveObject()"
"DEBUG" 3620 "2008-03-28 01:25:19.218" "AWStats::LogDeliverySuccess"
"DEBUG" 4076 "2008-03-28 01:25:19.265" "PMADO:SaveObject()"
"DEBUG" 3620 "2008-03-28 01:25:19.312" "SD::~_DeliverToLocalAccounts"
"APPLICATION" 3620 "2008-03-28 01:25:19.343" "SMTPDeliverer - Message 180: Message delivery thread completed."
"DEBUG" 4076 "2008-03-28 01:25:19.343" "PMADO:~SaveObject()"
"DEBUG" 3620 "2008-03-28 01:25:19.375" "PersistentMessage::DeleteObject()"
"DEBUG" 3620 "2008-03-28 01:25:19.515" "PersistentMessage::DeleteFile()"
"DEBUG" 3620 "2008-03-28 01:25:19.546" "PersistentMessage::DeleteObject() - E5"
"DEBUG" 4076 "2008-03-28 01:25:19.546" "SMTPClientConnection::_ParseASCII()"
"DEBUG" 3620 "2008-03-28 01:25:19.625" "SD::~DeliverMessage"
"SMTPC" 4076 267 "2008-03-28 01:25:19.687" "65.54.245.40" "RECEIVED: 220 bay0-mc12-f7.bay0.hotmail.com Sending unsolicited commercial or bulk e-mail to Microsoft's computer network is prohibited. Other restrictions are found at http://privacy.msn.com/Anti-spam/. Violations will result in use of equipment located in California and other states. Thu, 27 Mar 2008 17:22:09 -0700 "
"SMTPC" 4076 267 "2008-03-28 01:25:19.750" "65.54.245.40" "SENT: HELO http://www.pisoenrivas.com"
"DEBUG" 4076 "2008-03-28 01:25:19.781" "SMTPClientConnection::~_ParseASCII() - 2"
"DEBUG" 4064 "2008-03-28 01:25:19.843" "PMADO:SaveObject()"
"DEBUG" 4064 "2008-03-28 01:25:19.890" "PMADO:~SaveObject()"
"DEBUG" 4076 "2008-03-28 01:25:20.000" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:20.031" "65.54.245.40" "RECEIVED: 250 bay0-mc12-f7.bay0.hotmail.com (3.5.0.22) Hello [85.52.195.85]"
"SMTPC" 4076 267 "2008-03-28 01:25:20.062" "65.54.245.40" "SENT: MAIL FROM:<oscar@pisoenrivas.com>"
"DEBUG" 4076 "2008-03-28 01:25:20.093" "SMTPClientConnection::~_ParseASCII() - 4"
"DEBUG" 4076 "2008-03-28 01:25:20.296" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:20.296" "65.54.245.40" "RECEIVED: 250 oscar@pisoenrivas.com....Sender OK"
"DEBUG" 4076 "2008-03-28 01:25:20.296" "SMTPClientConnection::~_ParseASCII() - 6"
"SMTPC" 4076 267 "2008-03-28 01:25:20.296" "65.54.245.40" "SENT: RCPT TO:<xxx@hotmail.com>"
"TCPIP" 4064 "2008-03-28 01:25:20.328" "Disconnecting socket 1824 for session 266"
"DEBUG" 4064 "2008-03-28 01:25:20.328" "Socket::~Socket(ID: 266)"
"DEBUG" 4076 "2008-03-28 01:25:20.500" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:20.500" "65.54.245.40" "RECEIVED: 250 xxx@hotmail.com "
"SMTPC" 4076 267 "2008-03-28 01:25:20.500" "65.54.245.40" "SENT: DATA"
"DEBUG" 4076 "2008-03-28 01:25:20.500" "SMTPClientConnection::~_ParseASCII() - 7"
"DEBUG" 4076 "2008-03-28 01:25:20.765" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:20.796" "65.54.245.40" "RECEIVED: 354 Start mail input; end with <CRLF>.<CRLF>"
"DEBUG" 4076 "2008-03-28 01:25:20.796" "SocketConnection::SendFileContents()"
"DEBUG" 4076 "2008-03-28 01:25:20.796" "TransparentTransmissionBuffer::Initialize()"
"DEBUG" 4076 "2008-03-28 01:25:20.812" "SocketConnection::SendFileContents() - E2"
"SMTPC" 4076 267 "2008-03-28 01:25:20.812" "65.54.245.40" "SENT: [nl]."
"DEBUG" 4076 "2008-03-28 01:25:20.812" "SMTPClientConnection::~_ParseASCII() - 8"
"DEBUG" 4076 "2008-03-28 01:25:21.406" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:21.406" "65.54.245.40" "RECEIVED: 250 <4226.85.52.195.85.1206663917.squirrel@www.lindopiso.com> Queued mail for delivery"
"SMTPC" 4076 267 "2008-03-28 01:25:21.406" "65.54.245.40" "SENT: QUIT"
"DEBUG" 4076 "2008-03-28 01:25:21.406" "SMTPClientConnection::~_ParseASCII() - 9"
"DEBUG" 4076 "2008-03-28 01:25:21.640" "SMTPClientConnection::_ParseASCII()"
"SMTPC" 4076 267 "2008-03-28 01:25:21.671" "65.54.245.40" "RECEIVED: 221 bay0-mc12-f7.bay0.hotmail.com Service closing transmission channel"
"TCPIP" 4076 "2008-03-28 01:25:21.703" "Disconnecting socket 1880 for session 267"
"DEBUG" 4056 "2008-03-28 01:25:21.734" "SD::~_InitiateExternalConnection-5"
"DEBUG" 4076 "2008-03-28 01:25:21.734" "Socket::~Socket(ID: 267)"
"DEBUG" 4056 "2008-03-28 01:25:21.750" "SD::~_DeliverToExternalAccounts-1"
"DEBUG" 4056 "2008-03-28 01:25:21.750" "SD::_CollectDeliveryResult"
"DEBUG" 4056 "2008-03-28 01:25:21.750" "AWStats::LogDeliverySuccess"
"DEBUG" 4056 "2008-03-28 01:25:21.812" "SD::~_CollectDeliveryResult"
"DEBUG" 4056 "2008-03-28 01:25:21.812" "SD::_DeliverToExternalAccounts"
"TCPIP" 4056 "2008-03-28 01:25:21.812" "DNS - MX Lookup: yahoo.com"
"TCPIP" 4056 "2008-03-28 01:25:21.937" "DNS - MX Result: 10 IP addresses were found."
"DEBUG" 4056 "2008-03-28 01:25:21.937" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 01:25:21.937" "Socket::Socket(ID: 268)"
"APPLICATION" 4056 "2008-03-28 01:25:42.906" "SMTPDeliverer - Message 178: Failed to connect to 216.39.53.1."
"DEBUG" 4056 "2008-03-28 01:25:42.953" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 01:25:43.015" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 01:25:43.078" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 01:25:43.140" "Socket::Socket(ID: 269)"
"DEBUG" 4052 "2008-03-28 01:25:47.703" "TimedoutConnectionRemoverTask::DoWork()"
"APPLICATION" 4056 "2008-03-28 01:26:04.140" "SMTPDeliverer - Message 178: Failed to connect to 209.191.88.247."
"DEBUG" 4056 "2008-03-28 01:26:04.140" "ClientConnection::Connect() - Failed to connect."


and so with 9 yahoo's mail's servers....

Thanks for your help

redrummy
Senior user
Senior user
Posts: 370
Joined: 2007-06-21 06:52
Location: Alaska

Re: Failed to connect

Post by redrummy » 2008-03-28 03:33

There is a problem with your DNS hosting, or if you just set up the domain, then DNS hasn't finished propagating yet. I only see NS records for pisoenrivas.com, no A, MX, TXT, etc...

Also, dnsstuff.com doesn't give you any useful tools for free anymore. You might try network-tools.com, or some other site.

Yahoo is probably not responding to you because of the DNS issue. Hotmail is notorious for swallowing messages without notification so you can't really rely on them accepting your mail as any indication unless the other user actually receives it.

ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Re: Failed to connect

Post by ojpd » 2008-03-28 08:55

Thanks for your help.
I have the dns record a few months ago and the txt for the spf from last week(no propagation problem). Since I have the spf, I can send to gmail, so I think that's ok. I have deleted it today and reenter the info(same results).
------------
Records test from DNSEXIT (my dns):

Mail Exchanger(MX) Preference#
pisoenrivas.com 5
Hosts (A Record) IP Addresses
pisoenrivas.com 85.52.195.85

Alias(CName) Alias to Host IP Addresses
ftp.pisoenrivas.com pisoenrivas.com 85.52.195.85
http://www.pisoenrivas.com pisoenrivas.com 85.52.195.85
-------------
from http://network-tools.com/nslook

type MX
name class type data time to live
http://www.pisoenrivas.com IN CNAME pisoenrivas.com 120s (2m)
pisoenrivas.com IN MX preference: 5
exchange: pisoenrivas.com
type TXT
name class type data time to live
http://www.pisoenrivas.com IN CNAME pisoenrivas.com 120s (2m)
pisoenrivas.com IN TXT v=spf1 a mx ptr ~all 120s (2m)

type A
name class type data time to live
http://www.pisoenrivas.com IN CNAME pisoenrivas.com 120s (2m)
pisoenrivas.com IN A 85.52.195.85 28552s (7h 55m 52s)

But if I use
http://www.openspf.org/Why?show-form=1& ... mit=Submit

the result is:
An SPF-enabled mail server rejected a message that claimed an envelope sender address of oscar@pisoenrivas.com.

An SPF-enabled mail server received a message from 85.pool85-52-195.static.orange.es (85.52.195.85) that claimed an envelope sender address of oscar@pisoenrivas.com.



And its not correct.
---------
The return mail to the client when I try send to yahoo was:
-----------------------------
Your message did not reach some or all of the intended recipients.

Sent: Fri, 28 Mar 2008 01:37:09 +0100 (Hora est?ndar romance)
Subject: test3

The following recipient(s) could not be reached:

ojpd@yahoo.com
Error type: Winsock
Error Description: Connection timed out.
Additional information: connect()

Tried 2 time(s)



hMailServer
--------------------------
And we can read in the log a conection problem, with the ten yahoo's mail's servers(I just post the first of them). The server try to connect to each one without success.
I have an apache with three domains, and I have put spf records and the same configuration for each one, without problems except the mails sends to yahoo and hotmail.

I tried to search the entire forum ,and I haved googled a lot and I cant to find a solution, I go to be crazy with it.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Re: Failed to connect

Post by ^DooM^ » 2008-03-28 13:15

on your mailserver if you do an MX lookup from the hMail administrator on yahoo and hotmail does it return a valid result?
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Re: Failed to connect

Post by ojpd » 2008-03-28 17:28

Yes. Aparently, its ok
--------
nslookup
set type=mx
yahoo.com

servidor: --------- (server)
Address: 192.168.0.1

Respuesta no autoritativa --------------(response non autoritative)
yahoo.com MX preference= 1, mail exchanger = d.mx.mail.yahoo.com
yahoo.com MX prefernce = 1, mail exchanger = (e,f,g,a,b and c) .mx.mail.yahoo.com

yahoo.com nameserver = ns6 (ns2,ns8,ns4,ns1,ns3,ns5).yahoo.com
d.mx.mail.yahoo.com internet adress =66.196.82.7
e,f,f,g,g,a,b,c,c = 216.39.53.1,68.142.202.247,209.191.88.247, -------- (10 ips)
ns2.yahoo.com internet adress = 68.142.255.16
ns1.yahoo.com internet adress = 66.218.71.63
ns3.yahoo.com internet adress = 217.12.4.104
ns4.yahoo.com internet adress = 68.142.196.63

----------------------------------------------------------

In the log, a try for each one (10 times) with:
"APPLICATION" 4056 "2008-03-28 14:02:33.312" "SMTPDeliverer - Message 206: Delivering message from oscar@pisoenrivas.com to ojpd@yahoo.com. File: C:\Archivos de programa\hMailServer\Data\{EC3504D1-4880-47C4-9FA3-9F982E965E59}.eml"
"DEBUG" 4056 "2008-03-28 14:02:33.312" "SD::_DeliverToLocalAccounts"
"DEBUG" 4056 "2008-03-28 14:02:33.312" "SD::~_DeliverToLocalAccounts"
"DEBUG" 4056 "2008-03-28 14:02:33.312" "SD::_DeliverToExternalAccounts"
"TCPIP" 4056 "2008-03-28 14:02:33.312" "DNS - MX Lookup: yahoo.com"
"TCPIP" 4056 "2008-03-28 14:02:33.437" "DNS - MX Result: 10 IP addresses were found."
"DEBUG" 4056 "2008-03-28 14:02:33.437" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:02:33.437" "Socket::Socket(ID: 386)"
"APPLICATION" 4056 "2008-03-28 14:02:54.265" "SMTPDeliverer - Message 206: Failed to connect to 216.39.53.3."
"DEBUG" 4056 "2008-03-28 14:02:54.265" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:02:54.265" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:02:54.265" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:02:54.265" "Socket::Socket(ID: 387)"
"APPLICATION" 4056 "2008-03-28 14:03:15.281" "SMTPDeliverer - Message 206: Failed to connect to 216.39.53.2."
"DEBUG" 4056 "2008-03-28 14:03:15.281" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:03:15.281" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:03:15.281" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:03:15.281" "Socket::Socket(ID: 388)"
"APPLICATION" 4056 "2008-03-28 14:03:36.312" "SMTPDeliverer - Message 206: Failed to connect to 66.196.82.7."
"DEBUG" 4056 "2008-03-28 14:03:36.312" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:03:36.312" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:03:36.312" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:03:36.312" "Socket::Socket(ID: 389)"
"APPLICATION" 4056 "2008-03-28 14:03:57.328" "SMTPDeliverer - Message 206: Failed to connect to 216.39.53.1."
"DEBUG" 4056 "2008-03-28 14:03:57.328" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:03:57.328" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:03:57.328" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:03:57.328" "Socket::Socket(ID: 390)"
"APPLICATION" 4056 "2008-03-28 14:04:18.343" "SMTPDeliverer - Message 206: Failed to connect to 209.191.88.247."
"DEBUG" 4056 "2008-03-28 14:04:18.343" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:04:18.359" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:04:18.359" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:04:18.359" "Socket::Socket(ID: 391)"
"APPLICATION" 4056 "2008-03-28 14:04:39.375" "SMTPDeliverer - Message 206: Failed to connect to 68.142.202.247."
"DEBUG" 4056 "2008-03-28 14:04:39.375" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:04:39.375" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:04:39.375" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:04:39.375" "Socket::Socket(ID: 392)"
"APPLICATION" 4056 "2008-03-28 14:05:00.390" "SMTPDeliverer - Message 206: Failed to connect to 206.190.53.191."
"DEBUG" 4056 "2008-03-28 14:05:00.390" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:05:00.390" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:05:00.390" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:05:00.406" "Socket::Socket(ID: 393)"
"APPLICATION" 4056 "2008-03-28 14:05:21.421" "SMTPDeliverer - Message 206: Failed to connect to 209.191.88.239."
"DEBUG" 4056 "2008-03-28 14:05:21.421" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:05:21.421" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:05:21.421" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:05:21.421" "Socket::Socket(ID: 394)"
"APPLICATION" 4056 "2008-03-28 14:05:42.437" "SMTPDeliverer - Message 206: Failed to connect to 209.191.118.103."
"DEBUG" 4056 "2008-03-28 14:05:42.437" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:05:42.437" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:05:42.437" "SD::_InitiateExternalConnection"
"DEBUG" 4056 "2008-03-28 14:05:42.437" "Socket::Socket(ID: 395)"
"DEBUG" 4052 "2008-03-28 14:05:48.546" "TimedoutConnectionRemoverTask::DoWork()"
"APPLICATION" 4056 "2008-03-28 14:06:03.359" "SMTPDeliverer - Message 206: Failed to connect to 66.196.97.250."
"DEBUG" 4056 "2008-03-28 14:06:03.359" "ClientConnection::Connect() - Failed to connect."
"DEBUG" 4056 "2008-03-28 14:06:03.359" "SD:~_InitiateExternalConnection-4"
"DEBUG" 4056 "2008-03-28 14:06:03.359" "SD::~_DeliverToExternalAccounts-2"
"DEBUG" 4056 "2008-03-28 14:06:03.359" "SD::_CollectDeliveryResult"
"DEBUG" 4056 "2008-03-28 14:06:03.359" "SD::~_CollectDeliveryResult"
"DEBUG" 4056 "2008-03-28 14:06:03.359" "SD::_RescheduleDelivery"
"APPLICATION" 4056 "2008-03-28 14:06:03.375" "SMTPDeliverer - Message 206: Message could not be delivered. Returning error log to sender."
"DEBUG" 4056 "2008-03-28 14:06:03.375" "AWStats::LogDeliveryFailure"
"DEBUG" 4056 "2008-03-28 14:06:03.375" "SD::~_RescheduleDelivery-2"
"DEBUG" 4056 "2008-03-28 14:06:03.375" "SD::_SubmitErrorLog"
"DEBUG" 4056 "2008-03-28 14:06:03.375" "PMADO:SaveObject()"
"DEBUG" 4056 "2008-03-28 14:06:03.375" "Adding message to database. File: C:\Archivos de programa\hMailServer\Data\{BF57FBFB-5DD8-44FF-A5DB-FC7470805E8F}.eml"
"DEBUG" 4056 "2008-03-28 14:06:03.484" "PMADO:~SaveObject()"
"DEBUG" 4056 "2008-03-28 14:06:03.484" "SD::~_SubmitErrorLog"
"APPLICATION" 4056 "2008-03-28 14:06:03.484" "SMTPDeliverer - Message 206: Message delivery thread completed."
---------------------------------------------------------

The name is resolved, but it cant connect. Its not a firewall problem or something similar, beacause I can send to another servers. I cant to open a telnet with port 25 with yahoo, for example:
telnet 216.39.53.1 25
conectantose a 216.39.53.1... no se puede abrir la conexion al host, en el puerto 25: Error en la conexion
(connecting to 216.39.53.1... cant open host connection, at port 25: error connection)

¿Perhaps a problem with the spf? If I send a mail, the another server try make a reverse dns, it get 85.pool85-52-195.static.orange.es. . It not should be "pisoenrivas.com"?
http://www.openspf.org/Why?show-form=1& ... mit=Submit

Orange is my isp provider, so aparently, its most powerfull my provider's reverse dns than the mine. (Sorry for my english, I dont know if I can to be understand )

Thanks

redrummy
Senior user
Senior user
Posts: 370
Joined: 2007-06-21 06:52
Location: Alaska

Re: Failed to connect

Post by redrummy » 2008-03-28 19:19

I can see your DNS records now (MX, TXT, etc.) and they look fine, except for 1 thing: The TTL on some of your records is very short (120s). I've found that huge mail services like hotmail & yahoo don't trust servers with short TTL's. You should set the TTL for all of your DNS records to at least 43200s.

Other than that, I don't know why yahoo would be blocking your connections, unless your IP is temporarily blacklisted because of the previous DNS problem. Just a guess... you might want to contact their support.

RE: rDNS - Usually you can only set forward DNS records for yourself, the PTR (rDNS) has to be done by your ISP since they own the IP address space. Some ISP's will let you request a custom PTR, some won't.


EDIT:
Your IP (or netblock) appears to listed in a couple different RBL's. You'll want to check them out and see if you can complete whatever de-listing process they require:
- http://openrbl.org/client/#85.52.195.85
- http://www.robtex.com/rbl/85.52.195.85.html

ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Re: Failed to connect

Post by ojpd » 2008-03-28 20:55

Hello. Thanks for your help.
I find my ip blaclisted in http://www.uceprotect.net, at level 2 and 3, but not for me, its my isp fault. I have removed the another one blaklist, I hope, in nomorefun.
I go to call to my isp for try solve it, but I have read about in forums and the only solution is a ip change. The problem is that maybe they give me another one blacklisted ip too. I live in Spain, and we must to remain one year with the isp (its very bad and people isnt happy)
While, I have changed one domain to another dns server, and growup the ttl following your instructions. I haved down it for this tests .
Yesterday I speaked with my isp about the rdns and the tec who was in the support, after asked to another one, said to me what they havent created this rdns. So I dont have great hope about my ips's helpteam. Perhaps I find anotherone better.
I cant understand why we can to read in the log a connection problem with yahoo, and I cant to understand from hotmail no give error neither a bounced mail. Its better to find a reply explain something about a blacklist if its the problem.
I thinks that's a problem with my configuration. Im thinking about to translate the server to a friend's home to discard the problem with the ip. Im desesperate. And thanks again for your help.

redrummy
Senior user
Senior user
Posts: 370
Joined: 2007-06-21 06:52
Location: Alaska

Re: Failed to connect

Post by redrummy » 2008-03-29 21:55

It looks like you're successfully de-listed at no-more-funn, but the situation at uceprotect looks pretty bad. =( Apparently your ISP is doing a horrible job controlling spam from their network, so you're not likely to get any "good" IP from them because the whole network range is listed due to so many spam IP's: http://www.uceprotect.net/en/rblcheck.p ... .52.195.85

Code: Select all

Networks      Status  Level 1 listed spammers  Escalation to Level 2
85.48.0.0/12  LISTED  5424                     1885
This is a likely cause of both your hotmail and yahoo problems. If you haven't already done so, you should let your ISP know about this. Don't know if it will do any good, though.

If you want to run your own mail server, it sounds like you'll have to use the SMTP Relayer option in hMailServer with a 3rd party relayer in a "good" network, or have your entire server hosted somewhere else.

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Re: Failed to connect

Post by Kaan1983 » 2008-03-29 22:22

That's bad man :D

try to send me a test mail at xxx@y.z and let's see if you can pass ASSP :)

(Edited the e-mail)
Last edited by Kaan1983 on 2008-03-30 11:18, edited 1 time in total.

redrummy
Senior user
Senior user
Posts: 370
Joined: 2007-06-21 06:52
Location: Alaska

Re: Failed to connect

Post by redrummy » 2008-03-29 22:33

That's bad man :D
...and for some reason Kaan is "very happy" about this. ;)

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Re: Failed to connect

Post by Kaan1983 » 2008-03-30 00:02

hehehe :)

I'm bad too :P

@ojpd: just switch your host imidiately. Don't even call em, they are probably aware of the situation.

(and a little bit of humor:))

ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Re: Failed to connect

Post by ojpd » 2008-03-30 04:35

Hello everybody.
You are right, Im need a lot of humor. And perhaps a machinegun(for my isp) too. It will make my life better, sure.
I cant to change my isp till next september, and when I made the change, I must to wait without internet for two months. Here in Spain its a big shit.
I can to open the port 25 in another domains, but I cant with yahoo. Now I can to send to hotmail(my mails go to spam folder, so I must to resend to entry folder and its ok, I hope).
Tomorrow(now its very later here) I will call to my Isp, and I hope they can to put it ok with yahoo.
Last call they said me that its all open(Thats the reason beacause I have writed here in this forum).
This morning, I have connected a Vnc between my pc and my father's computer(another city, another isp).
From there, I can to open the port 25 in yahoo (they send me a error about her ip (dinamyc) listed in spamhouse, but I got the error message). From my ip, I got nothing except "cant to connect host". I cant understand why yahoo not send a error message neither hotmail with the problem.

I will test tomorrow sending a mail to you, Kaan1983 (Here's 4:30 am). Thanks everybody for your help.

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Re: Failed to connect

Post by Kaan1983 » 2008-03-30 09:53

I got your e-mail and answered.
I cant understand why yahoo not send a error message neither hotmail with the problem.
Don't wait any answer from hotmail anyways.

ojpd
New user
New user
Posts: 12
Joined: 2008-03-28 00:48

Re: Failed to connect

Post by ojpd » 2008-03-30 10:21

Microsoft: know now no. :x
I have writed to yahoo and hotmail last week. Yahoo has reply me, but nothing from hotmail.
I can send now to hotmail, and I have found it in my log:
"TCPIP" 3084 "2008-03-30 00:46:50.671" "Created accept socket 1744 on listening socket 1304"
"DEBUG" 3084 "2008-03-30 00:46:50.671" "Socket::Socket(ID: 106)"
"SMTPD" 3084 106 "2008-03-30 00:46:50.671" "193.200.50.4" "SENT: 220 lindopiso.com ESMTP"
"SMTPD" 3084 106 "2008-03-30 00:46:50.765" "193.200.50.4" "RECEIVED: HELO 85.52.195.85"
"SMTPD" 3084 106 "2008-03-30 00:46:50.765" "193.200.50.4" "SENT: 250 Hello."
"SMTPD" 3084 106 "2008-03-30 00:46:50.859" "193.200.50.4" "RECEIVED: MAIL FROM: <support@microsoft.com>"
"SMTPD" 3084 106 "2008-03-30 00:46:52.687" "193.200.50.4" "SENT: 250 OK"
"SMTPD" 3084 106 "2008-03-30 00:46:52.796" "193.200.50.4" "RECEIVED: RCPT TO: <support@microsoft.com>"
"SMTPD" 3084 106 "2008-03-30 00:46:52.796" "193.200.50.4" "SENT: 530 SMTP authentication is required."
"DEBUG" 3084 "2008-03-30 00:46:52.796" "AWStats::LogDeliveryFailure"
It is a security's verifycation for smtp?

I have send you the email. Have you recived it?

Kaan1983
Senior user
Senior user
Posts: 595
Joined: 2007-01-30 16:26
Location: TÜRKIYE

Re: Failed to connect

Post by Kaan1983 » 2008-03-30 11:01

ojpd wrote:I have send you the email. Have you recived it?
Yes, and replied back to you.

redrummy
Senior user
Senior user
Posts: 370
Joined: 2007-06-21 06:52
Location: Alaska

Re: Failed to connect

Post by redrummy » 2008-03-30 22:56

"SMTPD" 3084 106 "2008-03-30 00:46:50.671" "193.200.50.4" "SENT: 220 lindopiso.com ESMTP"
"SMTPD" 3084 106 "2008-03-30 00:46:50.765" "193.200.50.4" "RECEIVED: HELO 85.52.195.85"
"SMTPD" 3084 106 "2008-03-30 00:46:50.765" "193.200.50.4" "SENT: 250 Hello."
"SMTPD" 3084 106 "2008-03-30 00:46:50.859" "193.200.50.4" "RECEIVED: MAIL FROM: <support@microsoft.com>"
"SMTPD" 3084 106 "2008-03-30 00:46:52.687" "193.200.50.4" "SENT: 250 OK"
"SMTPD" 3084 106 "2008-03-30 00:46:52.796" "193.200.50.4" "RECEIVED: RCPT TO: <support@microsoft.com>"
"SMTPD" 3084 106 "2008-03-30 00:46:52.796" "193.200.50.4" "SENT: 530 SMTP authentication is required."
This is not you sending to Microsoft (or Microsoft sending to you). This is a relay test or plain old spam. Note that the remote server is claiming to be from YOUR IP address, and is trying to relay a message through your server to an external account. This should never be allowed without authentication, so your server is just doing it's job.

Post Reply