Installed but not working Please help.

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
frink
New user
New user
Posts: 3
Joined: 2008-03-12 06:20

Installed but not working Please help.

Post by frink » 2008-03-12 06:24

I have just installed and configured hMail onto my windows 2003 server. but somthing is wrong and i cannot figure out what.
When i try to connect to the account i created using outlook it fails. Also when i send an email to that address i recive an undeliverable error.
The MX record is set to the correct address, SMTP, IMAP and POP3 ports are forwarded to the server and the hMail server is configured as per the setup guide.

Does anyone have any ideas or know what ive missed. Thanks

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-03-12 06:38

Can you post some logs to start. Enable smtp, pop, imap, etc..

frink
New user
New user
Posts: 3
Joined: 2008-03-12 06:20

Post by frink » 2008-03-12 06:54

ERROR_hmailserver_2008-02-12.log

"ERROR" 4588 "2008-03-12 15:49:35.656" "Source: IOCPServer::_CreateListenSocket, Code: HM4316, Description: Call to bind() failed. Error: 10048. Is another server is already using this port (25)?"
"ERROR" 4588 "2008-03-12 15:49:35.656" "Source: IOCPServer::DoWork(), Code: HM4323, Description: _CreateListeningSockets() failed. Error: 183"



hmailserver_2008-02-12.log

"DEBUG" 5636 "2008-03-12 15:49:35.656" "Application::StartServers()"
"DEBUG" 5636 "2008-03-12 15:49:35.656" "Application::~StartServers()"
"APPLICATION" 4588 "2008-03-12 15:49:35.656" "Source: IOCPServer::_CreateListenSocket, Code: HM4316, Description: Call to bind() failed. Error: 10048. Is another server is already using this port (25)?"
"DEBUG" 2428 "2008-03-12 15:49:35.656" "ExternalFetchManager::Start()"
"DEBUG" 5728 "2008-03-12 15:49:35.656" "SMTPDeliveryManager::Start()"
"APPLICATION" 4588 "2008-03-12 15:49:35.656" "Source: IOCPServer::DoWork(), Code: HM4323, Description: _CreateListeningSockets() failed. Error: 183"
"DEBUG" 5484 "2008-03-12 15:54:35.656" "TimedoutConnectionRemoverTask::DoWork()"

Its says i have another server using port 25 but if so i have no idea what it is.

User avatar
mattg
Moderator
Moderator
Posts: 21103
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Post by mattg » 2008-03-12 07:33

do you IIS POP3 running on your win 2003 server?

Check in Add / remove programs >> windows components

Matt

frink
New user
New user
Posts: 3
Joined: 2008-03-12 06:20

Post by frink » 2008-03-12 07:51

Thanks guys its all workin now.
It was a mail component of my web server package which i didnt know was installed.

Post Reply