Problem with Authentication XXXX

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Problem with Authentication XXXX

Post by plobby » 2008-02-09 09:10

I have read the the guides, searched the forums and found a ton of threads related to this, mine is not much different but I have tried a few things and have yet to get it to work.

I setup a second domain today on my mail server. I had everything working perfectly, but now when I try and use outlook I cannot send mail outside these two domains. It give me the 530 error, smtp server requires authentication.

I have this disabled though. I have also tried enabling it and put the proper settings in my outlook account settings and still to no avail does this work.

I have disabled it on the server (default settings) and disabled it in my outlook and it still does now work. I have enabled it on the server and disabled it in out, and vice versa and that does not work either.

What am I doing wrong? Does this have something to do with ip ranges?

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-09 09:16

I got it working, but is it safe to have it be set to...

Not requiring authentication to external accounts?

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-09 10:34

You should configure hMailServer to require authentication when sending to external accounts. Please enable SMTP logging, reproduce the problem and post the log here.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 08:43

fixed.
Last edited by plobby on 2008-04-08 06:19, edited 1 time in total.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-10 10:57

Your Outlook Express is not using SMTP authentication. I don't think the settings in Outlook Express is correct. You should select that your outgoing email server requires authentication in the account settings.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 20:12

martin wrote:Your Outlook Express is not using SMTP authentication. I don't think the settings in Outlook Express is correct. You should select that your outgoing email server requires authentication in the account settings.
I have tried both checking it and un checking it, both errors come up.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-10 21:15

Was it checked when you captured the latest log you posted here? If not, check the setting, reproduce the problem and post the log here.

If you see this log when you've selected that your outgoing server requires authentication in OE, your Outlook Express installation is broken. You could try to remove the account and then add it again to see if that solves it.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 21:16

It was not checked with the log, but i get the exact same error message through outlook when its checked/unchecked.

One second, ill get the log posted in a minute.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 21:19

fixed.
Last edited by plobby on 2008-04-08 06:20, edited 1 time in total.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-10 21:37

Are you running a cisco pix firewall?

If so you need to turn off the fixup protocol.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-10 21:38

I'm starting to get annoyed by Ciscos crap..

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 21:40

^DooM^ wrote:Are you running a cisco pix firewall?

If so you need to turn off the fixup protocol.
Yes I am. But which fixup protocol? Smtp?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-10 21:42

plobby wrote:
^DooM^ wrote:Are you running a cisco pix firewall?

If so you need to turn off the fixup protocol.
Yes I am. But which fixup protocol? Smtp?
Yes.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 21:43

Alright, ill do that now.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-10 21:47

And now it works perfectly, thank you very much. How was this message with authentication?

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-11 03:36

Dunno why it happens. My pix did the same its some kind of weird packet inspection which causes the HELO command to be used incorrectly. notice the XXXX in the log.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-11 03:47

^DooM^ wrote:Dunno why it happens. My pix did the same its some kind of weird packet inspection which causes the HELO command to be used incorrectly. notice the XXXX in the log.
Hmm, weird. But thank you!

User avatar
SorenR
Senior user
Senior user
Posts: 3818
Joined: 2006-08-21 15:38
Location: Denmark

Post by SorenR » 2008-02-11 14:27

How Mailguard Works
In Part 1, when the mailserver receives an invalid or unacceptable command, it generates a 500 Command unrecognized message. In Part 2, when Mailguard is configured, the PIX then intercepts the entered command, and passes only valid commands (that is, one of the seven minimum-required SMTP commands) on to the mail server behind the PIX Firewall. It then returns an OK to the user regardless of whether the command entered was passed on or denied. In this way, PIX confuses anyone that attempts an attack on the mail system. The Mailguard feature also works in versions 4.2 and later. It is activated using the fixup protocol smtp 25 command instead of the mailhost command.

Note: If you have an ESMTP server behind the PIX, such as a Microsoft Exchange Server, you might need to turn off the Mailguard feature to allow mail to flow properly. Also, doing Telnet to port 25 might not work with the fixup protocol smtp command, especially with a Telnet client that does character mode.
http://www.cisco.com/en/US/products/hw/ ... 2ecb.shtml

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-11 15:41

That will be why then =D

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-11 23:29

Ohh I see now, that explains a lot :p

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-11 23:43

Been quite a lot of users who have reported this problem recently. I've added some notes about this problem to the hMailServer documentation.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Re:

Post by plobby » 2008-04-08 06:19

fixed.

Post Reply