Cannot Connect/Send/Receive with outlook express

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
mmvenne
New user
New user
Posts: 5
Joined: 2007-12-12 16:51

Cannot Connect/Send/Receive with outlook express

Post by mmvenne » 2007-12-12 17:00

Hi everyone,

This is my first post, so please go easy on me!

I have a windows 2003 standard box, and in it I am running a vmware of another windows 2003 standard.

On this VM Ware, I have installed hmail and have fully configured it according to the docs provided online.

From the server I can run outlook express and my send and receive/connection works and I can create and send mail and receive it.

This is the problem:
from the host computer, the windows 2003 standard thats hosting the vmware, I cannot connect/send/receive to the server and it just times out and keeps trying with no real error message that is of any use.

I can telnet into both pop and smtp and send and receive email so I know the ports are working.

Anyone have any ideas? I may be vague, but let me know if you need more details!

Marc.

mmvenne
New user
New user
Posts: 5
Joined: 2007-12-12 16:51

Post by mmvenne » 2007-12-12 18:46

I don't know if this helps, but I get the following error after a long timeout trying to connect with outlook express.

Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'markg', Server: 'XXX.XXX.XXX.XXX', Protocol: SMTP, Port: 25, Secure(SSL): Yes, Socket Error: 10053, Error Number: 0x800CCC0F

I have placed XXX.XXX.XXX.XXX to replace my server IP, for privacy reasons.

Marc

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-12-12 20:41

According to that error you are trying to use SSL? If you are using V4 then it will not connect.

mmvenne
New user
New user
Posts: 5
Joined: 2007-12-12 16:51

Post by mmvenne » 2007-12-12 22:13

^DooM^ wrote:According to that error you are trying to use SSL? If you are using V4 then it will not connect.
Hi Doom,

Not that I doubt you, as I see your very well informed posts all over in the forum, but I am not using SSL on my client. In my advanced settings of my account on outlook express, I do not have the "server requires a secure connection SSL" checked off.

I tried to find something on the hmail server side concerning SSL, to see if it's enabled, but I don't see anything like that.

One more note that I didn't mention, this current scenario is in preparation of a mail server migration. Basically the box I have with windows 2003 and the vmware are not using a real DNS at the moment. I am using a dummy DNS, simply to create the accounts, and test the mail server and client on the internal LAN side of things first.

In outlook express I have specified the IP of the server for both incoming POP3 and Outgoing SMTP addresses. This configuration is exactly the same on the outlook express I set inside the vmware, and it works great.

My only "guess" is that the host computer will try to resolve the dummy domain name out to the internet, but I have no idea if it's trying to do this. I have used wireshark and I don't really see anything too bizarre, but I will keep investigating!

Marc

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2007-12-13 00:20

Account: 'markg', Server: 'XXX.XXX.XXX.XXX', Protocol: SMTP, Port: 25, Secure(SSL): Yes, Socket Error: 10053, Error Number: 0x800CCC0F
Reason I asked that was because of the above quoted text, highlighted in red.

I am no expert on outlook as I haven't used it in years and that could just be some weird generic error message.

mmvenne
New user
New user
Posts: 5
Joined: 2007-12-12 16:51

Post by mmvenne » 2007-12-13 02:20

The problem has been resolved. By default, the windows 2003 firewall service is disabled. I enabled it, and set it to off. (For those of you who know 2003 well, you know what I mean).

This solved the problem, it's as if by default, ports are being blocked by windows 2003 before completely disabling the firewall. The WEIRD thing here is, that port 25 and 110 telnet log in send mail and receive/view mail worked prior to this change.

Although it works, anyone know exactly what happened behind the scenes, who could possibly shed some light on why this happens?

Marc.

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-15 00:15

Marc, can you please share how to set up the Outlook Express?

I have installed hMailserver in a VMserver. Installation seems okay. "telnet mail.hmailserver.com 25" gives me 220 mail.hmailserver.com ESMTP. However, when I set up an admin account in Outlook Express and tried to send a test mail, I got the following error:

There was a problem logging onto your mail server. Your Password was rejected. Account: 'Administrator account', Server: 'mail.hmailserver.com', Protocol: POP3, Server Response: '-ERR Invalid user name or password. Please use full email address as user name.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92

Can you please share your successful experience? Thanks a lot.


[quote="mmvenne"]The problem has been resolved. By default, the windows 2003 firewall service is disabled. I enabled it, and set it to off. (For those of you who know 2003 well, you know what I mean).

This solved the problem, it's as if by default, ports are being blocked by windows 2003 before completely disabling the firewall. The WEIRD thing here is, that port 25 and 110 telnet log in send mail and receive/view mail worked prior to this change.

Although it works, anyone know exactly what happened behind the scenes, who could possibly shed some light on why this happens?

Marc.[/quote]

mmvenne
New user
New user
Posts: 5
Joined: 2007-12-12 16:51

Post by mmvenne » 2008-02-15 00:25

Hey there CF,

I didn't do anything special in order to make it connect.

I specified the incoming and outgoing main (pop3 and smtp) and the account name and password under the Servers tab in the account settings.

I did NOT have to enable "my server requires authentication".

That was about it.

One thing that did help me though was using telnet to "test" to see if all was working, including port 25 being open. I would strongly suggest trying this first, and let me know if that worked for you. (At least you will know if your username and password work).

There are many website that can help you with this, but I will paste something that can help:

I used this link to test, look under POP3 and concluding notes:
http://www.garnetchaney.com/how_to_teln ... rver.shtml

This link could be useful also
http://www.activexperts.com/activemail/telnet/

Cheers, and good luck!

Marc
___________________________
Marc

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-21 00:43

mmvenne. Thanks for response, advice and info are great!

Problem is I have got the error in Outlook Express with a testing ourgoing mail.

The connection to the server has failed. Account: 'pop3.fscddv1.com', Server: 'pop3.fscddv1.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E

I have read through your 2 links and followed the tests.
In your 2nd link I have walked through up to :

Step 4
"Tell the server who you want to send the e-mail to. Let me send a mail to info@activexperts:
rcpt to: info@activexperts.com
There are no restrictions here. You can enter any e-mail address. If there is some problem with the recipient-address, your mail will bounce, but for now, the server doesn't complain. It will say:
250 Ok"

I didn't get the "250 Ok". Instead I got "530 SMTP authentication is required"

Any clues?

Thanks,
CF

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-21 01:47

Enable 'My server requires authentication'.

It will be under accounts, your account, then servers.

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-22 00:29

Yes. I did, plobby.
I have checked the box of "My sever requires authentication" under Outgoing Mail Server of the Servers page as you said. In the Settings, I just kept the "Use same setting as my incoming mail server" option.

I still received the following Outlook Express error message:

"The connection to the server has failed. Account: 'pop3.mydomain.com', Server: 'pop3.mydomain.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E"

However, I have checked that I was able to ping the pop3.mydomain.com and I have got the IP address. I supposed my DNS setup is okay.

What have I missed? Very frustrated...

[quote="plobby"]Enable 'My server requires authentication'.

It will be under accounts, your account, then servers.[/quote]

User avatar
SorenR
Senior user
Senior user
Posts: 3818
Joined: 2006-08-21 15:38
Location: Denmark

Post by SorenR » 2008-02-22 00:59

cf wrote:There was a problem logging onto your mail server. Your Password was rejected. Account: 'Administrator account', Server: 'mail.hmailserver.com', Protocol: POP3, Server Response: '-ERR Invalid user name or password. Please use full email address as user name.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92
Did you define a default domain in hMailServer (first choice in Advanced settings), if not you need to log on as "my-user@my-domain.com" for hMailServer to identify you.

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

hMailserver works with SharePoint?

Post by cf » 2008-02-26 00:56

I have tried your advice. It still doesn't not work...... I'm still hoping it will work.... good grief!

[quote="SorenR"][quote="cf"]There was a problem logging onto your mail server. Your Password was rejected. Account: 'Administrator account', Server: 'mail.hmailserver.com', Protocol: POP3, Server Response: '-ERR Invalid user name or password. Please [b]use full email address as user name.[/b]', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92
[/quote]
Did you define a default domain in hMailServer (first choice in Advanced settings), if not you need to log on as "my-user@my-domain.com" for hMailServer to identify you.[/quote]

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-26 01:03

cf wrote:There was a problem logging onto your mail server. Your Password was rejected. Account: 'Administrator account', Server: 'mail.hmailserver.com', Protocol: POP3, Server Response: '-ERR Invalid user name or password. Please use full email address as user name.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92
... why are you trying to log on mail.hmailserver.com? You know you should spcecify your own email server in your email client, right?

User avatar
SorenR
Senior user
Senior user
Posts: 3818
Joined: 2006-08-21 15:38
Location: Denmark

Post by SorenR » 2008-02-26 01:49

:lol:

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Problems in installing hMailServer, Outlook Express and DNS

Post by cf » 2008-02-26 18:15

Sorry for the confusion.

At the Outlook Express client:
When I send a testing email to myAccount@myDomain.com
The error message I have got:
The connection to the server has failed. Account: 'MyhMailServer', Server: 'pop3.myDomain.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E

The setting I have in the Outlook Express:
Under General tab:
Mail Account = MyhMailServer
E-mail address = myAccount@myDomain.com
Under Servers tab:
Incoming mail (POP3) = pop3.myDomain.com
Outgoing mail (SMTP) = smtp.myDomain.com
Incoming MailServer Account name = myAccount@myDomain.com

From the client I can ping (got reply from Host's ip address):
pop3.myDomain.com
smtp.myDomain.com
mail.myDomain.com

At the hMailServer Administrator:
An account under myDomain.com = myAccount@myDomain.com
SMTP setting:Delivery of e-mail tab: Host name = mail.myDomain.com

At the DNS management console:
Under MyServer, Forward Lookup Zones, myDomain.com, I have the follow records:
Name Type Host
mail Host (A) Host's ip address
pop3 Host (A) Host's ip address
smtp Host (A) Host's ip address
(same as parent folder) Mail Exchanger (MX) MyServer.myDomain.com

My Computer name = MyServer.myDomain.com

What have I missed? Or, any wrong settings?

All hMailServer gurus, please help. Many Thanks.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-26 20:09

How do you think anyone here would be able to say whether you're settings are correct when you just post a dummy domain name? There's no way for anyone here to tell whether "myserver.mydomain.com" is the correct host... :)

If you ping pop3.mydomain.com, do you get a response?
If you telnet this host on TCP/IP port 110, can you connect?
Have you checked that the firewall isn't blocking incoming connections on this port?

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-26 21:41

I just substituted my real computer and domain name with "myserver.mydomain.com" to show you the scenario.

Yes. I have turned off the Windows firewall.

When "telnet mail.hmailserver.com 25", I got ""220 mail.hmailserver.com ESMP".
When "telnet mail.hmailserver.com 110", I got "+OK POP3".

When "telnet myserver.mydomain.com 25", I got "220 myserver.mydomain.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3
959 ready at Tue, 26 Feb 2008 14:22:57 -0500"

When "telnet myserver.mydomain.com 110", I got "Connecting To myserver.mydomain.com...Could not open connection to the host
, on port 110: Connect failed".

Does this mean anything? If this is the problem, how to fix it?

Thanks.

plobby
Normal user
Normal user
Posts: 115
Joined: 2008-01-29 07:04

Post by plobby » 2008-02-26 21:48

I didnt read the entire thread, but have you properly forwarded port 110?

You said you can telnet into your pop/smtp just fine, but the error you just showed shows you cannot with your pop server.

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-26 22:07

Plobby, can you please tell me how to check if I have "properly forwarded your port for 110"?

In my previous mail, I mentioned:
At the DNS management console:
Under MyServer, Forward Lookup Zones, myDomain.com, I have the follow records:
Name Type Host
mail Host (A) Host's ip address
pop3 Host (A) Host's ip address
smtp Host (A) Host's ip address
(same as parent folder) Mail Exchanger (MX) MyServer.myDomain.com

Thanks for response.

User avatar
mattg
Moderator
Moderator
Posts: 21103
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Post by mattg » 2008-02-27 01:46

cf wrote:When "telnet mail.hmailserver.com 25", I got ""220 mail.hmailserver.com ESMP".
When "telnet mail.hmailserver.com 110", I got "+OK POP3".
Great.
cf wrote:When "telnet myserver.mydomain.com 25", I got "220 myserver.mydomain.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3
959 ready at Tue, 26 Feb 2008 14:22:57 -0500"
Sounds like you have IIS SMTP enabled on that computer.

Matt

cf
New user
New user
Posts: 9
Joined: 2008-02-14 23:54

Post by cf » 2008-02-27 17:12

Yes, Matt. But:

When "telnet myserver.mydomain.com 110", I got "Connecting To myserver.mydomain.com...Could not open connection to the host
, on port 110: Connect failed".

Does this mean anything? If this is the problem, how to fix it?

Thanks.

^DooM^
Site Admin
Posts: 13861
Joined: 2005-07-29 16:18
Location: UK

Post by ^DooM^ » 2008-02-27 17:48

Un-install IIS SMTP server reboot your machine and see if that corrects your issue.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2008-02-27 19:59

If you tell hMailServer to run a SMTP server and POP3 server, but you run another SMTP server on the same computer, the hMailServer POP3 server may not start properly either since an error will occur during start up. So as ^DooM^ says, Disable/Uninstall IIS SMTP and reboot.

Post Reply