Page 1 of 1

HELP! cant get ASSP working :(

Posted: 2007-12-02 11:04
by Shadoxity
Hey everyone,

Having a really REALLY hard time getting anti spam working on my server.

Tried spamassasin, couldnt get it going
tried mailwasher server, would not allow me to send to any domain other than my own.

Tried ASSP witht he new install how to, got it all installed but am unable to send any emails :(

This is really pi$$ing me off....

what happens is when sending an email to the local addresses i get an email back saying. "'' on 2/12/2007 7:59 PM 451 4.7.1 Please try again later"
Sending to another domain i get "' on 2/12/2007 7:59 PM 530 Relaying not allowed"

My domain is in the allowed local domains etc, is in Accept All Mail.

My guess is that this is an error from ASSP??? cause i dont know hmailserver to deliver via "system administrator" email addresses.

Please help this is driving me crazy and making me so frustrated, i have googled all i can and cant work it out :(

The mail log in ASSP gives me this

Dec-2-07 19:58:54 [InvalidLocalSender][scoring]** <> scoring
Invalid Local
Dec-2-07 19:58:54 [RelayAttempt]** <> relay attempt blocked

one other thing is that im sending it from another PC on my network, but in ASSP it seems to be bringing up my external IP address???

any help is greatly appreciated, i have no idea whats going wrong!

Posted: 2007-12-02 14:06
by minsik
assp is not easy. we took severl weeks in trial mode b4 using. Now i will recommend it for all. We are small company 50-60 users. sick of spam before. now happy people!

you have to tell assp what your local domain is. ie under the section "relaying" or else it wont know that this is the local domain thats local to its normal use.

hope this helps.

warning or helpful advise from me. use a clean install and get a standard assp.cfg to asrt off with. change as little as possible to get it working. Set test modes for all. see email coming and going through it. After spam and not spam buit up then do a spamdbrebuild. we set this in windows scheduler every day in the early morning. then gradually activate one thing at a time. change one thing at a time. when it works leave it alone!

We cc al spam to a local mailbox and then if it was actually good email we can sort of recover the file. (only the email and only 4k is what we save) its a sort of protection. anyway good luck.

oh yes its port 25>assp>225>hmainserver>end user.

Hope thats clear. ask again if need to. try to give info as you did in this case too.


ps i hope you have had hmailserver working and have used its greylisting etc as its spam filtering may be most of what you really need.

Posted: 2007-12-03 10:15
by Shadoxity
Hey mate,
Thanks for trying to help, have got my domain in the relaying section but it just does not work at all! it just flat out rejects the emails!

have used the greylisting but was still getting heaps of spam, its only a small userbase of about 15. and the delay in getting emails from some servers was really annoying!

Is there any where in hmail i should look? is there any way to get ASSP to allow all emails through and have hmailserver authenticate?

Need some desperate help as this is really killing me! i cant understand why it wont work!

Posted: 2007-12-03 11:10
by danny6167
i have used assp for a while and i didnt find it that hard to use. That is once i got perl and dependices installed. that prob was more of bad luck( sites down etc)

If you want add me on msn and asuming out timezones/waking hours match up ill give ya a hand,

daniel <at>

Posted: 2007-12-03 22:54
by Shadoxity
Thanks Daniel, I Appreciate it, i will add you and hopefully are online at the same time :)

Posted: 2007-12-04 08:15
by danny6167
Yeh well my sleeping pattens are a bit unpredictable so times zones don't count :P

Posted: 2007-12-05 01:52
by Shadoxity
same here :P hope it matches at somepoint in the next week or so :) added you to MSN

Posted: 2007-12-06 17:00
by danny6167
well after me randomly nudging him on msn while he way AFK then him responding shortly after i left my room for cheese cake we finally got it fixed.
Still have no idea of the cause but what we did was reset the ASSP config file.