Page 1 of 1

Problem with awstats: too many corrupted record ?

Posted: 2007-09-18 10:36
by Thomas Parvais

I've installed awstats to perform reporting on HMS traffic & usage. I enable awstats logging.

Here is an example of the log file:
2007-09-09 14:38:07 SMTP ?virus=&rblgheuristicspam=0&ssl=0 250 80937
2007-09-09 14:38:20 SMTP ?virus=&rblgheuristicspam=0&ssl=0 250 80937
2007-09-09 14:38:27 SMTP ?virus=&rblgheuristicspam=0&ssl=0 250 80937
I configure Awstats with the following parameters: in awstats.maxetzoe.conf:

Code: Select all

LogFile="C:/Program Files/hMailServer/Logs/hmailserver_awstats.log"
LogFormat="%time2 %email %email_r %host %method %url %code %bytesd" 
When i launch the script to update the DB by parsing the log, I found a lot of corrupted lines in the log: 7700 corrupted lines on 14000 total lines.

Where is the bug/issue ?

Thank you


Posted: 2007-09-18 12:23
by martin
Try using the LogFormat found in the logging documentation:
LogFormat="%time2 %email %email_r %host %host_r %method %url %code %bytesd"

Posted: 2007-09-18 12:42
by Thomas Parvais
martin wrote:Try using the LogFormat found in the logging documentation:
LogFormat="%time2 %email %email_r %host %host_r %method %url %code %bytesd"
I tried first, but according to me host_r is not present in hms log file !? In that case, all lines are incorrect


Posted: 2007-09-18 21:41
by martin
So you tried first and it didn't work? Or..? I agree, your line looks more correct but the one I suggested has been working according to other people. :-\

A bit hard to say why awstats say that the records are corrupt without actually seeing the corrupt ones. Perhaps possible to log those records in some way? :-\

Posted: 2007-09-19 09:15
by Thomas Parvais
Im' using the last release of awstats. i'll look at how to enable debug mode in awstats