IMAP and POP not working

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
Post Reply
Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

IMAP and POP not working

Post by Matargro » 2020-10-17 22:10

Hello,

I have problem with IMAP and POP3. If i login from outlook the server didn’t respone, but in log isn’t any error.

Thx for support.

User avatar
jimimaseye
Moderator
Moderator
Posts: 8727
Joined: 2011-09-08 17:48

Re: IMAP and POP not working

Post by jimimaseye » 2020-10-17 22:40

If tcpip and imap logging is enabled:

No log = no connection.
Check you routing, firewall/forwarding and dns

If tcpip and imap logging isn't enabled:
Enable it. Try again.

[Entered by mobile. Excuse my spelling.]
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-17 22:46

Here is the log, tcp loging is enabled

Code: Select all

"TCPIP"	9372	"2020-10-17 21:29:43.728"	"TCP - 46.174.20.12 connected to 46.28.107.249:143."
"IMAPD"	9372	3	"2020-10-17 21:29:43.732"	"46.174.20.12"	"SENT: * OK IMAPrev1"
"TCPIP"	9372	"2020-10-17 21:30:04.002"	"TCP - 127.0.0.1 connected to 127.0.0.1:143."
"IMAPD"	9372	8	"2020-10-17 21:30:04.005"	"127.0.0.1"	"SENT: * OK IMAPrev1"
"IMAPD"	9372	8	"2020-10-17 21:30:04.012"	"127.0.0.1"	"RECEIVED: A0001 CAPABILITY"
"IMAPD"	9372	8	"2020-10-17 21:30:04.015"	"127.0.0.1"	"SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk[nl]A0001 OK CAPABILITY completed"
"IMAPD"	4072	8	"2020-10-17 21:30:04.018"	"127.0.0.1"	"RECEIVED: A0002 CAPABILITY"
"IMAPD"	4072	8	"2020-10-17 21:30:04.021"	"127.0.0.1"	"SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk[nl]A0002 OK CAPABILITY completed"
"IMAPD"	9372	8	"2020-10-17 21:30:04.024"	"127.0.0.1"	"RECEIVED: A0003 LOGIN admin@czdplzen.cz ***"
"IMAPD"	9372	8	"2020-10-17 21:30:04.048"	"127.0.0.1"	"SENT: A0003 OK LOGIN completed"
"IMAPD"	9372	8	"2020-10-17 21:30:04.051"	"127.0.0.1"	"RECEIVED: A0004 STATUS INBOX (MESSAGES UNSEEN)"
"IMAPD"	9372	8	"2020-10-17 21:30:04.055"	"127.0.0.1"	"SENT: * STATUS "INBOX" (MESSAGES 2 UNSEEN 0)[nl]A0004 OK Status completed"
"IMAPD"	4072	8	"2020-10-17 21:30:04.058"	"127.0.0.1"	"RECEIVED: A0005 SELECT INBOX"
"IMAPD"	4072	8	"2020-10-17 21:30:04.060"	"127.0.0.1"	"SENT: * 2 EXISTS[nl]* 0 RECENT[nl]* FLAGS (\Deleted \Seen \Draft \Answered \Flagged)[nl]* OK [UIDVALIDITY 1602775828] current uidvalidity[nl]* OK [UIDNEXT 14] next uid[nl]* OK [PERMANENTFLAGS (\Deleted \Seen \Draft \Answered \Flagged)] limited[nl]A0005 OK [READ-WRITE] SELECT completed"
"IMAPD"	9372	8	"2020-10-17 21:30:04.063"	"127.0.0.1"	"RECEIVED: A0006 UID SEARCH 2"
"IMAPD"	9372	8	"2020-10-17 21:30:04.065"	"127.0.0.1"	"SENT: * SEARCH 7"
"IMAPD"	9372	8	"2020-10-17 21:30:04.068"	"127.0.0.1"	"SENT: A0006 OK UID completed"
"IMAPD"	9372	8	"2020-10-17 21:30:04.075"	"127.0.0.1"	"RECEIVED: A0007 UID FETCH 6:7 (FLAGS)"
"IMAPD"	9372	8	"2020-10-17 21:30:04.077"	"127.0.0.1"	"SENT: * 1 FETCH (UID 6 FLAGS (\Seen))"
"IMAPD"	9372	8	"2020-10-17 21:30:04.080"	"127.0.0.1"	"SENT: * 2 FETCH (UID 7 FLAGS (\Seen))"
"IMAPD"	9372	8	"2020-10-17 21:30:04.082"	"127.0.0.1"	"SENT: A0007 OK UID completed"
"IMAPD"	9372	8	"2020-10-17 21:30:04.106"	"127.0.0.1"	"RECEIVED: A0008 LOGOUT"
"IMAPD"	9372	8	"2020-10-17 21:30:04.109"	"127.0.0.1"	"SENT: * BYE Have a nice day[nl]A0008 OK Logout completed"

User avatar
jimimaseye
Moderator
Moderator
Posts: 8727
Joined: 2011-09-08 17:48

Re: IMAP and POP not working

Post by jimimaseye » 2020-10-17 22:56

Matargro wrote:
2020-10-17 22:46

Code: Select all

"TCPIP"	9372	"2020-10-17 21:30:04.002"	"TCP - 127.0.0.1 connected to 127.0.0.1:143."
"IMAPD"	9372	8	"2020-10-17 21:30:04.005"	"127.0.0.1"	"SENT: * OK IMAPrev1"
"IMAPD"	9372	8	"2020-10-17 21:30:04.012"	"127.0.0.1"	"RECEIVED: A0001 CAPABILITY"
.
.
.
Imap working ok on the email client that is on the server machine. Is this your outlook you refer to?

[Entered by mobile. Excuse my spelling.]
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-17 23:08

Yes on roundcube on same server working perfectly but on my pc or phone isn’t working

User avatar
jimimaseye
Moderator
Moderator
Posts: 8727
Joined: 2011-09-08 17:48

Re: IMAP and POP not working

Post by jimimaseye » 2020-10-17 23:53

jimimaseye wrote:
2020-10-17 22:40
If tcpip and imap logging is enabled:

No log = no connection.
Check you routing, firewall/forwarding and dns
Also run this and post the results: https://www.hmailserver.com/forum/viewt ... 20&t=30914
[Entered by mobile. Excuse my spelling.]
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-18 00:22

Code: Select all

2020-10-18   Hmailserver: 5.6.7-B2425

DOMAINS

   "Domain1.com" - czxxxxxx.cz                    Enabled: True

SIGNATURE         LIMITS                       DKIM               ADVANCED
  Enabled: False   Max size:                0   Enabled: True    
                   Max message size:        0   Header:   Relaxed  Plus addressing: False
                   Max size of accounts:    0   Body:     Relaxed
                                                Algorithm: SHA256  Greylisting:     False
                                                Private key: c:\servers\dkim.Domain1.com.pem
                                                Selector:    dkim

   "Domain2.com" - haxxxxxxxxxx.cz                Enabled: True

SIGNATURE         LIMITS                       DKIM               ADVANCED
  Enabled: False   Max size:                0   Enabled: False   
                   Max message size:        0                      Plus addressing: False
                   Max size of accounts:    0                    
                                                                   Greylisting:     False
-----------------------------------------------------------------------------------------------

IP RANGES

IP: 127.0.0.1 - 127.0.0.1     Priority: 15     Name: My computer

  Allow connections                         Other
     SMTP:   True                              Antispam :   True
     POP3:   True                              Antivirus:   True !! ANTIVIRUS NOT CONFIGURED !!
     IMAP:   True                              SSL/TLS:    False

  Allow Deliveries from                     Require Authentication from
     Local To Local       -  True              Local To Local       - False
     Local To External    -  True              Local To External    - False
     External To Local    -  True              External To Local    - False
     External To External -  True              External To External -  True


IP: 0.0.0.0 - 255.255.255.255     Priority: 10     Name: Internet

  Allow connections                         Other
     SMTP:   True                              Antispam :   True
     POP3:   True                              Antivirus:   True !! ANTIVIRUS NOT CONFIGURED !!
     IMAP:   True                              SSL/TLS:    False

  Allow Deliveries from                     Require Authentication from
     Local To Local       -  True              Local To Local       -  True
     Local To External    -  True              Local To External    -  True
     External To Local    -  True              External To Local    - False
     External To External -  True              External To External -  True


------------------------------------------------------
AUTOBANNED Local Addresses:
    No entries

-----------------------------------------------------------------------------------------------

AUTOBAN
  Autoban Enabled: True       Max invalid logon attempts:      5
                              Minutes Before Reset:           30  (0,50 hours, 0,02 days)
                              Minutes to Autoban:             60  (1,00 hours, 0,04 days)

No problems were found in the IP range configuration.
-----------------------------------------------------------------------------------------------

INCOMING RELAYS
   No entries
-----------------------------------------------------------------------------------------------

MIRRORING         Disabled
-----------------------------------------------------------------------------------------------

PROTOCOLS

SMTP
GENERAL             DELIVERY                  RFC COMPLIANCE            ADVANCED
No. Connections:  0  No Retries:  4 Mins: 60   Plain Text:         True  Bind: 
                     Host: EXTERNAL.TLD        Empty sender:       True  Batch recipients:   100
Max Msg Size: 20480  Relay:-                   Incorrect endings:  True  Use STARTTLS:      True
                     (none entered)            Disc. on invalid:   True  Delivered-To hdr: False
                                               Max number commands: 100  Loop limit:           5
                                                                         Recipient hosts:     15
  Routes:
     No routes defined.

POP3
  No. Connections: 0

IMAP
 GENERAL                   PUBLIC FOLDERS                    ADVANCED
  No. Connections:   0      Public folder name: #Public       IMAP sort:  True
                                                              IMAP Quota: True
                                                              IMAP Idle:  True
                                                              IMAP ACL:   True
                                                              Delim: "."
-----------------------------------------------------------------------------------------------

ANTISPAM

GENERAL                              SPAM TESTS              Score   SPAMASSASSIN
  Spam Mark:                  5       Use SPF:            True - 3    Use Spamassassin:   False
  Add X-HmailServer-Spam:     True    Check HELO host:    True - 2
  Add X-HmailServer-Reason:   True    Check MX records:   True - 2
  Add X-HmailServer-Subject: False    Verify DKIM:        True - 5

  Spam delete threshold: 20         Maximum message size: 1024

DNSBL ENTRIES:
   No 'enabled' entries

SURBL ENTRIES:
   No 'enabled' entries

GREYLISTING:
  Greylisting:  False

WHITELISTING
   No entries
-----------------------------------------------------------------------------------------------

ANTIVIRUS:  No application configured.

  Block Attachments: False
-----------------------------------------------------------------------------------------------

SSL CERTIFICATES
   No entries
-----------------------------------------------------------------------------------------------

SSL/TLS
             SSL 3.0 :  False
             TLS 1.0 :   True
             TLS 1.1 :   True
             TLS 1.2 :   True                Verify Remote SSL/TLS Certs:   True
SslCipherList  :

ECDHE-RSA-AES128-GCM-SHA256     - ECDHE-ECDSA-AES128-GCM-SHA256   - ECDHE-RSA-AES256-GCM-SHA384     
ECDHE-ECDSA-AES256-GCM-SHA384   - DHE-RSA-AES128-GCM-SHA256       - DHE-DSS-AES128-GCM-SHA256       
kEDH+AESGCM                     - ECDHE-RSA-AES128-SHA256         - ECDHE-ECDSA-AES128-SHA256       
ECDHE-RSA-AES128-SHA            - ECDHE-ECDSA-AES128-SHA          - ECDHE-RSA-AES256-SHA384         
ECDHE-ECDSA-AES256-SHA384       - ECDHE-RSA-AES256-SHA            - ECDHE-ECDSA-AES256-SHA          
DHE-RSA-AES128-SHA256           - DHE-RSA-AES128-SHA              - DHE-DSS-AES128-SHA256           
DHE-RSA-AES256-SHA256           - DHE-DSS-AES256-SHA              - DHE-RSA-AES256-SHA              
AES128-GCM-SHA256               - AES256-GCM-SHA384               - ECDHE-RSA-RC4-SHA               
ECDHE-ECDSA-RC4-SHA             - AES128                          - AES256                          
RC4-SHA                         - HIGH                            - !aNULL                          
!eNULL                          - !EXPORT                         - !DES                            
!3DES                           - !MD5                            - !PSK;                           
-----------------------------------------------------------------------------------------------

TCPIP PORTS                                         Connection Sec
               0.0.0.0         / 25    / SMTP   -   None                
               0.0.0.0         / 110   / POP3   -   None                
               0.0.0.0         / 143   / IMAP   -   None                
               0.0.0.0         / 587   / SMTP   -   None                
               0.0.0.0         / 993   / IMAP   -   None                
-----------------------------------------------------------------------------------------------

LOGGING      Logging Enabled: True

  Paths:-
    Current:  C:\Program Files (x86)\hMailServer\Logs\hmailserver_2020-10-18.log
    Error:    C:\Program Files (x86)\hMailServer\Logs\ERROR_hmailserver_2020-10-18.log
    Event:    C:\Program Files (x86)\hMailServer\Logs\hmailserver_events.log - Not present
    Awstats:  C:\Program Files (x86)\hMailServer\Logs\hmailserver_awstats.log
                        APPLICATION -      .
                        SMTP        -    True
                        POP3        -    True
                        IMAP        -    True
                        TCPIP       -    True
                        DEBUG       -      .
                        AWSTATS     -      .
-----------------------------------------------------------------------------------------------

SYSTEM TESTS

Database type: MySQL

IPv6 support is available in operating system.

Backup directory C:\Users\Administrator\Documents\mail-backup is writable.

Relative message paths are stored in the database for all messages.

-----------------------------------------------------------------------------------------------

HMAILSERVER.INI

[Directories]
Program folder:  C:\Program Files (x86)\hMailServer\
Database folder: 
Data folder:     C:\Program Files (x86)\hMailServer\Data
Log folder:      C:\Program Files (x86)\hMailServer\Logs
Temp folder:     C:\Program Files (x86)\hMailServer\Temp
Event folder:    C:\Program Files (x86)\hMailServer\Events

[Database]
Type=              MYSQL
Username=          root
PasswordEncryption=1
Port=              3306
Server=            127.0.0.1
Internal=          0
-----------------------------------------------------------------------------------------------

Generated by HMSSettingsDiagnostics v2.01, Hmailserver Forum.

User avatar
jimimaseye
Moderator
Moderator
Posts: 8727
Joined: 2011-09-08 17:48

Re: IMAP and POP not working

Post by jimimaseye » 2020-10-18 00:39

Looks ok.

So
jimimaseye wrote:
2020-10-17 23:53
If tcpip and imap logging is enabled:

No log = no connection.
Check you routing, firewall/forwarding and dns
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-18 01:47

Ok.
But if i use the diagnostic tool i hmail server admin, everything is ok.

In firewall is all ports opened.

So where is the problem.

I can place here the dns records, if you want.

User avatar
johang
Senior user
Senior user
Posts: 323
Joined: 2008-09-01 09:20

Re: IMAP and POP not working

Post by johang » 2020-10-18 17:43

Matargro wrote:
2020-10-17 23:08
Yes on roundcube on same server working perfectly but on my pc or phone isn’t working
Matargro wrote:
2020-10-18 01:47
Ok.
But if i use the diagnostic tool i hmail server admin, everything is ok.

In firewall is all ports opened.

So where is the problem.

I can place here the dns records, if you want.
if it does not show in your hmaislerver log.... there is NO connection being made .. .. !

if you do online test towards your mailserver IMAP and POP3 and SMTP what response do you get ?
( i tried an IP in you provided i the log.. seems to be online and reachable on internet )

what kind of response does your pc and phone say when you try to configure them ?

my guess is that you found problem and sorted it out... ( propabally windows defender firewall )
___________________________________________________________end of the line
spam filter appliance gateway: www.mailcleaner.org

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-18 19:03

Yes imap and smtp and pop3 is rechable. When i test online from hmail admin.

But if i using external conection. The result is the imap is not rechable. But the firewall ports is opened.

User avatar
johang
Senior user
Senior user
Posts: 323
Joined: 2008-09-01 09:20

Re: IMAP and POP not working

Post by johang » 2020-10-18 23:39

Matargro wrote:
2020-10-18 19:03
Yes imap and smtp and pop3 is rechable. When i test online from hmail admin.

But if i using external conection. The result is the imap is not rechable. But the firewall ports is opened.


knock knock

Port Number State Service Name Service Product Service Version Service Extra Info
21 open ftp FileZilla ftpd
25 open smtp hMailServer smtpd
80 open http Microsoft IIS httpd 10.0
110 open pop3 hMailServer pop3d
135 open msrpc Microsoft Windows RPC
139 open netbios-ssn Microsoft Windows netbios-ssn
143 open imap hMailServer imapd
443 open https Microsoft HTTPAPI httpd 2.0 SSDP/UPnP
445 open microsoft-ds
587 open smtp hMailServer smtpd
990 open ftp FileZilla ftpd
993 open imap hMailServer imapd
3389 open ms-wbt-server
5357 open http Microsoft HTTPAPI httpd 2.0 SSDP/UPnP

should be viewable in your log....


perhaps you use wrong name to your server..
test with IPaddress just to make sure
___________________________________________________________end of the line
spam filter appliance gateway: www.mailcleaner.org

Matargro
New user
New user
Posts: 7
Joined: 2020-10-17 22:07

Re: IMAP and POP not working

Post by Matargro » 2020-10-19 15:38

Fixed.
Thank for support.

Post Reply