SMTP not working

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
sanjudaveu
New user
New user
Posts: 5
Joined: 2012-03-23 04:54

SMTP not working

Postby sanjudaveu » 2012-03-23 06:28

Hi,

I am very new for Hmailserver , I have setup hmailserver in my network :

I am facing issue with email sending out from my domain , while I am able to access email from outside world.

following is my mail server setup information

Hmailserver 5.3.3 version on windows 2003 R2 server
I assigned static private IP address on server.
I created MX record for my mail server pointed to my firewall.
Firewall have NAT of private IP to public IP .
Port 25 is working in both direction.
I am able to do SMTP telnet from server machine to mail.hmailserver.com on port 25.

When I am using hmailserver diagnostics getting following error
:


Test: Collect server details
hMailServer version: hMailServer 5.3.3-B1879
Database type: MSSQL Compact

Test: Test IPv6
IPv6 support is not available in operating system.

Test: Test outbound port
SMTP relayer not in use. Attempting mail.hmailserver.com:25
Trying to connect to host mail.hmailserver.com...
Trying to connect to TCP/IP address 46.163.110.124 on port 25.
ERROR: It was not possible to connect.

I am also getting this log

the requested address is not valid in its context.(screenshot attached)

Don't understand where I am missing with configuration
Attachments
mail3.jpg
mail2.jpg
mail.jpg

sanjudaveu
New user
New user
Posts: 5
Joined: 2012-03-23 04:54

Re: SMTP not working

Postby sanjudaveu » 2012-03-23 06:42

here is telnet seesion screenshot
Attachments
telnet.jpg

^DooM^
Site Admin
Posts: 13853
Joined: 2005-07-29 16:18
Location: UK

Re: SMTP not working

Postby ^DooM^ » 2012-03-23 11:43

In your bind to local IP you have put a host. That is not an IP ADDRESS is it ;) you should leave it set to 0.0.0.0 unless you have multiple IP's assigned to your server.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

sanjudaveu
New user
New user
Posts: 5
Joined: 2012-03-23 04:54

Re: SMTP not working

Postby sanjudaveu » 2012-03-23 11:49

Hi Doom,

I made changes as you suggested but still not working , can you do me a favor I can provide you remote of server so you can check where I am missing configuration.

attached is snapshot of updated chanegs
Attachments
new.jpg

^DooM^
Site Admin
Posts: 13853
Joined: 2005-07-29 16:18
Location: UK

Re: SMTP not working

Postby ^DooM^ » 2012-03-23 11:55

That's not what I told you to change, that's delivery of email hostname, not bind to local ip under General (The one in your first screenshot)
If at first you don't succeed, bomb disposal probably isn't for you! ヅ

sanjudaveu
New user
New user
Posts: 5
Joined: 2012-03-23 04:54

Re: SMTP not working

Postby sanjudaveu » 2012-03-23 12:07

I made changes both tab ,I will made change on gernel tab and what i have to put in advance tab

sanjudaveu
New user
New user
Posts: 5
Joined: 2012-03-23 04:54

Re: SMTP not working

Postby sanjudaveu » 2012-03-23 12:33

now I am getting this error screenshot is attached:

if possible for you please take remote of my server and help me .. as I am helpless
Attachments
error.jpg

^DooM^
Site Admin
Posts: 13853
Joined: 2005-07-29 16:18
Location: UK

Re: SMTP not working

Postby ^DooM^ » 2012-03-23 16:42

If you want dedicated support it is going to cost you otherwise you can do it yourself with help in the forum.

Your image shows port 25 is blocked. You need to fix it. Possibl;y you have not allowed it through your firewall or your ISP blocks port 25.
If at first you don't succeed, bomb disposal probably isn't for you! ヅ


Return to “General discussions”



Who is online

Users browsing this forum: abgar and 3 guests