can't send email, 550 Access denied - Invalid HELO name

Use this forum if you have installed hMailServer and want to ask a question related to a production release of hMailServer. Before posting, please read the troubleshooting guide. A large part of all reported issues are already described in detail here.
yordanrhapsody
New user
New user
Posts: 26
Joined: 2010-07-18 18:40

can't send email, 550 Access denied - Invalid HELO name

Postby yordanrhapsody » 2010-07-18 18:48

Hi, I have a problem when configuring the hmail server

It's installed in a server with microsoft exchange and hmail for sending

when I try to send a mail with every account configured in the server, I receive this email in return

Code: Select all

Da: mailer-daemon@mydomain.com [mailto:mailer-daemon@mydomain.com]

Inviato: martedì 13 luglio 2010 10.26

A: user@mydomain.com

Oggetto: Undeliverable: subject of the email

 

Your message did not reach some or all of the intended recipients.

 

   Sent: Tue, 13 Jul 2010 10:25:32 +0200

   Subject: subject of the email

 

The following recipient(s) could not be reached:

 

"email of addresse"

   Error Type: SMTP

   Remote server (74.53.93.162) issued an error.

   hMailServer sent: MAIL FROM:<user@mydomain.com>

   Remote server replied: 550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

 

 

 

hMailServer


how can I resolve this problem?

Bill48105
Developer
Developer
Posts: 6186
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: can't send email, 550 Access denied - Invalid HELO name

Postby Bill48105 » 2010-07-18 19:24

Hi,
Maybe it would help to set the local host name in hmail under Settings-Protocols-smtp delivery of email tab. The controls what hmail sends with HELO that the other server doesn't seem to like.
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

yordanrhapsody
New user
New user
Posts: 26
Joined: 2010-07-18 18:40

Re: can't send email, 550 Access denied - Invalid HELO name

Postby yordanrhapsody » 2010-07-18 19:40

I tried to modify the local host name (I put the name of my domain in this case) but now I don't have any error email in return (and emails still don't go)

Bill48105
Developer
Developer
Posts: 6186
Joined: 2010-04-24 23:16
Location: Michigan, USA

Re: can't send email, 550 Access denied - Invalid HELO name

Postby Bill48105 » 2010-07-18 20:13

That means you're likely one step closer & next step would be to ensure hmail's logging & debug is enabled & try again & check the logs to see what is going on. You can post them along with the diagnostics results (under tools in GUI admin) if you'd like us to help interpret them.
Bill
hMailServer build LIVE on my servers: 5.4-B2014050402
#hmailserver on FreeNode IRC https://webchat.freenode.net/?channels=#hmailserver
*** ABSENT FROM hMail! Those in IRC know how to find me if urgent. ***

ObiWan
Senior user
Senior user
Posts: 277
Joined: 2010-07-21 14:30
Location: Halfway between Germany and Egypt

Re: can't send email, 550 Access denied - Invalid HELO name

Postby ObiWan » 2010-07-22 11:25

Bill48105 wrote:Hi,
Maybe it would help to set the local host name in hmail under Settings-Protocols-smtp delivery of email tab. The controls what hmail sends with HELO that the other server doesn't seem to like.
Bill


As a note, it would be a good idea if hMail could add an FQDN name there
right after the setup; the idea is to call the "gethostname()" to retrieve
the local host name; then, since the above call won't in general return
an FQDN name, to call "gethostbyname()" to retrieve the IP and then
the "gethostbyaddr()" which will return the FQDN PTR, this one should
then be used as the default host name


Return to “General discussions”



Who is online

Users browsing this forum: No registered users and 13 guests