XBL in addition to SBL

This forum contains features that has been archived. This section contains implemented features, duplicate requests, and requests which we have decided not to implement.
Post Reply
flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

XBL in addition to SBL

Post by flashbit » 2004-03-22 01:19

I've lately discovered that a lot of hosts sending mail amongst the spam sent on my email daily are listed on XBL list at Spamhaus but not at SBL.
In my opinion that would be the most important option in addition to SBL that I think can currently be most useful too.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 01:23

Version 3.1 will include posibility to specify a list of blacklist servers to use.. It will be possible to specify their host names..

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Great!

Post by flashbit » 2004-03-22 01:36

That's just great!
I've upgraded to 3.0.0 and it is superb. You've done a hell of the job!
Since it's alpha I'm ready for any bugs and will keep your new bugboard busy if necessary but it looks fantastic.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 01:51

Your rule ;)
Have you gotten IlohaMail to work?

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 01:58

Yes, very well. Above 10 users, all smooth. Like I told - superb.
Anyway, I'm keeping you busy, submitting a bug (or my stupidity) right now.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 02:07

I'm afraid I really don't understand the bug report. No data is written to the mysql database whatsoever? So you mean it's impossible to send email through the server?

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 02:15

No, if the mail comes in, it is written to the Data, but no actual MySQL is written into messages table and while POP3 nothing is returned in spite of the fact that theres email existing...

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 02:18

Alrite. I think I have found the problem. can you see if there is a column named messageflagseen in the hm_messages table?

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 02:22

There are following columns:
  • messageid
    messageaccountid
    messagefilename
    messagetype
    messagefrom
    messagerecipients
    messagesize
    messagecurnooftries
    messagenexttrytime
    messagerecipientsparsed
so I guess it is missing. Some db update problem right?

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 02:27

Yepp, true. Edit the file .\DBScripts\Upgrade2000to3000MySQL.sql.
There's a syntax error on the second row. There's two commas directly after eachother.

No extremly easy way to solve this. If you did a backup of the database you can fix the syntax error, restore the database and rerun the update of the db. Or you can "simply" look what the script does and make sure that all of the statements are executed.

I'll build a new version immediately, but that won't solve the problem for you since you have already run parts of the update.. :\

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 02:36

A new version is now up that solves this problem. Doesn't really understand how I could miss this since i tested it a lot of times before putting up the version.. :\

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 02:39

Still no messageflagseen in there :(
Did exactly what you told: took off the second comma, restored MySQL from bup and ran the update again.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 02:42

Hum, restore the db, install the new version and run the upgrade again and see if it helps... I have tested it myself and it worked for me in the latest version :\

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 02:51

I can't get the new version, it's still the same one. I disabled my browser's cache but still nothing. Is it up there?

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 03:03

Sorry man, it was my mistake about the db update.

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

MS Outlook 2003 POP3

Post by flashbit » 2004-03-22 03:55

Btw, I just submitted a new, Outlook 2003 POP3 problem that I just faced. Ilohamail works perfectly but Outlook gives back an error though.

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2004-03-22 13:40

Thanks a lot.
Fixed. New alpha availible.

flashbit
Normal user
Normal user
Posts: 46
Joined: 2004-02-11 01:17
Location: Estonia, Tartu
Contact:

Post by flashbit » 2004-03-22 14:18

POP3 works perfectly with Outlook now. Good job.

Post Reply