Add DNS-MX check to IP Ranges

This forum contains features that has been archived. This section contains implemented features, duplicate requests, and requests which we have decided not to implement.
Post Reply
jnolan517
New user
New user
Posts: 26
Joined: 2004-01-06 01:55

Add DNS-MX check to IP Ranges

Post by jnolan517 » 2005-02-09 19:03

Would be good to be able to add the DNS-MX check to the IP ranges in order to make the server work with various Web Mail and other notification services such as routers that send e-mail alerts etc.

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-02-10 18:54

Yes, that would probably be a good idéa.

I'm not so sure enabling the DNS-MX check is a good idéa at all as it works now. I've turned it off on my server. It sometimes stops mail I would actually want. For example, some emails have been sent from hosts as cgi.server.com. Since cgi.server.com don't have an MX host, the email is dropped.

Perhaps hMailServer should be modified so that it only checks the first part of the domain name. If someone sends from subhost.host.com, hMailServer only does a MX lookup for host.com.

User avatar
Bram
Senior user
Senior user
Posts: 417
Joined: 2004-05-24 22:57
Location: The Netherlands
Contact:

Post by Bram » 2005-02-11 10:20

I had the same problems so i also turned off DNS-MX. I think your solution will work. I will test it agian if it is changed!!
hmailserver 4.3 (242 Live)
hmailserver 5.0 (605 Test)
Windows 2003
MSSQL
ASSP 1.3.2
ClamAV (SOSDG)
http://www.realdesign.nl

User avatar
layer
Normal user
Normal user
Posts: 55
Joined: 2004-09-12 14:19
Location: Portugal

Post by layer » 2005-02-18 23:12

i think the "ip range" change is good... martin i think your idea is wrong because some people send spam from subdomains of ISP's (my ISP is one example) and the XXX.YYY.the name of isp.com and the name of isp.com is completly different IP/hostname... you will acept mail from the subdomain and "it will be" SPAM because the subdomain is not controlated by the corporation/person of the orginal webdomain...


PS: sory for by the BAD english
:oops:

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-09-02 16:40

In 4.2 you can disable Spam protection in the IP ranges settings. Moving to implemented.

Post Reply