Small problem with autoreply

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
Allegro1100
New user
New user
Posts: 18
Joined: 2006-12-06 16:43
Location: Milano, Italy

Small problem with autoreply

Post by Allegro1100 » 2007-02-20 11:04

Hi all,
in hMs 4.4 b260 , if I set a date when the auto-reply expire, *any* date, the automatic responder stops working the day after. Even if I disable the auto-expiration, the auto response not work until I disable and re-enable the autoreply for that account.
Someone found the same problem?
Ciao,

Andrea.

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-20 13:57

Do you know that the auto-reply functionality only sends one auto-reply per sender and recipient? If you send two messages to an account which have auto-reply enabled, you'll only receive one auto-reply. Could it be that your problem is related to that?

Allegro1100
New user
New user
Posts: 18
Joined: 2006-12-06 16:43
Location: Milano, Italy

Post by Allegro1100 » 2007-02-20 14:54

Thanks Martin,
yes, the problem could be related to that.
In effect, the documentation says: "hMailServer only sends one auto-reply per sender", but *per sender and per day* or *per sender and per week* or... what? :-)
How long between the first auto-answer and the next one?

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-20 19:05

It's not re-enabled until you disable and enable the auto-reply again.

Allegro1100
New user
New user
Posts: 18
Joined: 2006-12-06 16:43
Location: Milano, Italy

Post by Allegro1100 » 2007-02-20 19:26

Even if the service was stopped and restarted?

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-20 19:27

No, if the service is stopped and started, they are activated again since this information is only stored in memory.

Allegro1100
New user
New user
Posts: 18
Joined: 2006-12-06 16:43
Location: Milano, Italy

Post by Allegro1100 » 2007-02-20 19:34

Well, in short: it's not a bug, it's a feature! :-)
Thanks again Martin.
Ciao,

Andrea.

P.S. Maybe will be better to have one auto-reply per sender and per day?

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2007-02-20 19:39

Try using the search function in the forum. Would have saved this entire conversation.. :)
http://www.hmailserver.com/forum/viewtopic.php?t=2495

kdiamond
Normal user
Normal user
Posts: 94
Joined: 2013-03-20 10:51

Re: Small problem with autoreply

Post by kdiamond » 2015-02-01 01:18

Is there a way to turn this feature off ? I would nee autoreply to always to reply.

Thank you

Br,
kd

User avatar
mattg
Moderator
Moderator
Posts: 21256
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: Small problem with autoreply

Post by mattg » 2015-02-01 03:08

Sure

Use a rule, or a custom script.
(really old thread by the way)

How is your VBS?
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

percepts
Senior user
Senior user
Posts: 5282
Joined: 2009-10-20 16:33
Location: Sceptred Isle

Re: Small problem with autoreply

Post by percepts » 2015-02-01 06:04

Be warned that if two servers both have auto reply imlemented in the manner you are proposing, you could be sending each other mail at an alarming rate if you haven't coded to stop that from happening.
That is precisely the reason why the built in auto reply only auto replies to a sender once during a single hmailserver service load. The auto reply is cached so hmail knows not to do it again.

Post Reply