hMailServer 5.7

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Bodos
New user
New user
Posts: 13
Joined: 2019-01-14 16:45

Re: hMailServer 5.7

Post by Bodos » 2020-03-10 16:32

Sorry missed that out of excitement :D
Definitely give a try this weekend for our office with 5-6 users on new server that will be prepared fresh.
What is the mysql version recommended for x64 built? Stick with 5.7?

Kendo
Normal user
Normal user
Posts: 100
Joined: 2015-07-08 23:33
Location: Rural Australia

Re: hMailServer 5.7

Post by Kendo » 2020-03-10 23:16

mattg wrote:
2020-03-10 16:24
The drop down box next to the version number in the build environment shows a change log

https://build.hmailserver.com/viewType. ... eChangeLog
This link leads to a login page.

https://www.hmailserver.com/download/ shows old version links and info.

User avatar
mattg
Moderator
Moderator
Posts: 20837
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-03-10 23:29

I'm running mySQL ver5.5, but you can also use MariaDB or Microsoft's SQL Server, or PostgreSQL
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
mattg
Moderator
Moderator
Posts: 20837
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-03-26 09:47

came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 10:19

mattg wrote:
2020-03-26 09:47
came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
Looks similar as the DKIM CNAME records issue, but don't think this is the right place to report such bug, can't you better create a issue on github?

https://github.com/hmailserver/hmailser ... r.cpp#L159
https://github.com/hmailserver/hmailser ... r.cpp#L284
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 11:09

I just tried a setup like you described above, don't really had a problem sending mail out (5.7), it reported 7 ip addresses where it should report only 4

Code: Select all

"TCPIP"	3392	"2020-03-26 09:33:16.919"	"DNS MX lookup: domain.nl"
"TCPIP"	3392	"2020-03-26 09:33:17.075"	"DNS - MX Result: 7 IP addresses were found."
Is mail.otherdomain.com is also a MX record on mail.otherdomain.com or only a A-record?
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 15:53

Oops :oops:
7 mx records was right after all, 3 ip addresses (from backup mx) had a ipv6 equivalent


Weird, you didn't seem to have a issue with dkim sname's, and now I don't seem to have a issue with MX cname's....but i suspect it to be related
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
jimimaseye
Moderator
Moderator
Posts: 8580
Joined: 2011-09-08 17:48

Re: hMailServer 5.7

Post by jimimaseye » 2020-03-26 20:15

mattg wrote:
2020-03-26 09:47
came across an issue

Poorly configured dns I think

test@example.com

mx record for example.com = priority=10, mail.example.com

DNS lookup for mail.example.com shows a CNAME of mail.otherdomain.com
DNS lookup for mail.otherdomain.com points to an A record with an IP


hMailserver 5.7 logs

"APPLICATION" 7140 "2020-03-26 17:39:36.425" "SMTPDeliverer - Message 1511664: No mail servers could be found for the address test@example.com."
According typo RFC mx's should not be cname records. Even so, I don't think it should error and I already reported this in github against 5.7.
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-03-26 22:03

Funny thing is i recreated the MX DNS setup mattg described but had no issue sending email whatsoever...weird stuff is going on with 5.7 and DNS lookups :shock:
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-05-06 23:40

mattg wrote:
2019-11-04 16:23
I noticed the new builds, so I moved up to 5.7.0b2497 yesterday

Just checking my logs (to answer a post here) and I noticed something not correct.

DNS Score + HELOHost Score were lost after a positive SURBL score
This didn't happen long before, but I haven't checked logs on any 5.7

Please note that I accept all mail then delete the high score spam

Code: Select all

"TCPIP"	5552	"2019-11-04 23:51:52.872"	"TCP - 196.15.183.2 connected to 10.10.10.150:25."
"DEBUG"	5552	"2019-11-04 23:51:52.872"	"Executing event OnClientConnect"
"DEBUG"	5552	"2019-11-04 23:51:56.404"	"Event completed"
"DEBUG"	5552	"2019-11-04 23:51:56.404"	"TCP connection started for session 4690"
"SMTPD"	5552	4690	"2019-11-04 23:51:56.404"	"196.15.183.2"	"SENT: 220 example.com ESMTP"
"SMTPD"	20572	4690	"2019-11-04 23:51:57.185"	"196.15.183.2"	"RECEIVED: EHLO lundstedt.it"
"DEBUG"	20572	"2019-11-04 23:51:57.185"	"Executing event OnHELO"
"DEBUG"	20572	"2019-11-04 23:52:00.607"	"Event completed"
"SMTPD"	20572	4690	"2019-11-04 23:52:00.607"	"196.15.183.2"	"SENT: 250-example.com[nl]250-SIZE[nl]250-STARTTLS[nl]250 HELP"
"SMTPD"	20572	4690	"2019-11-04 23:52:01.810"	"196.15.183.2"	"RECEIVED: MAIL FROM: <BenjaminYoungbazrg@lundstedt.it>"
"SMTPD"	20572	4690	"2019-11-04 23:52:01.826"	"196.15.183.2"	"SENT: 250 OK"
"SMTPD"	19732	4690	"2019-11-04 23:52:02.591"	"196.15.183.2"	"RECEIVED: RCPT TO: <sales@example.com>"
"TCPIP"	19732	"2019-11-04 23:52:02.810"	"DNS lookup: 2.183.15.196.bl.spamcop.net, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:02.826"	"DNS lookup: 2.183.15.196.zen.spamhaus.org, 0 addresses found: (none), Match: False"
"TCPIP"	19732	"2019-11-04 23:52:03.279"	"DNS lookup: 2.183.15.196.b.barracudacentral.org, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:03.326"	"DNS lookup: 2.183.15.196.cbl.abuseat.org, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:03.857"	"DNS lookup: 2.183.15.196.aspews.ext.sorbs.net, 0 addresses found: (none), Match: False"
"TCPIP"	19732	"2019-11-04 23:52:03.919"	"DNS lookup: 2.183.15.196.dnsbl.sorbs.net, 2 addresses found: 127.0.0.7, 127.0.0.6, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:04.544"	"DNS lookup: 2.183.15.196.ubl.unsubscore.com, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:04.576"	"DNS lookup: 2.183.15.196.sbl.spamhaus.org, 0 addresses found: (none), Match: False"
"TCPIP"	19732	"2019-11-04 23:52:04.576"	"DNS lookup: 2.183.15.196.sbl.spamhaus.org, 0 addresses found: (none), Match: False"
"TCPIP"	19732	"2019-11-04 23:52:05.218"	"DNS lookup: 2.183.15.196.zz.countries.nerd.dk, 1 addresses found: 127.0.2.198, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:05.466"	"DNS lookup: 2.183.15.196.hostkarma.junkemailfilter.com, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:05.685"	"DNS lookup: 2.183.15.196.all.bl.blocklist.de, 0 addresses found: (none), Match: False"
"TCPIP"	19732	"2019-11-04 23:52:06.107"	"DNS lookup: 2.183.15.196.all.spamrats.com, 3 addresses found: 127.0.0.37, 127.0.0.38, 127.0.0.43, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:06.716"	"DNS lookup: 2.183.15.196.ix.dnsbl.manitu.net, 1 addresses found: 127.0.0.2, Match: False"
"TCPIP"	19732	"2019-11-04 23:52:07.216"	"DNS lookup: 2.183.15.196.dnsbl-1.uceprotect.net, 1 addresses found: 127.0.0.2, Match: True"
"TCPIP"	19732	"2019-11-04 23:52:07.513"	"DNS lookup: 2.183.15.196.torexit.dan.me.uk, 0 addresses found: (none), Match: False"
"DEBUG"	19732	"2019-11-04 23:52:07.513"	"Spam test: SpamTestDNSBlackLists, Score: 21"
"DEBUG"	19732	"2019-11-04 23:52:08.091"	"Spam test: SpamTestHeloHost, Score: 1"
"DEBUG"	19732	"2019-11-04 23:52:08.685"	"Spam test: SpamTestMXRecords, Score: 0"
"DEBUG"	19732	"2019-11-04 23:52:08.685"	"Total spam score: 22"
"SMTPD"	19732	4690	"2019-11-04 23:52:08.685"	"196.15.183.2"	"SENT: 250 OK"
"SMTPD"	19732	4690	"2019-11-04 23:52:09.435"	"196.15.183.2"	"RECEIVED: DATA"
"DEBUG"	19732	"2019-11-04 23:52:09.435"	"Executing event OnSMTPData"
"DEBUG"	19732	"2019-11-04 23:52:09.544"	"Event completed"
"SMTPD"	19732	4690	"2019-11-04 23:52:09.544"	"196.15.183.2"	"SENT: 354 OK, send."
"DEBUG"	20572	"2019-11-04 23:52:11.951"	"Could not retrieve PTR record for IP (false)! 196.15.183.2"
"DEBUG"	20572	"2019-11-04 23:52:11.951"	"Adding task AsynchronousTask to work queue Asynchronous task queue"
"DEBUG"	14904	"2019-11-04 23:52:11.951"	"Executing task AsynchronousTask in work queue Asynchronous task queue"
"DEBUG"	14904	"2019-11-04 23:52:11.951"	"SURBL: Execute"
"DEBUG"	14904	"2019-11-04 23:52:11.951"	"SURBL: Found URL: toppharmacy02.su"
"DEBUG"	14904	"2019-11-04 23:52:11.966"	"SURBL: Found URL: tildacdn.com"
"DEBUG"	14904	"2019-11-04 23:52:11.966"	"SURBL: Found URL: directupload.net"
"DEBUG"	14904	"2019-11-04 23:52:11.966"	"SURBL: Found URL: 666kb.com"
"DEBUG"	14904	"2019-11-04 23:52:11.966"	"SURBL: 4 unique addresses found."
"DEBUG"	14904	"2019-11-04 23:52:11.966"	"SURBL: Lookup: 666kb.com.multi.surbl.org"
"DEBUG"	14904	"2019-11-04 23:52:12.283"	"SURBL: Lookup: directupload.net.multi.surbl.org"
"DEBUG"	14904	"2019-11-04 23:52:12.497"	"SURBL: Lookup: tildacdn.com.multi.surbl.org"
"DEBUG"	14904	"2019-11-04 23:52:12.529"	"SURBL: Lookup: toppharmacy02.su.multi.surbl.org"
"DEBUG"	14904	"2019-11-04 23:52:12.763"	"SURBL: Match found"
"DEBUG"	14904	"2019-11-04 23:52:12.763"	"SURBL: Execute"
"DEBUG"	14904	"2019-11-04 23:52:12.763"	"SURBL: Found URL: toppharmacy02.su"
"DEBUG"	14904	"2019-11-04 23:52:12.763"	"SURBL: Found URL: tildacdn.com"
"DEBUG"	14904	"2019-11-04 23:52:12.779"	"SURBL: Found URL: directupload.net"
"DEBUG"	14904	"2019-11-04 23:52:12.779"	"SURBL: Found URL: 666kb.com"
"DEBUG"	14904	"2019-11-04 23:52:12.779"	"SURBL: 4 unique addresses found."
"DEBUG"	14904	"2019-11-04 23:52:12.779"	"SURBL: Lookup: 666kb.com.dbl.spamhaus.org"
"DEBUG"	14904	"2019-11-04 23:52:12.810"	"SURBL: Lookup: directupload.net.dbl.spamhaus.org"
"DEBUG"	14904	"2019-11-04 23:52:12.826"	"SURBL: Lookup: tildacdn.com.dbl.spamhaus.org"
"DEBUG"	14904	"2019-11-04 23:52:12.857"	"SURBL: Lookup: toppharmacy02.su.dbl.spamhaus.org"
"DEBUG"	14904	"2019-11-04 23:52:12.872"	"SURBL: Match not found"
"DEBUG"	14904	"2019-11-04 23:52:12.872"	"SURBL: Execute"
"DEBUG"	14904	"2019-11-04 23:52:12.872"	"SURBL: Found URL: toppharmacy02.su"
"DEBUG"	14904	"2019-11-04 23:52:12.872"	"SURBL: Found URL: tildacdn.com"
"DEBUG"	14904	"2019-11-04 23:52:12.888"	"SURBL: Found URL: directupload.net"
"DEBUG"	14904	"2019-11-04 23:52:12.888"	"SURBL: Found URL: 666kb.com"
"DEBUG"	14904	"2019-11-04 23:52:12.888"	"SURBL: 4 unique addresses found."
"DEBUG"	14904	"2019-11-04 23:52:12.888"	"SURBL: Lookup: 666kb.com.uribl.spameatingmonkey.net"
"DEBUG"	14904	"2019-11-04 23:52:13.279"	"SURBL: Match found"
"DEBUG"	14904	"2019-11-04 23:52:13.279"	"Spam test: SpamTestSURBL, Score: 6"
"DEBUG"	14904	"2019-11-04 23:52:13.279"	"Spam test: SpamTestDKIM, Score: 0"
"DEBUG"	14904	"2019-11-04 23:52:13.329"	"Pre-creating session 4697"
"TCPIP"	14904	"2019-11-04 23:52:13.329"	"Connecting to 10.10.10.15:783..."
"DEBUG"	20572	"2019-11-04 23:52:13.329"	"TCP connection started for session 4697"
"DEBUG"	20572	"2019-11-04 23:52:13.329"	"Sending message to SpamAssassin. Session 4697, File: c:\hMailServer\Data\{79B4BDB4-0E48-4C48-8BF4-D050F4FA1760}.eml"
"DEBUG"	18888	"2019-11-04 23:52:13.657"	"No messages to index."
"DEBUG"	11672	"2019-11-04 23:52:15.872"	"Parsing response from SpamAssassin. Session 4697"
"DEBUG"	19732	"2019-11-04 23:52:15.888"	"SA - Copy+Delete used"
"DEBUG"	19732	"2019-11-04 23:52:15.888"	"Ending session 4697"
"DEBUG"	14904	"2019-11-04 23:52:15.888"	"Spam test: SpamTestSpamAssassin, Score: 124"
"DEBUG"	14904	"2019-11-04 23:52:15.888"	"Total spam score: 130"
"DEBUG"	14904	"2019-11-04 23:52:15.904"	"Executing event OnAcceptMessage"
"DEBUG"	14904	"2019-11-04 23:52:39.576"	"Event completed"
"DEBUG"	14904	"2019-11-04 23:52:39.576"	"Saving message: {79B4BDB4-0E48-4C48-8BF4-D050F4FA1760}.eml"
"DEBUG"	14904	"2019-11-04 23:52:39.591"	"Requesting SMTPDeliveryManager to start message delivery"
"SMTPD"	14904	4690	"2019-11-04 23:52:39.591"	"196.15.183.2"	"SENT: 250 Queued (6.336 seconds)"
"DEBUG"	19732	"2019-11-04 23:52:39.591"	"The write operation failed. Bytes transferred: 0 Remote IP: 196.15.183.2, Session: 4690, Code: 10053, Message: An established connection was aborted by the software in your host machine"
"DEBUG"	11672	"2019-11-04 23:52:39.591"	"Ending session 4690"
"DEBUG"	21428	"2019-11-04 23:52:39.591"	"Adding task DeliveryTask to work queue SMTP delivery queue"
"DEBUG"	21216	"2019-11-04 23:52:39.591"	"Executing task DeliveryTask in work queue SMTP delivery queue"
"DEBUG"	21216	"2019-11-04 23:52:39.591"	"Delivering message..."
"APPLICATION"	21216	"2019-11-04 23:52:39.591"	"SMTPDeliverer - Message 1243175: Delivering message from BenjaminYoungbazrg@lundstedt.it to spam@example.com. File: c:\hMailServer\Data\{79B4BDB4-0E48-4C48-8BF4-D050F4FA1760}.eml"
"DEBUG"	21216	"2019-11-04 23:52:39.591"	"Executing event OnDeliveryStart"
"DEBUG"	21216	"2019-11-04 23:52:39.608"	"Event completed"
"DEBUG"	21216	"2019-11-04 23:52:39.608"	"Running custom virus scanner..."
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Scanner: "C:\Program Files\Windows Defender\mpcmdrun.exe" -scan -scantype 3 -file "c:\hMailServer\Data\{79B4BDB4-0E48-4C48-8BF4-D050F4FA1760}.eml" -disableremediation. Return code: 0"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rules"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule SPAM"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Spam Senders"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Delayed one hour"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Delayed one day"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Avast Virus"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Dominos_vouchers"
"DEBUG"	21216	"2019-11-04 23:52:39.904"	"Applying rule Vista Print"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule Clam Virus"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule Windows Insider"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule Backups"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule logs"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule System Parameters"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule Shadow Protect Fail"
"DEBUG"	21216	"2019-11-04 23:52:39.924"	"Applying rule Test for ZuckMail"
"DEBUG"	21216	"2019-11-04 23:52:39.935"	"Applying rule Mailer Daemon"
"DEBUG"	21216	"2019-11-04 23:52:39.935"	"Applying rule Mailer Daemon2"
"DEBUG"	21216	"2019-11-04 23:52:39.935"	"Applying rule Test header log"
"DEBUG"	21216	"2019-11-04 23:52:39.935"	"Performing rule action"
"DEBUG"	21216	"2019-11-04 23:52:39.935"	"Executing event Unknown"
"DEBUG"	21216	"2019-11-04 23:52:41.203"	"Event completed"
"DEBUG"	21216	"2019-11-04 23:52:41.203"	"Applying rule Logitech"
"DEBUG"	21216	"2019-11-04 23:52:41.203"	"Applying rule testlist@example.com"
"DEBUG"	21216	"2019-11-04 23:52:41.203"	"Applying rule test ??"
"DEBUG"	21216	"2019-11-04 23:52:41.203"	"Executing event OnDeliverMessage"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Event completed"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Performing local delivery"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Applying rules"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Applying rule Delete large score"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Performing rule action"
"DEBUG"	21216	"2019-11-04 23:52:41.232"	"Performing rule action"
"APPLICATION"	21216	"2019-11-04 23:52:41.232"	"SMTPDeliverer - Message 1243175: The message was not delivered to spam@example.com. Delivery to this account was canceled by an account rule Rule name: Delete large score, ID: 176."
"DEBUG"	21216	"2019-11-04 23:52:41.252"	"Local delivery completed"
"DEBUG"	21216	"2019-11-04 23:52:41.252"	"Deleting message"
"DEBUG"	21216	"2019-11-04 23:52:41.252"	"Deleting message file."
"APPLICATION"	21216	"2019-11-04 23:52:41.252"	"SMTPDeliverer - Message 1243175: Message delivery thread completed."
ALSO

In my hmailserver.ini I have the following lines

Code: Select all

DNSBLChecksAfterMailFrom=0
; DNSBLChecksAfterMailFrom now works. It was removed during the re-design of the spam protection but have been added again.
; By default, hMailServer runs DNS blacklists checks after SMTP/MAIL FROM.
; Some users prefer to have it running after the SMTP/RCPT TO command.
; In this case, set the value of this setting to 0.
I was under the impression that i noticed what you were seeing as well today on 5.7.x, but it seems we have 2 TotalScore values, for pre and post spam checking mechanisms, the "X-hMailServer-Reason-Score" holds the 'proper' calculated value

Code: Select all

"DEBUG"	19732	"2019-11-04 23:52:08.685"	"Total spam score: 22"
"DEBUG"	14904	"2019-11-04 23:52:15.888"	"Total spam score: 130"
The X-hMailServer-Reason-Score value for that message should read 152, but i doubt you still have that message to verify, right?
Last edited by RvdH on 2020-05-06 23:56, edited 1 time in total.
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-05-06 23:50

Code: Select all

"SMTPD"	7600	17178	"2020-05-06 07:49:44.752"	"45.148.122.113"	"SENT: 220 mydomain.com ESMTP"
"SMTPD"	7588	17178	"2020-05-06 07:49:45.018"	"45.148.122.113"	"RECEIVED: EHLO airgas.com"
"DEBUG"	7588	"2020-05-06 07:49:45.018"	"Executing event OnHELO"
"DEBUG"	7588	"2020-05-06 07:50:06.670"	"Event completed"
"SMTPD"	7588	17178	"2020-05-06 07:50:06.670"	"45.148.122.113"	"SENT: 250-mydomain.com[nl]250-SIZE 51200000[nl]250-STARTTLS[nl]250 HELP"
"SMTPD"	7592	17178	"2020-05-06 07:50:06.920"	"45.148.122.113"	"RECEIVED: MAIL FROM:<dframeayrobt@fastmail.com>"
"DEBUG"	7592	"2020-05-06 07:50:06.967"	"Spam test: SpamTestHeloHost, Score: 1"
"DEBUG"	7592	"2020-05-06 07:50:06.982"	"Spam test: SpamTestMXRecords, Score: 0"
"DEBUG"	7592	"2020-05-06 07:50:07.014"	"Spam test: SpamTestSPF, Result: Neutral"
"DEBUG"	7592	"2020-05-06 07:50:07.014"	"Spam test: SpamTestSPF, Score: 0"
"DEBUG"	7592	"2020-05-06 07:50:07.014"	"Total spam score: 1"
"SMTPD"	7592	17178	"2020-05-06 07:50:07.029"	"45.148.122.113"	"SENT: 250 OK"
"SMTPD"	7600	17178	"2020-05-06 07:50:07.280"	"45.148.122.113"	"RECEIVED: RCPT TO:<user@mydomain.com>"
"SMTPD"	7600	17178	"2020-05-06 07:50:07.296"	"45.148.122.113"	"SENT: 250 OK"
"SMTPD"	7588	17178	"2020-05-06 07:50:08.030"	"45.148.122.113"	"RECEIVED: DATA"
"DEBUG"	7588	"2020-05-06 07:50:08.030"	"Executing event OnSMTPData"
"DEBUG"	7572	"2020-05-06 07:50:10.783"	"No messages to index."
"DEBUG"	7588	"2020-05-06 07:50:29.675"	"Event completed"
"SMTPD"	7588	17178	"2020-05-06 07:50:29.675"	"45.148.122.113"	"SENT: 354 OK, send."
"DEBUG"	7600	"2020-05-06 07:50:29.971"	"Adding task AsynchronousTask to work queue Asynchronous task queue"
"DEBUG"	7440	"2020-05-06 07:50:29.971"	"Executing task AsynchronousTask in work queue Asynchronous task queue"
"DEBUG"	7440	"2020-05-06 07:50:29.987"	"Spam test: SpamTestDKIM, Score: 0"
"DEBUG"	7440	"2020-05-06 07:50:29.987"	"Pre-creating session 17180"
"TCPIP"	7440	"2020-05-06 07:50:30.003"	"Connecting to 127.0.0.1:783..."
"DEBUG"	7600	"2020-05-06 07:50:30.003"	"TCP connection started for session 17180"
"DEBUG"	7600	"2020-05-06 07:50:30.003"	"Sending message to SpamAssassin. Session 17180, File: C:\Program Files\hMailServer\Data\{A684C812-D3D1-4F2F-BAAB-FF62CA36DDC8}.eml"
"DEBUG"	7600	"2020-05-06 07:50:34.169"	"Parsing response from SpamAssassin. Session 17180"
"DEBUG"	7592	"2020-05-06 07:50:34.185"	"SA - Copy+Delete used"
"DEBUG"	7592	"2020-05-06 07:50:34.185"	"Ending session 17180"
"DEBUG"	7440	"2020-05-06 07:50:34.201"	"Spam test: SpamTestSpamAssassin, Score: 13"
"DEBUG"	7440	"2020-05-06 07:50:34.201"	"Total spam score: 13"
mail headers:

Code: Select all

X-hMailServer-Spam: YES
X-hMailServer-Reason-1: Tagged as Spam by SpamAssassin - (Score: 13)
X-hMailServer-Reason-2: The host name specified in HELO does not match IP address. - (Score: 1)
X-hMailServer-Reason-Score: 14
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

User avatar
mattg
Moderator
Moderator
Posts: 20837
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-05-07 11:16

RvdH wrote:
2020-05-06 23:40
The X-hMailServer-Reason-Score value for that message should read 152, but i doubt you still have that message to verify, right?
Unlikely
(I think it was deleted at the time)


In previous versions, I'm sure that the total spam score accumulated correctly, yes showing a total score multiple times in the logs for each message, but the first one was more of a sub-total, on the way to the final total

Having the total score shown multiple times is a bug, but not a huge one
Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-05-07 12:23

mattg wrote:
2020-05-07 11:16
RvdH wrote:
2020-05-06 23:40
The X-hMailServer-Reason-Score value for that message should read 152, but i doubt you still have that message to verify, right?
Unlikely
(I think it was deleted at the time)


In previous versions, I'm sure that the total spam score accumulated correctly, yes showing a total score multiple times in the logs for each message, but the first one was more of a sub-total, on the way to the final total

Having the total score shown multiple times is a bug, but not a huge one
I doubt it, this piece of code is identical between 5.6.x and 5.7.x
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

Fantomas
New user
New user
Posts: 27
Joined: 2006-02-07 12:37
Location: Czech rep.

Re: hMailServer 5.7

Post by Fantomas » 2020-05-18 11:56

Hey guys!
I'm running 5.7 for months without issues with one exception. For some domains hMailserver is unable to find MX records properly:

Code: Select all

DNS - MX Result: 0 IP addresses were found.
No mail servers could be found for the address []
My hMail is set to retry the delivery 5 times after 30 minutes, even though it always fails for following domains:
poliklinikapraha.cz
liska-solutions.cz
dolnykubin.sk
koroskabel.hu
cdci.hu
fanacz.cz
louda.cz
mujvyzkum.cz

My DNS servers are set to 1.1.1.1 and 4.4.4.4, tested both set as primary with no change.

I have tested DNS records for all above listed domains, nslookup always returns an MX record, but hMail doesn't find any, example here:

Code: Select all

C:\>nslookup -type=mx poliklinikapraha.cz
Server:  one.one.one.one
Address:  1.1.1.1
poliklinikapraha.cz     MX preference = 10, mail exchanger = mx.itdone.cz
At the same time using MX-query utility in hMail:

Code: Select all

"TCPIP"	7544	"2020-05-18 11:36:42.106"	"DNS MX lookup: poliklinikapraha.cz"
"TCPIP"	7544	"2020-05-18 11:36:42.162"	"DNS - MX Result: 0 IP addresses were found."
I guess my config is alright. I even tested installing hMail b2519 on another machine in different network (even country! :D ) with the same result for above mentioned domains. Could be related to what you've been talking about few posts above?
Could you please test some of the domains just to make sure it's not just me?

Thank you!
Fantomas
_________________
hMailServer 5.7 * Roundcube * ASSP 2 * ClamAV

User avatar
jimimaseye
Moderator
Moderator
Posts: 8580
Joined: 2011-09-08 17:48

Re: hMailServer 5.7

Post by jimimaseye » 2020-05-18 12:56

Fantomas wrote:
2020-05-18 11:56
Could be related to what you've been talking about few posts above?
Could you please test some of the domains just to make sure it's not just me?
You can determine this yourself. Use MXTOOLBOX.com to look up the records for those domains. If the mx record is behind a CNAME then it's likely the same issue.

[Entered by mobile. Excuse my spelling.]
5.7 on test.
SpamassassinForWindows 3.4.0 spamd service
AV: Clamwin + Clamd service + sanesecurity defs : https://www.hmailserver.com/forum/viewtopic.php?f=21&t=26829

User avatar
RvdH
Senior user
Senior user
Posts: 1076
Joined: 2008-06-27 14:42
Location: Netherlands

Re: hMailServer 5.7

Post by RvdH » 2020-05-18 13:04

@Fantomas

I see you use CNAME records for MX records, as you can read a few post back (by jimimaseye) this isn't allowed according the RFC for MX records

Code: Select all

poliklinikapraha.cz -> MX lookup: mx.itdone.cz -> CNAME -> itdone.cz
For the other domains (i didn't check them all) you have same kind of issues
CIDR to RegEx: d-fault.nl/CIDRtoRegEx
DNS Lookup: d-fault.nl/DNSTools
DNSBL Lookup: d-fault.nl/DNSBLLookup
GEOIP Lookup: d-fault.nl/GeoipLookup

mic.max
New user
New user
Posts: 28
Joined: 2009-06-16 17:01

Re: hMailServer 5.7

Post by mic.max » 2020-05-25 16:40

why removed branch 5.7.0 on build.hmailserver.com ???

User avatar
mattg
Moderator
Moderator
Posts: 20837
Joined: 2007-06-14 05:12
Location: 'The Outback' Australia

Re: hMailServer 5.7

Post by mattg » 2020-05-25 17:30

Just 'cause I link to a page and say little else doesn't mean I am not being nice.
https://www.hmailserver.com/documentation

mic.max
New user
New user
Posts: 28
Joined: 2009-06-16 17:01

Re: hMailServer 5.7

Post by mic.max » 2020-05-25 17:58

ok thanks !

Jorgo
New user
New user
Posts: 24
Joined: 2018-01-21 19:54
Location: Germany

Re: hMailServer 5.7

Post by Jorgo » 2020-05-31 18:42

Is there a way to get compiled versions, like the "artifacts" before?

Jorgo
New user
New user
Posts: 24
Joined: 2018-01-21 19:54
Location: Germany

Re: hMailServer 5.7

Post by Jorgo » 2020-05-31 19:01

Never mind, found the new artifacts hidden under actions but they weren't downloadable because I wasn't logged in.... :lol:

Post Reply