message removed from server (updated)

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
dikkertje
New user
New user
Posts: 11
Joined: 2005-09-22 18:59

message removed from server (updated)

Post by dikkertje » 2005-10-18 14:46

In my Imap folder in Outlook Express 6, there is a message which
is marked for deletion but when selecting 'permanently delete
message' it does not go away. When clicking on the message,
OE displays a message saying that it cannot retrieve the message
because it no longer exists on the server. Restarting OE and hMailServer
does not help.
What supposedly has happened is that the external pop3 account
was checked simultaneously by hMailServer (every 3 minutes) and
Outlook's internal pop3 client (on manual request). At the same time
that hMailServer retrieved the message header, OE retrieved the
message body and deleted it from the server. Admittedly, it is uncommon
to have two pop3 clients check for mail simultaneously. On the other
hand, there has to be a way to handle this kind of error.
Maybe hMailServer can create a message body with a description of
the error when it fails to retrieve a message body from the server.
Or is the blame entirely with OE?
- using build 156 standard installation winxp

UPDATE:
After the above error, I tried to backup messages using hMailAdmin,
to get an xml view of the message database. First I got a runtime error.
After rebooting my computer, which runs both hMailServer and OE,
I tried to backup again and it worked. From the xml-file I found where
the 'lost message' is stored on my computer, and then checked to
see that it was present.
As the next step, I tried the IMAP client bundled with Mozilla.
That client showed the 'lost message' as a new message, and I could
delete it from there. So OE seems to be the problem.

Dikkertje

Post Reply