hMailServer 4.0 - Build 99 (Alpha)

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

hMailServer 4.0 - Build 99 (Alpha)

Post by martin » 2005-04-13 00:28

There's a new build available:
http://dev.hmailserver.com/hMailServer-4.0-Build-99.exe

Changes since the previous build:

* IMAP: BODY[HEADER] no longer touches the contents of the header fields. This should solve problem that Japanese characters not encoded properly.

* IMAP: FETCH command now supports partial fetches. I have not found a single client that uses this, but anyway... Might be used by hand-held devices and other clients that assumes a slow network connection. (It gives the client an option to download half an email.)

* Antivirus: hMailServer now uses the --tempdir command line option when running ClamScan. This should solve the "Return value 50" problem a couple of users have reported.
Last edited by martin on 2005-04-13 12:37, edited 1 time in total.

User avatar
layer
Normal user
Normal user
Posts: 55
Joined: 2004-09-12 14:19
Location: Portugal

Post by layer » 2005-04-13 10:52

hie martin,

i have some problems whith this build and build 98 (i have upgraded from build 91 to 98 first and later to 99)
i have upgraded mysql too (4.1.11)...
the problem occur when i try to open admin (GUI), i receive a box whith a COM error "mysql: can't connect to mysql server on 'localhost' 10061", when i press OK i receive:
"run-time error '91':
object variable or blockvariable not set"
BUT i have all acess in outlook via IMAP! :?


i have another problem whith 99 build (i don't see that on 98).
when i receive some new mails in some folder (IMAP using outlook express) when i goo to the folder the new mail milagrosily turn all new mails "read", but this is random!

can u help me ??

thanks :)

PS: here he is the error log:
"ERROR" 3012 "2005-04-13 03:37:59.190" "Source: MySQLConnection::Open, Code: HM10050, Description: Open(select messageid, messagefrom, messageaccountid, messagerecipients, messagetype, messagefilename, messagesize, messagerecipientsparsed, messagecurnooftries, messageflagseen, messagecreatetime, messageflagflagged, messageflagdraft, messageflaganswered, messageflagrecent from hm_messages WHERE messagetype = 1 AND (messagenexttrytime <= CONCAT(CURDATE(), ' ', CURTIME())) and messagelocked = 0 order by messageid asc) failed. Error: Lost connection to MySQL server during query"
"ERROR" 1592 "2005-04-13 09:29:01.689" "Source: MySQLConnection::Connect, Code: HM10048, Description: Error when connecting to database. Can't connect to MySQL server on 'localhost' (10061) Run hMail Administrator and check your database settings."
"ERROR" 3324 "2005-04-13 09:35:09.167" "Source: MySQLConnection::Open, Code: HM10050, Description: Open(select messageid, messagefrom, messageaccountid, messagerecipients, messagetype, messagefilename, messagesize, messagerecipientsparsed, messagecurnooftries, messageflagseen, messagecreatetime, messageflagflagged, messageflagdraft, messageflaganswered, messageflagrecent from hm_messages WHERE messagetype = 1 AND (messagenexttrytime <= CONCAT(CURDATE(), ' ', CURTIME())) and messagelocked = 0 order by messageid asc) failed. Error: Lost connection to MySQL server during query"
"ERROR" 3336 "2005-04-13 09:35:10.148" "Source: MySQLConnection::Open, Code: HM10050, Description: Open(select * from hm_fetchaccounts WHERE (fanexttry <= CONCAT(CURDATE(), ' ', CURTIME())) and falocked = 0 and faactive = 1 order by faid asc) failed. Error: Can't connect to MySQL server on 'localhost' (10061)"
"ERROR" 1532 "2005-04-13 09:35:58.783" "Source: MySQLConnection::Connect, Code: HM10048, Description: Error when connecting to database. Can't connect to MySQL server on 'localhost' (10061) Run hMail Administrator and check your database settings."
"ERROR" 1620 "2005-04-13 09:37:34.010" "Source: MySQLConnection::Connect, Code: HM10048, Description: Error when connecting to database. Can't connect to MySQL server on 'localhost' (10061) Run hMail Administrator and check your database settings."

User avatar
martin
Developer
Developer
Posts: 6837
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Post by martin » 2005-04-13 12:22

>all new mails "read",

I've found that one. WIll be fixed in the next build.

> object variable or blockvariable not set"

If you restart the hMailServer service and then try to start hMailAdmin, does it work then?

User avatar
layer
Normal user
Normal user
Posts: 55
Joined: 2004-09-12 14:19
Location: Portugal

Post by layer » 2005-04-13 16:07

martin wrote:>all new mails "read",

I've found that one. WIll be fixed in the next build.

> object variable or blockvariable not set"

If you restart the hMailServer service and then try to start hMailAdmin, does it work then?
yes if i restart it works...

Post Reply