Error with the version 5.3-B363...

Use this forum if you want to discuss a problem or ask a question related to a hMailServer beta release.
Post Reply
User avatar
Rainer
Normal user
Normal user
Posts: 166
Joined: 2007-06-21 13:40
Location: Zweibrücken - Germany

Error with the version 5.3-B363...

Post by Rainer » 2009-10-01 08:26

Hello, the following lines are in my errog log this morning:

"ERROR" 372 "2009-10-01 07:05:43.935" "Severity: 3 (Medium), Code: HM5136, Source: TCPConnection::HandleRead, Description: An error occured while parsing data. Data length: 6, Data: RETR 5. Remote IP: 87.177.113.164"
"ERROR" 516 "2009-10-01 07:09:56.232" "Severity: 3 (Medium), Code: HM5042, Source: File::ReadTextFile, Description: An unknown error occurred while reading a text file from disk."
"ERROR" 516 "2009-10-01 07:09:56.232" "Severity: 3 (Medium), Code: HM4227, Source: File::ReadFile, Description: An unknown error occurred while reading file from disk."
"ERROR" 1824 "2009-10-01 07:20:14.185" "Severity: 3 (Medium), Code: HM5136, Source: TCPConnection::HandleRead, Description: An error occured while parsing buffer. Remote IP: 212.11.227.161"
"ERROR" 2696 "2009-10-01 07:40:20.560" "Severity: 3 (Medium), Code: HM5136, Source: TCPConnection::HandleRead, Description: An error occured while parsing buffer. Remote IP: 212.11.227.161"
"ERROR" 516 "2009-10-01 07:41:39.607" "Severity: 2 (High), Code: HM4223, Source: DeliveryTask::DoWork, Description: SMTPDeliverer::DeliverMessage() failed"
"ERROR" 372 "2009-10-01 07:44:00.607" "Severity: 2 (High), Code: HM4208, Source: IOCPQueueWorkerTask::DoWork, Description: An unknown error occured while handling asynchronous requests."
"ERROR" 4392 "2009-10-01 07:50:04.966" "Severity: 2 (High), Code: HM4208, Source: IOCPQueueWorkerTask::DoWork, Description: An unknown error occured while handling asynchronous requests."

Any ideas whats happend?

Kind regards :)
Rainer Noa

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: Error with the version 5.3-B363...

Post by martin » 2009-10-01 17:51

Was the server still running?
Did you have logging enabled?

User avatar
Rainer
Normal user
Normal user
Posts: 166
Joined: 2007-06-21 13:40
Location: Zweibrücken - Germany

Re: Error with the version 5.3-B363...

Post by Rainer » 2009-10-02 07:19

Hello Martin, no the server wont send and receive emails.
After stop und start the HMS-Service in admin-windows nothing happend.
Only a reboot of my server was the solution.

Yes, I have enabled logging, but only SMTP.

Kind regards :)
Rainer Noa

User avatar
martin
Developer
Developer
Posts: 6834
Joined: 2003-11-21 01:09
Location: Sweden
Contact:

Re: Error with the version 5.3-B363...

Post by martin » 2009-10-02 17:50

Can you send the SMTP log from the time to me at martin@hmailserver.com?

Post Reply